aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-10-24 20:07:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-10-24 20:39:19 +0200
commit400eea1a01502c95311fdddd6c2a6e7b416b860d (patch)
treee1fa1d54fde886077d382c4ac2f9dace58ea3223 /kde-plasma/plasma-firewall
parentkde-plasma/plasma-disks: 5.27.9 version bump (diff)
downloadkde-400eea1a01502c95311fdddd6c2a6e7b416b860d.tar.gz
kde-400eea1a01502c95311fdddd6c2a6e7b416b860d.tar.bz2
kde-400eea1a01502c95311fdddd6c2a6e7b416b860d.zip
kde-plasma/plasma-firewall: 5.27.9 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-firewall')
-rw-r--r--kde-plasma/plasma-firewall/Manifest1
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-5.27.9.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/kde-plasma/plasma-firewall/Manifest b/kde-plasma/plasma-firewall/Manifest
new file mode 100644
index 0000000000..fbbc4e9214
--- /dev/null
+++ b/kde-plasma/plasma-firewall/Manifest
@@ -0,0 +1 @@
+DIST plasma-firewall-5.27.9.tar.xz 363280 BLAKE2B 519e9e21aba5d779733320d4a1ab4b71a71c2b6a032c4274f99b84a8e22329b912b67f492b2cc6782ae5a185a578247ae7d5a9364a2ab3e527b0ce7400a8addb SHA512 e58f27f4823f5c01d1f447018c43cc36bdbe8055f3cade667539a09e12dc4e73b9051f104a0a5e904846ae1dabc611006276eba68462fd19d7769f5d79803734
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-5.27.9.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-5.27.9.ebuild
new file mode 100644
index 0000000000..147513260d
--- /dev/null
+++ b/kde-plasma/plasma-firewall/plasma-firewall-5.27.9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PYTHON_COMPAT=( python3_{10..12} )
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org python-single-r1
+
+DESCRIPTION="Plasma frontend for Firewalld or UFW"
+HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="firewalld +ufw"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ firewalld? ( net-firewall/firewalld )
+ ufw? ( net-firewall/ufw )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:5"
+
+src_prepare() {
+ ecm_src_prepare
+ # this kind of cmake magic doesn't work for us at all.
+ sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
+ -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
+ -DBUILD_UFW_BACKEND=$(usex ufw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}