aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-15 09:54:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-15 10:10:50 +0200
commit47fd4271a6f93deb244aa9979ece2fba52704d60 (patch)
treee8a94b3b2594d0796e4387e58bc8829a93e6b377 /media-gfx
parentmedia-gfx/kio-ps-thumbnailer: 24.07.90 version bump (diff)
downloadkde-47fd4271a6f93deb244aa9979ece2fba52704d60.tar.gz
kde-47fd4271a6f93deb244aa9979ece2fba52704d60.tar.bz2
kde-47fd4271a6f93deb244aa9979ece2fba52704d60.zip
media-gfx/kio-raw-thumbnailer: 24.07.90 version bump
Inherit KEYWORDS from kde-apps/thumbnailers. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/kio-raw-thumbnailer/Manifest1
-rw-r--r--media-gfx/kio-raw-thumbnailer/kio-raw-thumbnailer-24.07.90.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/kio-raw-thumbnailer/Manifest b/media-gfx/kio-raw-thumbnailer/Manifest
new file mode 100644
index 0000000000..118608c4d0
--- /dev/null
+++ b/media-gfx/kio-raw-thumbnailer/Manifest
@@ -0,0 +1 @@
+DIST kdegraphics-thumbnailers-24.07.90.tar.xz 48988 BLAKE2B 34a24b2b6b5f2e7f3dee80d19f160ed5c04750a82fe63a7fd654a5fc94c276f6f5e0dc368b109f5ef933072c63ecd76abc8a23856d2fac2f33c052999fe6d1ec SHA512 aea23a777ee98e0decfdf2934f1c3d109d1033a33466eeed05909be39647bd946f8b843b6cf73e19bac80bef6bc1ef110c197a78955f287d859956abbd8a71c2
diff --git a/media-gfx/kio-raw-thumbnailer/kio-raw-thumbnailer-24.07.90.ebuild b/media-gfx/kio-raw-thumbnailer/kio-raw-thumbnailer-24.07.90.ebuild
new file mode 100644
index 0000000000..369f5f4409
--- /dev/null
+++ b/media-gfx/kio-raw-thumbnailer/kio-raw-thumbnailer-24.07.90.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="KIO thumbnail generator for RAW files"
+HOMEPAGE="https://apps.kde.org/kdegraphics_thumbnailers/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=kde-apps/libkdcraw-${PVCUT}:6
+ >=kde-apps/libkexiv2-${PVCUT}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/thumbnailers-24.05.2-r1:6
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module Archive
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_blend=OFF
+ -DBUILD_ps=OFF
+ -DDISABLE_MOBIPOCKET=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_QMobipocket6=ON
+ )
+
+ ecm_src_configure
+}