summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-10-07 11:48:29 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-10-07 11:48:29 +0000
commit6b6297064601966dae0a80aa331b2113339b4a46 (patch)
treec45ce633190082f1cea0218480892085145ff3f0
parentAdded ec2-sources. (diff)
downloadkolab-6b6297064601966dae0a80aa331b2113339b4a46.tar.gz
kolab-6b6297064601966dae0a80aa331b2113339b4a46.tar.bz2
kolab-6b6297064601966dae0a80aa331b2113339b4a46.zip
Add basic ebuilds.
svn path=/overlay/; revision=2984
-rw-r--r--sys-cluster/ec2-ami-tools/ec2-ami-tools-1.3.21885.ebuild38
-rw-r--r--sys-cluster/ec2-api-tools/ec2-api-tools-1.3.24159.ebuild36
2 files changed, 74 insertions, 0 deletions
diff --git a/sys-cluster/ec2-ami-tools/ec2-ami-tools-1.3.21885.ebuild b/sys-cluster/ec2-ami-tools/ec2-ami-tools-1.3.21885.ebuild
new file mode 100644
index 0000000..962a87a
--- /dev/null
+++ b/sys-cluster/ec2-ami-tools/ec2-ami-tools-1.3.21885.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+inherit eutils
+
+PKG=${PN}-1.3-21885
+
+DESCRIPTION="Amazon EC2 AMI Tools"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${PKG}.zip"
+HOMEPAGE="http://developer.amazonwebservices.com"
+KEYWORDS="x86 amd64"
+SLOT="0"
+LICENSE="commercial"
+IUSE=""
+
+S=${WORKDIR}/${PKG}
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/ruby net-misc/rsync net-misc/curl"
+
+src_install () {
+ rm -rf ${S}/bin/*.cmd
+ dodir /opt/${P}
+ insinto /opt/${P}/lib
+ doins -r ${S}/lib/*
+ exeinto /opt/${P}/bin
+ doexe ${S}/bin/*
+ insinto /usr/bin
+ for exe in ${S}/bin/*; do
+ target="$(basename ${exe})"
+ base="$(basename ${exe})"
+ ln -s /opt/${P}/bin/${target} ${D}/usr/bin/${base}
+ done
+ insinto /opt/${P}/etc
+ doins -r ${S}/etc/*
+ dodir /etc/env.d
+ echo "EC2_AMITOOL_HOME=/opt/${P}" > ${D}/etc/env.d/99ec2-ami-tools
+}
diff --git a/sys-cluster/ec2-api-tools/ec2-api-tools-1.3.24159.ebuild b/sys-cluster/ec2-api-tools/ec2-api-tools-1.3.24159.ebuild
new file mode 100644
index 0000000..5cc453e
--- /dev/null
+++ b/sys-cluster/ec2-api-tools/ec2-api-tools-1.3.24159.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+inherit eutils
+
+PKG=${PN}-1.3-24159
+
+DESCRIPTION="Amazon EC2 API Tools"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${PKG}.zip"
+HOMEPAGE="http://developer.amazonwebservices.com"
+KEYWORDS="x86 amd64"
+SLOT="0"
+LICENSE="commercial"
+IUSE=""
+
+S=${WORKDIR}/${PKG}
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+src_install () {
+ rm -rf ${S}/bin/*.cmd
+ dodir /opt/${P}
+ insinto /opt/${P}/lib
+ doins -r ${S}/lib/*
+ exeinto /opt/${P}/bin
+ doexe ${S}/bin/*
+ insinto /usr/bin
+ for exe in ${S}/bin/*; do
+ target="$(basename ${exe})"
+ base="$(basename ${exe})"
+ ln -s /opt/${P}/bin/${target} ${D}/usr/bin/${base}
+ done
+ dodir /etc/env.d
+ echo "EC2_HOME=/opt/${P}" > ${D}/etc/env.d/99ec2-api-tools
+}