summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-08-18 14:06:20 -0400
committerMike Pagano <mpagano@gentoo.org>2018-08-18 14:06:20 -0400
commit01459b6cc0464bc9e56dcdc3a12ab8692443f456 (patch)
treeaf5393ce9de80df2246bf483131a8cd9f836b3d9
parentLinux patch 4.4.149 (diff)
downloadlinux-patches-4.4-151.tar.gz
linux-patches-4.4-151.tar.bz2
linux-patches-4.4-151.zip
Linux patch 4.4.1504.4-151
-rw-r--r--0000_README4
-rw-r--r--1149_linux-4.4.150.patch36
2 files changed, 40 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 1b036be8..4bbc43a4 100644
--- a/0000_README
+++ b/0000_README
@@ -639,6 +639,10 @@ Patch: 1148_linux-4.4.149.patch
From: http://www.kernel.org
Desc: Linux 4.4.149
+Patch: 1149_linux-4.4.150.patch
+From: http://www.kernel.org
+Desc: Linux 4.4.150
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1149_linux-4.4.150.patch b/1149_linux-4.4.150.patch
new file mode 100644
index 00000000..2446bbe3
--- /dev/null
+++ b/1149_linux-4.4.150.patch
@@ -0,0 +1,36 @@
+diff --git a/Makefile b/Makefile
+index e7c46ece5f27..7789195c6a59 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION = 4
+ PATCHLEVEL = 4
+-SUBLEVEL = 149
++SUBLEVEL = 150
+ EXTRAVERSION =
+ NAME = Blurry Fish Butt
+
+diff --git a/arch/x86/include/asm/pgtable-invert.h b/arch/x86/include/asm/pgtable-invert.h
+index 44b1203ece12..a0c1525f1b6f 100644
+--- a/arch/x86/include/asm/pgtable-invert.h
++++ b/arch/x86/include/asm/pgtable-invert.h
+@@ -4,9 +4,18 @@
+
+ #ifndef __ASSEMBLY__
+
++/*
++ * A clear pte value is special, and doesn't get inverted.
++ *
++ * Note that even users that only pass a pgprot_t (rather
++ * than a full pte) won't trigger the special zero case,
++ * because even PAGE_NONE has _PAGE_PROTNONE | _PAGE_ACCESSED
++ * set. So the all zero case really is limited to just the
++ * cleared page table entry case.
++ */
+ static inline bool __pte_needs_invert(u64 val)
+ {
+- return !(val & _PAGE_PRESENT);
++ return val && !(val & _PAGE_PRESENT);
+ }
+
+ /* Get a mask to xor with the page table entry to get the correct pfn. */