summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStelian Ionescu <sionescu@common-lisp.net>2009-02-19 13:40:09 +0100
committerStelian Ionescu <sionescu@common-lisp.net>2009-02-19 13:40:09 +0100
commit7f3f52ceb5d06194a243f8199c488c8ab319db1e (patch)
tree2303b6071f5236c2c7ddb013915f7789a9363c9b /dev-lisp/hunchentoot
parentdev-lisp/drakma: bump to version 1.0.0 (diff)
downloadlisp-7f3f52ceb5d06194a243f8199c488c8ab319db1e.tar.gz
lisp-7f3f52ceb5d06194a243f8199c488c8ab319db1e.tar.bz2
lisp-7f3f52ceb5d06194a243f8199c488c8ab319db1e.zip
dev-lisp/hunchentoot: bump to version 1.0.0
Diffstat (limited to 'dev-lisp/hunchentoot')
-rw-r--r--dev-lisp/hunchentoot/Manifest2
-rw-r--r--dev-lisp/hunchentoot/hunchentoot-1.0.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-lisp/hunchentoot/Manifest b/dev-lisp/hunchentoot/Manifest
index 36feba6c..b49ebf85 100644
--- a/dev-lisp/hunchentoot/Manifest
+++ b/dev-lisp/hunchentoot/Manifest
@@ -1,2 +1,4 @@
DIST hunchentoot-0.15.7.tar.bz2 106425 RMD160 2aa03a48e9c7dd224c340ede6e125d5c8add42a7 SHA1 422341b2521d5b9aeba70a6668414c2c40dc1583 SHA256 4d96131ab58581ffc1de4c7da930f93b2d44565eb21a47d2486b1fbcade536ac
+DIST hunchentoot-1.0.0.tar.bz2 113441 RMD160 e2423dee5e7869f020983aa06eee1bd0bec3b3e7 SHA1 f36e1c0b9c4d8afdeff1269a851d243b295f7c30 SHA256 372e5a5ebecd7beed3dd6b750efcb605546a48c0062e226818fe09462f2f42a4
EBUILD hunchentoot-0.15.7.ebuild 731 RMD160 41d4c2a4ab1c76f51ebd8c6b53dba0bff1590a70 SHA1 d95db47222bc24f7c08ae5730d68bf10e9464257 SHA256 dee2ff09b6a967dc304d7b57a029fe4076008e3b8f7091cfdfd712042d310edd
+EBUILD hunchentoot-1.0.0.ebuild 1006 RMD160 2960d77f17e8688a74f65877153576294892aacc SHA1 c4aaf421429d556b97560c3866447d868abdb2dc SHA256 2afef2b664919cd4e91cf2f08a4c5ddeb741584a5496349c863edfb965cee606
diff --git a/dev-lisp/hunchentoot/hunchentoot-1.0.0.ebuild b/dev-lisp/hunchentoot/hunchentoot-1.0.0.ebuild
new file mode 100644
index 00000000..3239a2b5
--- /dev/null
+++ b/dev-lisp/hunchentoot/hunchentoot-1.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit common-lisp-2
+
+DESCRIPTION="Hunchentoot is a web server written in Common Lisp."
+HOMEPAGE="http://weitz.de/hunchentoot/"
+SRC_URI="http://common-lisp.net/~sionescu/files/ediware/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-libs/libxslt )"
+RDEPEND="dev-lisp/md5
+ >=dev-lisp/cl-base64-3.3.0
+ dev-lisp/rfc2388
+ dev-lisp/cl-plus-ssl
+ >=dev-lisp/chunga-0.5.0
+ >=dev-lisp/cl-ppcre-2.0.0
+ >=dev-lisp/flexi-streams-0.12.0
+ dev-lisp/cl-fad
+ >=dev-lisp/usocket-0.4.0
+ dev-lisp/bordeaux-threads
+ dev-lisp/cl-who
+ >=dev-lisp/drakma-1.0.0"
+
+CLSYSTEMS="${PN} ${PN}-test"
+
+src_compile() {
+ if use doc ; then
+ cd doc
+ xsltproc clixdoc.xsl index.xml > index.html
+ fi
+}
+
+src_install() {
+ common-lisp-install *.{lisp,asd} url-rewrite/ test/*
+ common-lisp-symlink-asdf
+ dodoc CHANGELOG* README
+ use doc && dohtml -r doc/*
+}