summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2018-02-17 10:26:28 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2018-02-17 10:26:28 +0700
commit94977099663fc0279c8b214fb7f8b9293098b8b1 (patch)
tree178f1381b18591eaa5c30c158dfc556dd83c17d6
parentlyaml: supposed to be fix, but it is still brainfucking packages from @gvvaug... (diff)
downloadlua-94977099663fc0279c8b214fb7f8b9293098b8b1.tar.gz
lua-94977099663fc0279c8b214fb7f8b9293098b8b1.tar.bz2
lua-94977099663fc0279c8b214fb7f8b9293098b8b1.zip
lyaml: fixed (thanks @gvvaughan for describing the buildsystem specialities, and sorry for prev. commit msg); Although, specl buildprocess is still broken anyway (but with another reason this time)
-rw-r--r--dev-lua/lyaml/files/Makefile13
-rw-r--r--dev-lua/lyaml/lyaml-9999.ebuild10
2 files changed, 14 insertions, 9 deletions
diff --git a/dev-lua/lyaml/files/Makefile b/dev-lua/lyaml/files/Makefile
index 3667fe6..6be8e46 100644
--- a/dev-lua/lyaml/files/Makefile
+++ b/dev-lua/lyaml/files/Makefile
@@ -1,4 +1,15 @@
+CC ?= cc
+package ?= "lyaml"
+version ?= "git:HEAD"
+DEBUG ?= NDEBUG
+LUA_INCDIR ?= /usr/include/lua5.1
+CF ?= -fPIC -O2 -DPACKAGE='"$(package)"' -D$(DEBUG) -DVERSION='"$(version)"' -Iext/include -I/usr/include -I$(LUA_INCDIR) $(CFLAGS)
+LF ?= -shared -L/usr/lib64 -L/usr/lib32 -L/usr/libx32 -L/usr/lib -lyaml $(LDFLAGS)
+
+SOURCES = ext/yaml/yaml.c ext/yaml/emitter.c ext/yaml/parser.c ext/yaml/scanner.c
+SONAME = yaml.so
+
all:
- $(LUA) build-aux/luke package=$(package) version=$(version) LUA_INCDIR="$(LUA_INCDIR)" LYAML_DIR="$(LYAML_DIR)"
+ $(CC) $(CF) $(SOURCES) $(LF) -o $(SONAME)
doc:
ldoc -c build-aux/config.ld.in .
diff --git a/dev-lua/lyaml/lyaml-9999.ebuild b/dev-lua/lyaml/lyaml-9999.ebuild
index 1a35f58..5cc85c9 100644
--- a/dev-lua/lyaml/lyaml-9999.ebuild
+++ b/dev-lua/lyaml/lyaml-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
VCS="git"
GITHUB_A="gvvaughan"
-inherit autotools lua
+inherit lua
DESCRIPTION="LibYAML binding for Lua."
HOMEPAGE="https://github.com/gvvaughan/lyaml"
@@ -35,11 +35,6 @@ all_lua_prepare() {
-e '/^dir/s@../doc@../html@' \
-i build-aux/config.ld.in
- sed -r \
- -e '/^ldocs/d' \
- -e '/^external_dependencies/,/\}/s@checksymbol[^ ]*@@' \
- -i lukefile
-
cp "${FILESDIR}"/Makefile "${S}"
lua_default
@@ -54,12 +49,11 @@ each_lua_configure() {
package="${PN}"
version="${ver}"
LUA_INCDIR="$(lua_get_incdir)"
- LYAML_DIR="${EROOT}usr"
)
lua_default
}
each_lua_install() {
dolua lib/"${PN}"
- dolua linux/"${PN:1}".so
+ dolua "${PN:1}".so
}