summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2018-04-16 06:01:06 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2018-04-16 06:01:06 +0700
commiteb37a05d84673c70d09a05fcaf36c4da5e1af563 (patch)
treeaee8a3a613b765b388709e083f9ce7c2cc04786f
parentspecl: working on (diff)
downloadlua-eb37a05d84673c70d09a05fcaf36c4da5e1af563.tar.gz
lua-eb37a05d84673c70d09a05fcaf36c4da5e1af563.tar.bz2
lua-eb37a05d84673c70d09a05fcaf36c4da5e1af563.zip
lua-evdev: added
-rw-r--r--dev-lua/lua-evdev/lua-evdev-9999.ebuild54
-rw-r--r--dev-lua/lua-evdev/metadata.xml14
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-lua/lua-evdev/lua-evdev-9999.ebuild b/dev-lua/lua-evdev/lua-evdev-9999.ebuild
new file mode 100644
index 0000000..2f1392c
--- /dev/null
+++ b/dev-lua/lua-evdev/lua-evdev-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VCS="git"
+LUA_COMPAT="lua51 lua52 lua53 luajit2"
+GITHUB_A="Tangent128"
+GITHUB_A="zhangxiangxiao"
+
+inherit lua
+
+DESCRIPTION="Lua module for reading Linux input events from /dev/input/eventXX nodes"
+HOMEPAGE="https://github.com/Tangent128/lua-evdev"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=(README.md)
+EXAMPLES=(example/.)
+
+all_lua_prepare() {
+ sed -r \
+ -e '1iCC ?= gcc' \
+ -e '/^CFLAGS/s@$@ -I.@' \
+ -e 's@gcc@\$\(CC\)@g' \
+ -i Makefile
+ lua_default
+}
+
+each_lua_prepare() {
+ lua_is_jit && (
+ sed -r \
+ -e '/^CFLAGS/s@\$\(COMPAT_CFLAGS\) -I.@@' \
+ -e '/^CORE_C/s@(evdev/core.c) .*@\1@' \
+ -i Makefile
+ sed -r \
+ -e '/#include "compat53\/compat-5.3.h"/d' \
+ -i evdev/core.c
+ )
+ lua_default
+}
+
+each_lua_install() {
+ rm evdev/core.c
+ dolua evdev evdev.lua
+}
diff --git a/dev-lua/lua-evdev/metadata.xml b/dev-lua/lua-evdev/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/dev-lua/lua-evdev/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>