aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-04-13 14:24:01 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-04-13 14:24:01 -0400
commit13a404519fb31f98f98a50bd346e31a7d767fe84 (patch)
tree4ebbd9e570007466335b1e9963ae00c8c5dbbf37
parentdev-libs/elfutils: add missing patch (diff)
downloadmusl-13a404519fb31f98f98a50bd346e31a7d767fe84.tar.gz
musl-13a404519fb31f98f98a50bd346e31a7d767fe84.tar.bz2
musl-13a404519fb31f98f98a50bd346e31a7d767fe84.zip
sys-devel/gcc: address issue #233
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--sys-devel/gcc/files/8.3.0/gcc-pure64.patch25
-rw-r--r--sys-devel/gcc/gcc-8.3.0-r1.ebuild3
2 files changed, 27 insertions, 1 deletions
diff --git a/sys-devel/gcc/files/8.3.0/gcc-pure64.patch b/sys-devel/gcc/files/8.3.0/gcc-pure64.patch
new file mode 100644
index 00000000..53ea7fd1
--- /dev/null
+++ b/sys-devel/gcc/files/8.3.0/gcc-pure64.patch
@@ -0,0 +1,25 @@
+Adopted from https://git.alpinelinux.org/aports/tree/main/gcc/gcc-pure64.patch
+
+diff -Naur gcc-8.3.0.orig/gcc/config/aarch64/t-aarch64-linux gcc-8.3.0/gcc/config/aarch64/t-aarch64-linux
+--- gcc-8.3.0.orig/gcc/config/aarch64/t-aarch64-linux 2018-01-03 05:03:58.000000000 -0500
++++ gcc-8.3.0/gcc/config/aarch64/t-aarch64-linux 2019-04-13 14:07:21.580151954 -0400
+@@ -22,7 +22,7 @@
+ LIB1ASMFUNCS = _aarch64_sync_cache_range
+
+ AARCH_BE = $(if $(findstring TARGET_BIG_ENDIAN_DEFAULT=1, $(tm_defines)),_be)
+-MULTILIB_OSDIRNAMES = mabi.lp64=../lib64$(call if_multiarch,:aarch64$(AARCH_BE)-linux-gnu)
++MULTILIB_OSDIRNAMES = mabi.lp64=../lib
+ MULTIARCH_DIRNAME = $(call if_multiarch,aarch64$(AARCH_BE)-linux-gnu)
+
+ MULTILIB_OSDIRNAMES += mabi.ilp32=../libilp32$(call if_multiarch,:aarch64$(AARCH_BE)-linux-gnu_ilp32)
+diff -Naur gcc-8.3.0.orig/gcc/config/i386/t-linux64 gcc-8.3.0/gcc/config/i386/t-linux64
+--- gcc-8.3.0.orig/gcc/config/i386/t-linux64 2019-04-13 13:58:55.047489953 -0400
++++ gcc-8.3.0/gcc/config/i386/t-linux64 2019-04-13 14:09:48.131716954 -0400
+@@ -33,6 +33,6 @@
+ comma=,
+ MULTILIB_OPTIONS = $(subst $(comma),/,$(TM_MULTILIB_CONFIG))
+ MULTILIB_DIRNAMES = $(patsubst m%, %, $(subst /, ,$(MULTILIB_OPTIONS)))
+-MULTILIB_OSDIRNAMES = m64=../lib64
++MULTILIB_OSDIRNAMES = m64=../lib
+ MULTILIB_OSDIRNAMES+= m32=../lib32
+ MULTILIB_OSDIRNAMES+= mx32=../libx32
diff --git a/sys-devel/gcc/gcc-8.3.0-r1.ebuild b/sys-devel/gcc/gcc-8.3.0-r1.ebuild
index 115bd4ff..1cf74d8f 100644
--- a/sys-devel/gcc/gcc-8.3.0-r1.ebuild
+++ b/sys-devel/gcc/gcc-8.3.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
PATCH_VER="1.1"
@@ -24,5 +24,6 @@ src_prepare() {
if use elibc_musl || [[ ${CATEGORY} = cross-*-musl* ]]; then
epatch "${FILESDIR}"/6.3.0/cpu_indicator.patch
epatch "${FILESDIR}"/7.1.0/posix_memalign.patch
+ epatch "${FILESDIR}"/8.3.0/gcc-pure64.patch
fi
}