aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2021-08-06 23:06:48 -0500
committerJory Pratt <anarchy@gentoo.org>2021-08-06 23:06:48 -0500
commit3416537664fad1883a21d416225f9908b9ed8259 (patch)
tree4321f38fd44f9618fb4ed2b1fbd47e222fd4da25 /media-tv
parentsys-devel/gcc: sync with ::gentoo stable (diff)
downloadmusl-3416537664fad1883a21d416225f9908b9ed8259.tar.gz
musl-3416537664fad1883a21d416225f9908b9ed8259.tar.bz2
musl-3416537664fad1883a21d416225f9908b9ed8259.zip
media-tv/kodi: sync with ::gentoo
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/kodi/files/kodi-19.1-fmt-8.patch28
-rw-r--r--media-tv/kodi/kodi-19.1.ebuild27
2 files changed, 42 insertions, 13 deletions
diff --git a/media-tv/kodi/files/kodi-19.1-fmt-8.patch b/media-tv/kodi/files/kodi-19.1-fmt-8.patch
new file mode 100644
index 00000000..ea82d007
--- /dev/null
+++ b/media-tv/kodi/files/kodi-19.1-fmt-8.patch
@@ -0,0 +1,28 @@
+https://github.com/xbmc/xbmc/pull/19904
+
+From 18ff80a9c169fb969b75e2143d9f1f234b71a730 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Thu, 24 Jun 2021 20:41:11 -0400
+Subject: [PATCH] [utils] include fmt/xchar.h
+
+fmt 8 moved wchar/custom char overloads to xchar.h, so for fmt 8 compatibility, xchar.h must be included
+
+See https://github.com/fmtlib/fmt/commit/76ee490468212f8705a1421b4c88f8f814b2d351
+---
+ xbmc/utils/StringUtils.h | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/xbmc/utils/StringUtils.h b/xbmc/utils/StringUtils.h
+index ca6f82953d90a..2dc5c3f03af2f 100644
+--- a/xbmc/utils/StringUtils.h
++++ b/xbmc/utils/StringUtils.h
+@@ -36,6 +36,9 @@
+ #if FMT_VERSION >= 40000
+ #include <fmt/printf.h>
+ #endif
++#if FMT_VERSION >= 80000
++#include <fmt/xchar.h>
++#endif
+
+ #include "XBDateTime.h"
+ #include "utils/params_check_macros.h"
diff --git a/media-tv/kodi/kodi-19.1.ebuild b/media-tv/kodi/kodi-19.1.ebuild
index 9cbf604a..769fe1df 100644
--- a/media-tv/kodi/kodi-19.1.ebuild
+++ b/media-tv/kodi/kodi-19.1.ebuild
@@ -10,7 +10,7 @@ LIBDVDNAV_VERSION="6.0.0-Leia-Alpha-3"
FFMPEG_VERSION="4.3.2"
CODENAME="Matrix"
FFMPEG_KODI_VERSION="19.1"
-PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
SRC_URI="https://github.com/xbmc/libdvdcss/archive/${LIBDVDCSS_VERSION}.tar.gz -> libdvdcss-${LIBDVDCSS_VERSION}.tar.gz
https://github.com/xbmc/libdvdread/archive/${LIBDVDREAD_VERSION}.tar.gz -> libdvdread-${LIBDVDREAD_VERSION}.tar.gz
https://github.com/xbmc/libdvdnav/archive/${LIBDVDNAV_VERSION}.tar.gz -> libdvdnav-${LIBDVDNAV_VERSION}.tar.gz
@@ -30,7 +30,16 @@ else
S=${WORKDIR}/xbmc-${MY_PV}
fi
-inherit autotools cmake desktop flag-o-matic linux-info pax-utils python-single-r1 xdg
+PATCHES=(
+ "${FILESDIR}/${P}-fmt-8.patch"
+ "${FILESDIR}/musl/19.0/0001-add-missing-stdint.h.patch"
+ "${FILESDIR}/musl/19.0/0002-fix-fileemu.patch"
+ "${FILESDIR}/musl/19.0/0003-Use-stdint.h-defined-types-uint8_t-uint16_t-uint32_t.patch"
+ "${FILESDIR}/musl/19.0/0004-Fix-ldt-for-musl.patch"
+ "${FILESDIR}/musl/19.0/0005-Fix-fortify-sources.patch"
+)
+
+inherit autotools cmake desktop linux-info pax-utils python-single-r1 xdg
DESCRIPTION="A free and open source media-player and entertainment hub"
HOMEPAGE="https://kodi.tv/ https://kodi.wiki/"
@@ -84,8 +93,8 @@ COMMON_TARGET_DEPEND="${PYTHON_DEPS}
>=dev-libs/spdlog-1.5.0:=
dev-libs/tinyxml[stl]
$(python_gen_cond_dep '
- dev-python/pillow[${PYTHON_MULTI_USEDEP}]
- dev-python/pycryptodome[${PYTHON_MULTI_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
')
>=dev-libs/libcdio-2.1.0[cxx]
>=dev-libs/libfmt-6.1.2
@@ -190,14 +199,6 @@ In some cases Kodi needs to access multicast addresses.
Please consider enabling IP_MULTICAST under Networking options.
"
-PATCHES=(
- "${FILESDIR}/musl/19.0/0001-add-missing-stdint.h.patch"
- "${FILESDIR}/musl/19.0/0002-fix-fileemu.patch"
- "${FILESDIR}/musl/19.0/0003-Use-stdint.h-defined-types-uint8_t-uint16_t-uint32_t.patch"
- "${FILESDIR}/musl/19.0/0004-Fix-ldt-for-musl.patch"
- "${FILESDIR}/musl/19.0/0005-Fix-fortify-sources.patch"
-)
-
pkg_setup() {
check_extra_config
python-single-r1_pkg_setup
@@ -240,7 +241,7 @@ src_prepare() {
|| die
# Required to prevent addons from crashing
- use elibc_musl && append-ldflags -Wl,-z,stack-size=1048576
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
}
src_configure() {