aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2022-07-19 09:08:13 -0400
committerAnthony G. Basile <blueness@gentoo.org>2022-07-19 09:08:13 -0400
commit8d73cb6c1ebd7cc206c904cfa019f4f369ec46da (patch)
tree3c89378afbf96f31c73ddd2d3900ad8fa16cbdb4 /sys-apps
parentprofiles/package.unmask: outdated and unnecessary (diff)
downloadmusl-8d73cb6c1ebd7cc206c904cfa019f4f369ec46da.tar.gz
musl-8d73cb6c1ebd7cc206c904cfa019f4f369ec46da.tar.bz2
musl-8d73cb6c1ebd7cc206c904cfa019f4f369ec46da.zip
sys-apps/bubblewrap: in tree version 0.6.2 works
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/bubblewrap/Manifest1
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.4.1.ebuild49
-rw-r--r--sys-apps/bubblewrap/files/bubblewrap-0.3.1-missing-TEMP_FAILURE_RETRY.patch21
-rw-r--r--sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch224
-rw-r--r--sys-apps/bubblewrap/metadata.xml11
5 files changed, 0 insertions, 306 deletions
diff --git a/sys-apps/bubblewrap/Manifest b/sys-apps/bubblewrap/Manifest
deleted file mode 100644
index 7be60f2b..00000000
--- a/sys-apps/bubblewrap/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST bubblewrap-0.4.1.tar.xz 214496 BLAKE2B bdbff50cc4e28c91d83c814df7f2ee15702962d26a9316bd841b1e63bf5976c4549c88e20869e8cc236a8a0c9a065518f945c356fa7a058f8831f5b1e9d4eb0d SHA512 0ff46dc0fda2d0cffbb36cc52ff43951b30cbd835a42cc56806acbbbd827796bfadbb1cfafc84d6b47a72c031ca44abe1c377acc0cc25fe3b33e854f5f687d35
diff --git a/sys-apps/bubblewrap/bubblewrap-0.4.1.ebuild b/sys-apps/bubblewrap/bubblewrap-0.4.1.ebuild
deleted file mode 100644
index 51a815f6..00000000
--- a/sys-apps/bubblewrap/bubblewrap-0.4.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 linux-info
-
-DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
-HOMEPAGE="https://github.com/containers/bubblewrap/"
-SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
-IUSE="selinux +suid"
-
-RDEPEND="
- sys-libs/libseccomp
- sys-libs/libcap
- selinux? ( >=sys-libs/libselinux-2.1.9 )
-"
-DEPEND="${RDEPEND}
- app-text/docbook-xml-dtd:4.3
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
-"
-
-# tests require root priviledge
-RESTRICT="test"
-PATCHES=(
- "${FILESDIR}/${PN}-0.3.1-selinux-configure.patch" # bug 674312
- "${FILESDIR}/${PN}-0.3.1-missing-TEMP_FAILURE_RETRY.patch"
-)
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
- linux-info_pkg_setup
- fi
-}
-
-src_configure() {
- econf \
- $(use_enable selinux) \
- "--enable-man" \
- "--with-bash-completion-dir=$(get_bashcompdir)" \
- "--with-priv-mode=$(usex suid setuid none)"
-}
diff --git a/sys-apps/bubblewrap/files/bubblewrap-0.3.1-missing-TEMP_FAILURE_RETRY.patch b/sys-apps/bubblewrap/files/bubblewrap-0.3.1-missing-TEMP_FAILURE_RETRY.patch
deleted file mode 100644
index a5319bb4..00000000
--- a/sys-apps/bubblewrap/files/bubblewrap-0.3.1-missing-TEMP_FAILURE_RETRY.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur bubblewrap-0.3.1.orig/bubblewrap.c bubblewrap-0.3.1/bubblewrap.c
---- bubblewrap-0.3.1.orig/bubblewrap.c 2018-09-26 12:55:17.000000000 -0000
-+++ bubblewrap-0.3.1/bubblewrap.c 2019-05-11 14:02:55.475083321 -0000
-@@ -37,6 +37,7 @@
- #include "utils.h"
- #include "network.h"
- #include "bind-mount.h"
-+#include "missing.h"
-
- #ifndef CLONE_NEWCGROUP
- #define CLONE_NEWCGROUP 0x02000000 /* New cgroup namespace */
-diff -Naur bubblewrap-0.3.1.orig/missing.h bubblewrap-0.3.1/missing.h
---- bubblewrap-0.3.1.orig/missing.h 1970-01-01 00:00:00.000000000 -0000
-+++ bubblewrap-0.3.1/missing.h 2019-05-11 14:00:21.001061569 -0000
-@@ -0,0 +1,6 @@
-+# define TEMP_FAILURE_RETRY(expression) \
-+ (__extension__ \
-+ ({ long int __result; \
-+ do __result = (long int) (expression); \
-+ while (__result == -1L && errno == EINTR); \
-+ __result; }))
diff --git a/sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch b/sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch
deleted file mode 100644
index b8fad6cc..00000000
--- a/sys-apps/bubblewrap/files/bubblewrap-0.3.1-selinux-configure.patch
+++ /dev/null
@@ -1,224 +0,0 @@
-Author: Jonas Jelten <jj@sft.mx>
-
-upstream decided to ship the generated ./configure file...
-here's the updated configure script with the missing PKG_PROG_PKG_CONFIG call
-
-===================================================================
---- bubblewrap-0.3.1.orig/configure
-+++ bubblewrap-0.3.1/configure
-@@ -5224,107 +5224,6 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
-
-
-
--for ac_header in sys/capability.h
--do :
-- ac_fn_c_check_header_mongrel "$LINENO" "sys/capability.h" "ac_cv_header_sys_capability_h" "$ac_includes_default"
--if test "x$ac_cv_header_sys_capability_h" = xyes; then :
-- cat >>confdefs.h <<_ACEOF
--#define HAVE_SYS_CAPABILITY_H 1
--_ACEOF
--
--else
-- as_fn_error $? "*** POSIX caps headers not found" "$LINENO" 5
--fi
--
--done
--
--
--# Check whether --enable-man was given.
--if test "${enable_man+set}" = set; then :
-- enableval=$enable_man;
--else
-- enable_man=maybe
--fi
--
--
--if test "$enable_man" != no; then :
--
-- # Extract the first word of "xsltproc", so it can be a program name with args.
--set dummy xsltproc; ac_word=$2
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
--$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_path_XSLTPROC+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- case $XSLTPROC in
-- [\\/]* | ?:[\\/]*)
-- ac_cv_path_XSLTPROC="$XSLTPROC" # Let the user override the test with a path.
-- ;;
-- *)
-- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-- ac_cv_path_XSLTPROC="$as_dir/$ac_word$ac_exec_ext"
-- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
-- done
--IFS=$as_save_IFS
--
-- ;;
--esac
--fi
--XSLTPROC=$ac_cv_path_XSLTPROC
--if test -n "$XSLTPROC"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $XSLTPROC" >&5
--$as_echo "$XSLTPROC" >&6; }
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
--
-- if test -z "$XSLTPROC"; then :
--
-- if test "$enable_man" = yes; then :
--
-- as_fn_error $? "xsltproc is required for --enable-man" "$LINENO" 5
--
--fi
-- enable_man=no
--
--else
--
-- enable_man=yes
--
--fi
--
--fi
-- if test "$enable_man" != no; then
-- ENABLE_MAN_TRUE=
-- ENABLE_MAN_FALSE='#'
--else
-- ENABLE_MAN_TRUE='#'
-- ENABLE_MAN_FALSE=
--fi
--
--
--
--# Check whether --with-bash-completion-dir was given.
--if test "${with_bash_completion_dir+set}" = set; then :
-- withval=$with_bash_completion_dir;
--else
-- with_bash_completion_dir=yes
--fi
--
--
--if test "x$with_bash_completion_dir" = "xyes"; then
--
-
-
-
-@@ -5445,6 +5344,107 @@ $as_echo "no" >&6; }
- fi
- fi
-
-+for ac_header in sys/capability.h
-+do :
-+ ac_fn_c_check_header_mongrel "$LINENO" "sys/capability.h" "ac_cv_header_sys_capability_h" "$ac_includes_default"
-+if test "x$ac_cv_header_sys_capability_h" = xyes; then :
-+ cat >>confdefs.h <<_ACEOF
-+#define HAVE_SYS_CAPABILITY_H 1
-+_ACEOF
-+
-+else
-+ as_fn_error $? "*** POSIX caps headers not found" "$LINENO" 5
-+fi
-+
-+done
-+
-+
-+# Check whether --enable-man was given.
-+if test "${enable_man+set}" = set; then :
-+ enableval=$enable_man;
-+else
-+ enable_man=maybe
-+fi
-+
-+
-+if test "$enable_man" != no; then :
-+
-+ # Extract the first word of "xsltproc", so it can be a program name with args.
-+set dummy xsltproc; ac_word=$2
-+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-+$as_echo_n "checking for $ac_word... " >&6; }
-+if ${ac_cv_path_XSLTPROC+:} false; then :
-+ $as_echo_n "(cached) " >&6
-+else
-+ case $XSLTPROC in
-+ [\\/]* | ?:[\\/]*)
-+ ac_cv_path_XSLTPROC="$XSLTPROC" # Let the user override the test with a path.
-+ ;;
-+ *)
-+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-+for as_dir in $PATH
-+do
-+ IFS=$as_save_IFS
-+ test -z "$as_dir" && as_dir=.
-+ for ac_exec_ext in '' $ac_executable_extensions; do
-+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-+ ac_cv_path_XSLTPROC="$as_dir/$ac_word$ac_exec_ext"
-+ $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-+ break 2
-+ fi
-+done
-+ done
-+IFS=$as_save_IFS
-+
-+ ;;
-+esac
-+fi
-+XSLTPROC=$ac_cv_path_XSLTPROC
-+if test -n "$XSLTPROC"; then
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $XSLTPROC" >&5
-+$as_echo "$XSLTPROC" >&6; }
-+else
-+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-+$as_echo "no" >&6; }
-+fi
-+
-+
-+ if test -z "$XSLTPROC"; then :
-+
-+ if test "$enable_man" = yes; then :
-+
-+ as_fn_error $? "xsltproc is required for --enable-man" "$LINENO" 5
-+
-+fi
-+ enable_man=no
-+
-+else
-+
-+ enable_man=yes
-+
-+fi
-+
-+fi
-+ if test "$enable_man" != no; then
-+ ENABLE_MAN_TRUE=
-+ ENABLE_MAN_FALSE='#'
-+else
-+ ENABLE_MAN_TRUE='#'
-+ ENABLE_MAN_FALSE=
-+fi
-+
-+
-+
-+# Check whether --with-bash-completion-dir was given.
-+if test "${with_bash_completion_dir+set}" = set; then :
-+ withval=$with_bash_completion_dir;
-+else
-+ with_bash_completion_dir=yes
-+fi
-+
-+
-+if test "x$with_bash_completion_dir" = "xyes"; then
-+
- pkg_failed=no
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for BASH_COMPLETION" >&5
- $as_echo_n "checking for BASH_COMPLETION... " >&6; }
diff --git a/sys-apps/bubblewrap/metadata.xml b/sys-apps/bubblewrap/metadata.xml
deleted file mode 100644
index 29a569e6..00000000
--- a/sys-apps/bubblewrap/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <upstream>
- <remote-id type="github">projectatomic/bubblewrap</remote-id>
- </upstream>
-</pkgmetadata>