aboutsummaryrefslogtreecommitdiff
path: root/RPM
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>1998-11-26 10:18:33 +0000
committerPhil Blundell <philb@gnu.org>1998-11-26 10:18:33 +0000
commit4eec9b724304fa33423973df345353a53a0bbd6b (patch)
tree88b63bb4bd90e177d4923a3605157891703f6af5 /RPM
parentMore #include "util.h" (diff)
downloadnet-tools-4eec9b724304fa33423973df345353a53a0bbd6b.tar.gz
net-tools-4eec9b724304fa33423973df345353a53a0bbd6b.tar.bz2
net-tools-4eec9b724304fa33423973df345353a53a0bbd6b.zip
Added RPM packaging stuff.
Various small makefile tweaks. Released as 1.48
Diffstat (limited to 'RPM')
-rw-r--r--RPM/README3
-rw-r--r--RPM/net-tools-1.45-config.patch46
-rw-r--r--RPM/net-tools.spec100
3 files changed, 149 insertions, 0 deletions
diff --git a/RPM/README b/RPM/README
new file mode 100644
index 0000000..5a2f415
--- /dev/null
+++ b/RPM/README
@@ -0,0 +1,3 @@
+This directory contains some files that may be of use to people who want
+to build a net-tools RPM.
+
diff --git a/RPM/net-tools-1.45-config.patch b/RPM/net-tools-1.45-config.patch
new file mode 100644
index 0000000..2231c4a
--- /dev/null
+++ b/RPM/net-tools-1.45-config.patch
@@ -0,0 +1,46 @@
+diff -C 2 -P net-tools/config.h net-tools-new/config.h
+*** net-tools/config.h Wed Dec 31 18:00:00 1969
+--- net-tools-new/config.h Fri Feb 27 20:21:30 1998
+***************
+*** 0 ****
+--- 1,40 ----
++ /*
++ * config.h Automatically generated configuration includefile
++ *
++ * NET-TOOLS A collection of programs that form the base set of the
++ * NET-3 Networking Distribution for the LINUX operating
++ * system.
++ *
++ * DO NOT EDIT DIRECTLY
++ *
++ * Version: Generated from "config.in 1.04 (96-04-24)"
++ */
++
++ /*
++ *
++ * Protocol Families.
++ *
++ */
++ #define HAVE_AFUNIX 1
++ #define HAVE_AFINET 1
++ #define HAVE_AFINET6 0
++ #define HAVE_AFIPX 1
++ #define HAVE_AFATALK 1
++ #define HAVE_AFAX25 1
++ #define HAVE_AFNETROM 1
++
++ /*
++ *
++ * Device Hardware types.
++ *
++ */
++ #define HAVE_HWETHER 1
++ #define HAVE_HWARC 1
++ #define HAVE_HWSLIP 1
++ #define HAVE_HWPPP 1
++ #define HAVE_HWTUNNEL 1
++ #define HAVE_HWTR 1
++ #define HAVE_HWAX25 1
++ #define HAVE_HWNETROM 1
++ #define HAVE_HWFR 1
++ #define HAVE_HWSIT 0
diff --git a/RPM/net-tools.spec b/RPM/net-tools.spec
new file mode 100644
index 0000000..b3da28a
--- /dev/null
+++ b/RPM/net-tools.spec
@@ -0,0 +1,100 @@
+Summary: Basic Networking Tools
+Name: net-tools
+Version: 1.48
+Release: 1
+Copyright: GPL
+Group: Networking/Admin
+Source: http://www.tazenda.demon.co.uk/phil/net-tools/net-tools-%{version}.tar.gz
+Patch0: net-tools-1.45-config.patch
+BuildRoot: /var/tmp/%{name}-root
+
+%description
+This is a collection of the basic tools necessary for setting up networking
+on a Linux machine. It includes ifconfig, route, netstat, rarp, and
+some other minor tools.
+
+%prep
+%setup -q
+%patch0 -p1 -b .config
+
+%build
+make
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT/bin
+mkdir -p $RPM_BUILD_ROOT/sbin
+mkdir -p $RPM_BUILD_ROOT/usr/man/man1
+mkdir -p $RPM_BUILD_ROOT/usr/man/man5
+mkdir -p $RPM_BUILD_ROOT/usr/man/man8
+
+make BASEDIR=$RPM_BUILD_ROOT install
+
+( cd $RPM_BUILD_ROOT/sbin
+ strip arp ifconfig rarp route
+ cd ../bin
+ strip hostname netstat
+)
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root)
+/sbin/arp
+/sbin/ifconfig
+/sbin/rarp
+/sbin/route
+/bin/domainname
+/bin/dnsdomainname
+/bin/hostname
+/bin/netstat
+/bin/nisdomainname
+/bin/ypdomainname
+/usr/man/man[158]/*
+/usr/man/pt_BR/man[18]/*
+/usr/man/fr_FR/man[18]/*
+/usr/share/locale/*/LC_MESSAGES/net-tools.mo
+
+%changelog
+* Thu Nov 26 1998 Phil Blundell <pb@nexus.co.uk>
+- update to 1.48.
+
+* Thu Nov 12 1998 Jeff Johnson <jbj@redhat.com>
+- update to 1.47.
+
+* Wed Sep 2 1998 Jeff Johnson <jbj@redhat.com>
+- update to 1.46
+
+* Thu Jul 9 1998 Jeff Johnson <jbj@redhat.com>
+- build root
+- include ethers.5
+
+* Thu Jun 11 1998 Aron Griffis <agriffis@coat.com>
+- upgraded to 1.45
+- patched hostname.c to initialize buffer
+- patched ax25.c to use kernel headers
+
+* Fri May 01 1998 Prospector System <bugs@redhat.com>
+- translations modified for de, fr, tr
+
+* Fri Feb 27 1998 Jason Spangler <jasons@usemail.com>
+- added config patch
+
+* Fri Feb 27 1998 Jason Spangler <jasons@usemail.com>
+- changed to net-tools 1.432
+- removed old glibc 2.1 patch
+
+* Wed Oct 22 1997 Erik Troan <ewt@redhat.com>
+- added extra patches for glibc 2.1
+
+* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
+- included complete set of network protocols (some were removed for
+ initial glibc work)
+
+* Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
+- updated glibc patch for glibc 2.0.5
+
+* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
+- built against glibc
+- updated to 1.33