aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2024-01-07 02:16:30 -0500
committerSam James <sam@gentoo.org>2024-01-07 09:42:35 +0000
commit7b1c09f80b94f01f670c8d487df361b3ddfebe0c (patch)
treef543ac8a756c8842ee43e187f2c87f5d73f57415
parentnet.lo.in: replace "type" bashism with "command" (diff)
downloadnetifrc-7b1c09f80b94f01f670c8d487df361b3ddfebe0c.tar.gz
netifrc-7b1c09f80b94f01f670c8d487df361b3ddfebe0c.tar.bz2
netifrc-7b1c09f80b94f01f670c8d487df361b3ddfebe0c.zip
Remove support for treecleaned net-misc/pump0.7.8
Bug: https://bugs.gentoo.org/694314 Closes: https://bugs.gentoo.org/921538 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/netifrc/pull/51 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--doc/net.example.Linux.in7
-rw-r--r--net/Makefile2
-rw-r--r--net/dhclient.sh2
-rw-r--r--net/dhcpcd.sh2
-rw-r--r--net/pump.sh63
5 files changed, 5 insertions, 71 deletions
diff --git a/doc/net.example.Linux.in b/doc/net.example.Linux.in
index cbd81e7..84e4b1c 100644
--- a/doc/net.example.Linux.in
+++ b/doc/net.example.Linux.in
@@ -493,11 +493,10 @@
#-----------------------------------------------------------------------------
# DHCP
-# DHCP can be provided by dhclient, dhcpcd, pump or udhcpc.
+# DHCP can be provided by dhclient, dhcpcd, or udhcpc.
#
# dhclient: emerge net-misc/dhcp
# dhcpcd: emerge net-misc/dhcpcd
-# pump: emerge net-misc/pump
# udhcpc: emerge sys-apps/busybox
# If you have more than one DHCP client installed, you need to specify which
@@ -508,7 +507,6 @@
# - All clients send the current hostname to the DHCP server by default
# - dhcpcd does not daemonize when the lease time is infinite
# - udhcp-0.9.3-r3 and earlier do not support getting NTP servers
-# - pump does not support getting NIS servers
# - DHCP tends to erase any existing device information - so add
# static addresses after dhcp if you need them
# - dhclient and udhcpc can set other resolv.conf options such as "option"
@@ -524,11 +522,10 @@
# default) to 10 seconds.
#dhcpcd_eth0="-t 10"
-# dhclient, udhcpc and pump don't have many runtime options
+# dhclient and udhcpc don't have many runtime options
# You can pass options to them in a similar manner to dhcpcd though
#dhclient_eth0="..."
#udhcpc_eth0="..."
-#pump_eth0="..."
# GENERIC DHCP OPTIONS
# Set generic DHCP options like so
diff --git a/net/Makefile b/net/Makefile
index f562d15..22bd8d1 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -12,7 +12,7 @@ INC-FreeBSD= iwconfig.sh
SRCS-Linux= iwconfig.sh.in udhcpc.sh.in
INC-Linux= adsl.sh apipa.sh arping.sh bonding.sh br2684ctl.sh bridge.sh \
ccwgroup.sh clip.sh ethtool.sh iproute2.sh ifplugd.sh ip6to4.sh \
- ipppd.sh iwconfig.sh netplugd.sh pppd.sh pump.sh tuntap.sh udhcpc.sh \
+ ipppd.sh iwconfig.sh netplugd.sh pppd.sh tuntap.sh udhcpc.sh \
vlan.sh macvlan.sh ip6rd.sh firewalld.sh dummy.sh hsr.sh l2tp.sh \
iw.sh iwd.sh wireguard.sh veth.sh dhclientv6.sh qmi.sh
diff --git a/net/dhclient.sh b/net/dhclient.sh
index 6fa4a92..ce964b0 100644
--- a/net/dhclient.sh
+++ b/net/dhclient.sh
@@ -9,7 +9,7 @@ dhclient_depend()
provide dhcp
# We prefer dhclient over these
- after udhcpc pump
+ after udhcpc
}
_config_vars="$_config_vars dhcp dhcpcd"
diff --git a/net/dhcpcd.sh b/net/dhcpcd.sh
index 2493f27..e159f0a 100644
--- a/net/dhcpcd.sh
+++ b/net/dhcpcd.sh
@@ -10,7 +10,7 @@ dhcpcd_depend()
provide dhcp
# We prefer dhcpcd over these
- after udhcpc pump dhclient
+ after udhcpc dhclient
}
_config_vars="$_config_vars dhcp dhcpcd"
diff --git a/net/pump.sh b/net/pump.sh
deleted file mode 100644
index 144316f..0000000
--- a/net/pump.sh
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright (c) 2007-2008 Roy Marples <roy@marples.name>
-# Released under the 2-clause BSD license.
-# shellcheck shell=sh disable=SC1008
-
-pump_depend()
-{
- program pump
- after interface
- provide dhcp
-
- # We prefer pump over udhcpc
- after udhcpc
-}
-
-_config_vars="$_config_vars dhcp pump"
-
-pump_start()
-{
- local args= opt= opts=
-
- # Get our options
- eval opts=\$dhcp_${IFVAR}
- [ -z "${opts}" ] && opts=${dhcp}
-
- # Map some generic options to dhcpcd
- for opt in ${opts}; do
- case "${opt}" in
- nodns) args="${args} --no-dns";;
- nontp) args="${args} --no-ntp";;
- nogateway) args="${args} --no-gateway";;
- esac
- done
-
- # Add our route metric
- [ "${metric:-0}" != "0" ] && args="${args} --route-metric ${metric}"
-
- args="${args} --win-client-ident"
- args="${args} --keep-up --interface ${IFACE}"
-
- ebegin "Running pump"
- eval pump "${args}"
- eend $? || return 1
-
- _show_address
- return 0
-}
-
-pump_stop()
-{
- # We check for a pump process first as querying for status
- # causes pump to spawn a process
- start-stop-daemon --quiet --test --stop --exec pump || return 0
-
- # Check that pump is running on the interface
- if ! pump --status --interface "${IFACE}" >/dev/null 2>&1; then
- return 0
- fi
-
- # Pump always releases the lease
- ebegin "Stopping pump on ${IFACE}"
- pump --release --interface "${IFACE}"
- eend $? "Failed to stop pump"
-}