summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-01-25 01:18:59 +0100
committerUlrich Müller <ulm@gentoo.org>2022-01-25 01:18:59 +0100
commitbd1f8977651b3ea9a7a20fdd439e2f66f236a3bd (patch)
treecee679ce27c1c6a3aaa3d1f1122274483abd8dfd
parentMakefile: New dist target replaces $(TARBALL) (diff)
downloadnxml-gentoo-schemas-bd1f8977651b3ea9a7a20fdd439e2f66f236a3bd.tar.gz
nxml-gentoo-schemas-bd1f8977651b3ea9a7a20fdd439e2f66f236a3bd.tar.bz2
nxml-gentoo-schemas-bd1f8977651b3ea9a7a20fdd439e2f66f236a3bd.zip
Makefile: The devmanual now uses RELAX NG instead of DTD
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--.gitignore1
-rw-r--r--Makefile19
2 files changed, 12 insertions, 8 deletions
diff --git a/.gitignore b/.gitignore
index fb79b6a..cf60873 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
*.dtd
+*.stamp
*.tar.xz
diff --git a/Makefile b/Makefile
index acba372..57ca512 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
-DTDS = devbook.dtd glsa.dtd metadata.dtd mirrors.dtd \
- projects.dtd repositories.dtd userinfo.dtd
+DTDS = glsa.dtd metadata.dtd mirrors.dtd projects.dtd \
+ repositories.dtd userinfo.dtd
-RNCS = $(patsubst %.dtd,%.rnc,$(DTDS))
+RNCS = $(patsubst %.dtd,%.rnc,$(DTDS)) devbook.rnc
ifneq ($(PV),)
P=nxml-gentoo-schemas-$(PV)
@@ -10,7 +10,7 @@ P=nxml-gentoo-schemas-$(shell TZ=UTC date '+%Y%m%d')
endif
.PHONY: all dist clean
-.PRECIOUS: $(RNCS) $(DTDS)
+.PRECIOUS: $(RNCS)
all: $(RNCS)
@@ -18,14 +18,17 @@ dist: Makefile LICENCE schemas.xml $(RNCS)
tar -cJf $(P).tar.xz --transform='s%^%$(P)/%' $^
clean:
- rm -f *.dtd *.tar.xz
+ rm -f *.dtd *.stamp *.tar.xz
%.rnc: %.dtd
trang -I dtd -O rnc $< $@
-%.dtd:
+$(DTDS):
wget -N --no-verbose https://www.gentoo.org/dtd/$@
-devbook.dtd:
+devbook.rnc: devbook.stamp
+
+devbook.stamp:
wget -N --no-verbose \
- https://gitweb.gentoo.org/proj/devmanual.git/plain/$@
+ https://gitweb.gentoo.org/proj/devmanual.git/plain/devbook.rnc
+ touch -r devbook.rnc $@