aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-10-28 20:31:16 +0100
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-10-28 20:31:16 +0100
commitd4b2e0a027ce1c0b0d0dc7b41d31eb2902c7099e (patch)
treec8241dcb9399afe2465800980825e8c9853a9d28
parentAdd an optional never-failing pam_permit at the end of system-auth's session. (diff)
downloadpambase-d4b2e0a027ce1c0b0d0dc7b41d31eb2902c7099e.tar.gz
pambase-d4b2e0a027ce1c0b0d0dc7b41d31eb2902c7099e.tar.bz2
pambase-d4b2e0a027ce1c0b0d0dc7b41d31eb2902c7099e.zip
Add a system-services stack.
The system-services stack provides a session chain for services to have the same session settings as standard user logins. This includes limits (on Linux), temporary directories, namespaces and so on.
-rw-r--r--.gitignore1
-rw-r--r--Makefile2
-rw-r--r--system-services.in13
3 files changed, 15 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index 219a620..81b97ba 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,6 @@ system-auth
system-login
system-local-login
system-remote-login
+system-services
other
pambase-*.tar.bz2
diff --git a/Makefile b/Makefile
index 651b641..312a6fe 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@
CPP=cpp
# The pam.d file to create
-PAMD=system-auth system-login system-local-login system-remote-login other
+PAMD=system-auth system-login system-local-login system-remote-login system-services other
# command for git (the DVCS); set this to "true" to ignore GIT support
# (i.e.: in the ebuild)
diff --git a/system-services.in b/system-services.in
new file mode 100644
index 0000000..9d4aea1
--- /dev/null
+++ b/system-services.in
@@ -0,0 +1,13 @@
+#if HAVE_LIMITS
+session required pam_limits.so DEBUG
+#endif
+#if HAVE_ENV
+session required pam_env.so DEBUG
+#endif
+#if HAVE_MKTEMP
+session optional pam_mktemp.so
+#endif
+#if SUPPORT_UNIX_SESSION
+session required pam_unix.so DEBUG
+#endif
+session optional pam_permit.so