aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index c91bb64..e891d98 100644
--- a/meson.build
+++ b/meson.build
@@ -48,11 +48,9 @@ foreach x : [
'elf-hints.h',
'glob.h',
]
- x_exists = 0
if cc.has_header(x)
- x_exists = 1
+ probe_results.set('HAVE_' + x.to_upper().underscorify(), 1)
endif
- probe_results.set('HAS_' + x.to_upper().underscorify(), x_exists)
endforeach
configure_file(