summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2015-06-16 10:39:30 +1200
committerKent Fredric <kentfredric@gmail.com>2015-06-16 10:40:53 +1200
commitf022f3b9410f4dbec1bef736c280702e7b0ccb13 (patch)
tree11e213f7ab0d8298a737158f3b693bb1c123f080 /dev-perl/CGI-Cache/CGI-Cache-1.420.700.ebuild
parent[fixup] Text-SimpleTable: EAPI5, fixup deps, fixup tests (diff)
downloadperl-overlay-f022f3b9410f4dbec1bef736c280702e7b0ccb13.tar.gz
perl-overlay-f022f3b9410f4dbec1bef736c280702e7b0ccb13.tar.bz2
perl-overlay-f022f3b9410f4dbec1bef736c280702e7b0ccb13.zip
[bump] CGI-Cache-1.420.700, remove old
Package-Manager: portage-2.2.17
Diffstat (limited to 'dev-perl/CGI-Cache/CGI-Cache-1.420.700.ebuild')
-rw-r--r--dev-perl/CGI-Cache/CGI-Cache-1.420.700.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/CGI-Cache/CGI-Cache-1.420.700.ebuild b/dev-perl/CGI-Cache/CGI-Cache-1.420.700.ebuild
new file mode 100644
index 000000000..599854d27
--- /dev/null
+++ b/dev-perl/CGI-Cache/CGI-Cache-1.420.700.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+MODULE_VERSION=1.4207
+MODULE_AUTHOR=DCOPPIT
+inherit perl-module
+
+DESCRIPTION="Perl extension to help cache output of time-intensive CGI scripts"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Tie-Restore
+ virtual/perl-File-Spec
+ dev-perl/Cache-Cache
+ virtual/perl-Storable
+"
+# URI::Escape -> URI
+DEPEND="${RDEPEND}
+ dev-perl/URI
+ test? (
+ dev-perl/File-Slurp
+ virtual/perl-Test-Simple
+ dev-perl/Error
+ )
+"
+src_prepare() {
+ local PERLCODE
+ cd "${S}"
+ IFS='' read -r -d '' PERLCODE <<'CODE'
+print unless ( $. >= 12 && $. <= 13 )
+ || ( $. >= 34 && $. <= 38 )
+ || ( $. >= 44 && $. <= 47 )
+CODE
+ perl -i -nle "${PERLCODE}" Makefile.PL
+ perl-module_src_prepare
+}