summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2012-03-02 11:54:59 +1300
committerKent Fredric <kentfredric@gmail.com>2012-03-02 11:54:59 +1300
commit352fa6c97c131e589b190948a7f7c3aa345d3562 (patch)
tree642431a091d7913db879cfa5bdfd02c36bc32fc1 /dev-perl/CPAN-Reporter
parent[newversion] *CPAN-Reporter-1.200.400 (diff)
downloadperl-overlay-352fa6c97c131e589b190948a7f7c3aa345d3562.tar.gz
perl-overlay-352fa6c97c131e589b190948a7f7c3aa345d3562.tar.bz2
perl-overlay-352fa6c97c131e589b190948a7f7c3aa345d3562.zip
[newversion/patched] CPAN-Reporter-1.200.400-r1
(Portage version: 2.2.0_alpha85/git/Linux x86_64, signed Manifest commit with key 4132B87441EA24A4EB5E6DE181EC638ED7AE97A6)
Diffstat (limited to 'dev-perl/CPAN-Reporter')
-rw-r--r--dev-perl/CPAN-Reporter/CPAN-Reporter-1.200.400-r1.ebuild101
-rw-r--r--dev-perl/CPAN-Reporter/ChangeLog6
-rw-r--r--dev-perl/CPAN-Reporter/Manifest30
-rw-r--r--dev-perl/CPAN-Reporter/files/1.2004/canonpath.patch398
4 files changed, 521 insertions, 14 deletions
diff --git a/dev-perl/CPAN-Reporter/CPAN-Reporter-1.200.400-r1.ebuild b/dev-perl/CPAN-Reporter/CPAN-Reporter-1.200.400-r1.ebuild
new file mode 100644
index 000000000..9855bd433
--- /dev/null
+++ b/dev-perl/CPAN-Reporter/CPAN-Reporter-1.200.400-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=4
+MODULE_AUTHOR=DAGOLDEN
+MODULE_VERSION=1.2004
+inherit perl-module
+
+DESCRIPTION='Adds CPAN Testers reporting to CPAN.pm'
+LICENSE=" Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+PATCHES=(
+ "${FILESDIR}/${MODULE_VERSION}/canonpath.patch"
+)
+perl_meta_configure() {
+ # ExtUtils::MakeMaker 6.30 ( 6.300.0 )
+ echo \>=virtual/perl-ExtUtils-MakeMaker-6.30
+}
+perl_meta_runtime() {
+ # CPAN 1.9301 ( 1.930.100 )
+ echo \>=virtual/perl-CPAN-1.930.100
+ # CPAN::Version
+ echo virtual/perl-CPAN
+ # Capture::Tiny
+ echo dev-perl/Capture-Tiny
+ # Carp
+ # echo virtual/perl-Carp
+ # Config
+ #echo unresolved
+ # Config::Tiny 2.08 ( 2.80.0 )
+ echo \>=dev-perl/Config-Tiny-2.08
+ # Devel::Autoflush 0.04 ( 0.40.0 )
+ echo \>=dev-perl/Devel-Autoflush-0.40.0
+ # Exporter
+ echo virtual/perl-Exporter
+ # ExtUtils::MakeMaker 6.36 ( 6.360.0 )
+ echo \>=virtual/perl-ExtUtils-MakeMaker-6.36
+ # Fcntl
+ echo dev-lang/perl
+ # File::Basename
+ echo dev-lang/perl
+ # File::Find
+ echo dev-lang/perl
+ # File::Glob
+ echo dev-lang/perl
+ # File::HomeDir 0.58 ( 0.580.0 )
+ echo \>=dev-perl/File-HomeDir-0.58
+ # File::Path
+ echo virtual/perl-File-Path
+ # File::Spec 3.19 ( 3.190.0 )
+ echo \>=virtual/perl-File-Spec-3.19
+ # File::Temp 0.16 ( 0.160.0 )
+ echo \>=virtual/perl-File-Temp-0.160.0
+ # IO::File
+ echo virtual/perl-IO
+ # IPC::Cmd 0.46 ( 0.460.0 )
+ echo \>=virtual/perl-IPC-Cmd-0.460.0
+ # Parse::CPAN::Meta
+ echo virtual/perl-Parse-CPAN-Meta
+ # Probe::Perl
+ echo dev-perl/Probe-Perl
+ # Test::Reporter 1.54 ( 1.540.0 )
+ echo \>=dev-perl/Test-Reporter-1.540.0
+ # constant
+ # echo virtual/perl-constant
+ # perl 5.006 ( 5.6.0 )
+ echo \>=dev-lang/perl-5.6.0
+ # strict
+ echo dev-lang/perl
+ # vars
+ echo dev-lang/perl
+}
+perl_meta_test() {
+ # Archive::Tar 1.54 ( 1.540.0 )
+ echo \>=virtual/perl-Archive-Tar-1.54
+ # File::Copy::Recursive 0.35 ( 0.350.0 )
+ echo \>=dev-perl/File-Copy-Recursive-0.350.0
+ # File::Spec::Functions
+ echo virtual/perl-File-Spec
+ # File::pushd 0.32 ( 0.320.0 )
+ echo \>=dev-perl/File-pushd-0.320.0
+ # IO::CaptureOutput 1.03 ( 1.30.0 )
+ echo \>=dev-perl/IO-CaptureOutput-1.30.0
+ # Test::Harness
+ echo virtual/perl-Test-Harness
+ # Test::More 0.62 ( 0.620.0 )
+ echo \>=virtual/perl-Test-Simple-0.62
+ # warnings
+ echo dev-lang/perl
+}
+DEPEND="
+ $(perl_meta_configure)
+ $(perl_meta_runtime)
+ test? ( $(perl_meta_test) )
+"
+RDEPEND="
+ $(perl_meta_runtime)
+"
+SRC_TEST="do"
diff --git a/dev-perl/CPAN-Reporter/ChangeLog b/dev-perl/CPAN-Reporter/ChangeLog
index c50492b02..d7090c8ae 100644
--- a/dev-perl/CPAN-Reporter/ChangeLog
+++ b/dev-perl/CPAN-Reporter/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*CPAN-Reporter-1.200.400-r1 (01 Mar 2012)
+
+ 01 Mar 2012; Kent Fredric <kentfredric@gmail.com>
+ +files/1.2004/canonpath.patch, +CPAN-Reporter-1.200.400-r1.ebuild:
+ Add a patched version fixed to let tests pass
+
*CPAN-Reporter-1.200.400 (01 Mar 2012)
01 Mar 2012; Kent Fredric <kentfredric@gmail.com>
diff --git a/dev-perl/CPAN-Reporter/Manifest b/dev-perl/CPAN-Reporter/Manifest
index 4603927c1..00b87eba8 100644
--- a/dev-perl/CPAN-Reporter/Manifest
+++ b/dev-perl/CPAN-Reporter/Manifest
@@ -1,6 +1,7 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256
+AUX 1.2004/canonpath.patch 12455 RMD160 419128c61695bdda2814890500fbbf2907e90f60 SHA1 6897720057c793cd27533d641930f86f846ad314 SHA256 4610044cc0e86cd014c18ef274b611810d1d7368db64e07bff16882830bd711d
DIST CPAN-Reporter-1.1708.tar.gz 123146 RMD160 e98e0b3582cb9322d439a9277fdf7988953eeaed SHA1 1c5fc36870711d6461750badc64c8d8c0fd5a0b6 SHA256 c57dd6808444c556d01f4bd4ee6d825a25d8b47add66db8a46bddb592285b0ec
DIST CPAN-Reporter-1.1711.tar.gz 125526 RMD160 36f509a5ce9be08adece129e205b346f099c1843 SHA1 52fc555586273551f2cc049800e1c28a8286938d SHA256 ac5b99e26fc85a7c3046a239287746ef7bd47b12cc96090566df97da553bf7b9
DIST CPAN-Reporter-1.1800.tar.gz 125855 RMD160 f533646b3ede3bdc8756d605c8a4cd1abca8d813 SHA1 6fb12c10281a37a1f1f3d0f760de5d274ff78aa4 SHA256 4a72ea0fa7f1b7910cbf4d84bd4a1ac62b19de530473309907c233ef3515290d
@@ -20,23 +21,24 @@ EBUILD CPAN-Reporter-1.200.0.ebuild 1306 RMD160 5b2285ba19ccbe7c43ae3d4da30dd71c
EBUILD CPAN-Reporter-1.200.100.ebuild 1308 RMD160 cf43ef0794890557f32c38a776e375491eb0514a SHA1 d7c79c6e4bfe3627516edacc4b20e5452d8aa346 SHA256 8c1fbbace6b4af2567c3565987415b108f29a89a72908be03d5fa763796de68d
EBUILD CPAN-Reporter-1.200.200.ebuild 1308 RMD160 b45a35acb05d9821617e87f3a904576f743cdc4a SHA1 d183f797146da3a4c1ca08e778c0d25c2c691351 SHA256 14d9f99b38082fc698fde1b5c94b92adb71d2aa1b036c35134d6f9fe7a07c69c
EBUILD CPAN-Reporter-1.200.300.ebuild 2417 RMD160 191d52cfacf7bec8992ef6bebac72f32705abc7a SHA1 481db7ec6f96cdd8de9862c01f705e530e79ad73 SHA256 61cf2e80a198eba99ca08335feebf341dfc940e41a0dd11bead26a94e2aea2c2
+EBUILD CPAN-Reporter-1.200.400-r1.ebuild 2474 RMD160 2b5716afc493d1a36068531aaf9eb0e59f68be6a SHA1 773173f1d5ce36395e7d4cea29c771069c6807c5 SHA256 44cfe7ed53012784c9adc4854b04741ab298709a403191280cbd0aa8d9f29702
EBUILD CPAN-Reporter-1.200.400.ebuild 2417 RMD160 1124c5c03188592ee92844b48ac0241a51f30619 SHA1 280ea69841b9145c8890b99be35ffd26ef366239 SHA256 78c0058e54884fd888ba811484da96eb107b2d5e458267d886996aad0f20a4b8
-MISC ChangeLog 2620 RMD160 2f4b9ae37180a1aeeabdabc3e3afb3c15f411b0d SHA1 e3ad6949725d89f79e97b3fc09619aee07a12383 SHA256 9548d9a675e6b9b132550ebf839784c816ebe6873ba6fd66e66b098d62d69f88
+MISC ChangeLog 2833 RMD160 d157bbeab608150f60ea191e31ce30ff20afc2d1 SHA1 f3d04b070414b9089f19f8905ad80a7fba807af5 SHA256 ab807a8524a40666463a341b4aadd91407df31cbbbae5ce4dd2e7ca69457e9b6
MISC metadata.xml 364 RMD160 e32afd8ec977ac32529ad18dd1a72b47eb8e7826 SHA1 0d56a66a6bb31b3d55b7aa0b129b0b2fad3ea927 SHA256 596e449024c292919f83edb92e921e02170ce14622ed1673ad4205e194d47d76
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.18 (GNU/Linux)
-iQIcBAEBCAAGBQJPT/qFAAoJEE321xbMTOIUphwQAJYOUCtQ8HJg3VgOYZ9oDrra
-RhsRWiEh6WNY1Y2aLM9weK2EBi4KqNuYVHJ8L+CnLcLEYtBlaC2gYiSMXfCrzq+D
-PaO0+HJpwmv2vp+S1Vi/NrHIWuRhsjg6AmeFVGscDToh087jh23a3al1XlYEGRsE
-51STmLK2Gjtb2ciKanTeroCpb6Q7LkU2bVnyrjbBb0nNet5oaf3oSPU/+zHBihqG
-fRpINLQriw7xyRgiM7WYx8Owdb6YeShC6wRpOUSGJgVMVEP3uFqn3hT6RqZEmLq1
-W2o6b0TZ95roMRRX+VemsoGxYLJlr9uIUXHNy8GuOH2Mss1ND3Z0mMGdhgCfHQoN
-Qb6km08frHKGf6kJuupZZiOnoClsIC1Kfmvow4RGhmAU1HlCp/2g8uZkT6AGMQE/
-ujm29Vqvdxu0y7AiXWqDhpU+3lRfdDiSFX2nT0Y/XRqbkhG8sURssbq2zfaOju+W
-f1jplJLZ+6PSmuHziONqQOBrqld1e56miDZAdNSo6A15GkiV4kfVVaHix/HXejTv
-C8mrCXm1FDEShmrsym7qmHL9gVU6ilnNuemoG1sf3+FYVNwazvAYhdQY+K0S5wRv
-+3Mtu6DIdjBzse9iQu3Hx+SLMvaUc2aNzeghI7KnYbA78S9ebD8+mS3tXY3kSte4
-cCsNtT1eLFqv4q3r8Gbo
-=Kmbt
+iQIcBAEBCAAGBQJPT/5DAAoJEE321xbMTOIUCvIQAMKpIMnZv0N1zU3rhV/gSl0E
+2LCbqy+2jrlsTaxxTySakRXNHUGBqYqr9V55qwZ3B/cU8I/bVr2UKDb+yTNnSCLv
+eiW3lRL20ZG0fELqarUl0HyzbzJhwbgrh4EtAnr7piVAWZa+essBFkXqmZprzsgk
+mJhagDR4N7jfbgKg3R+zvA8KgxYE9bb9LQzs+k8g0MNbdeVhwH6e4M2j3fGb8TDi
+162wRaksgISboFko0jOriyDTYnaRI6GgYSNbFR8lP3IttvURsDC1VZgCJ6XNm7kG
+vgb/C1vhHH669yhaaaCDkX30pZfaire0z6qC25ow4OGSwt0tlIjuOtnu8oxHfJYx
+Y1fGHzgWfKeY9AH/dnflbf9i4EExx6g/UQGxPOauYvfVCfmd/D+UZEE2oM+l7pRB
+y5PI6EbBp+90aEwCzgloekU6r1d4x9Gxy7YgYtiCnMZmmD2V0w5K1jW7XqdmHpwE
+9OO7OXzpqFIpfppEHwTayJ1wHGZULxFCRquBEDYdd/bzFJ9PGWrGXkTqC8c5arhD
+glOEoT3Ccdvnp7jM0hUBs/6OXXZG3CO9mJaAEfh2dzcY7x1QLrL2dVQr9K/rHaiE
+tFmsE0YQdcjdiSEVbxx2WMbwRxUAKxjCe0xOPj0yIYtrYoUMqUoxbMsFFwLlQsSN
+kPhdGBn2PSrIfGCgtpyg
+=yR+G
-----END PGP SIGNATURE-----
diff --git a/dev-perl/CPAN-Reporter/files/1.2004/canonpath.patch b/dev-perl/CPAN-Reporter/files/1.2004/canonpath.patch
new file mode 100644
index 000000000..ed4846ed3
--- /dev/null
+++ b/dev-perl/CPAN-Reporter/files/1.2004/canonpath.patch
@@ -0,0 +1,398 @@
+diff -Naur CPAN-Reporter-1.2004/Changes CPAN-Reporter-1.2004_01/Changes
+--- CPAN-Reporter-1.2004/Changes 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/Changes 2012-03-02 11:33:56.888329313 +1300
+@@ -1,5 +1,7 @@
+ Revision history for Perl module CPAN::Reporter
+
++1.2004_01 2012-03-02 11:33:41 Pacific/Auckland
++
+ 1.2004 2012-02-13 16:25:07 EST5EDT
+
+ [BUG FIXES]
+diff -Naur CPAN-Reporter-1.2004/lib/CPAN/Reporter/API.pm CPAN-Reporter-1.2004_01/lib/CPAN/Reporter/API.pm
+--- CPAN-Reporter-1.2004/lib/CPAN/Reporter/API.pm 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/lib/CPAN/Reporter/API.pm 2012-03-02 11:33:56.919329455 +1300
+@@ -1,6 +1,6 @@
+ use strict; # make CPANTS happy
+ package CPAN::Reporter::API;
+-our $VERSION = '1.2004'; # VERSION
++our $VERSION = '1.2004_01'; # VERSION
+
+ 1;
+
+@@ -16,7 +16,7 @@
+
+ =head1 VERSION
+
+-version 1.2004
++version 1.2004_01
+
+ =head1 FUNCTIONS
+
+diff -Naur CPAN-Reporter-1.2004/lib/CPAN/Reporter/Config.pm CPAN-Reporter-1.2004_01/lib/CPAN/Reporter/Config.pm
+--- CPAN-Reporter-1.2004/lib/CPAN/Reporter/Config.pm 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/lib/CPAN/Reporter/Config.pm 2012-03-02 11:33:56.921329464 +1300
+@@ -1,6 +1,6 @@
+ use strict;
+ package CPAN::Reporter::Config;
+-our $VERSION = '1.2004'; # VERSION
++our $VERSION = '1.2004_01'; # VERSION
+
+ use Config::Tiny 2.08 ();
+ use File::Glob ();
+@@ -457,7 +457,7 @@
+ $id_file = File::Spec->catdir(File::HomeDir->my_home, $1);
+ }
+ elsif ( $id_file =~ /~/ ) {
+- $id_file = File::Glob::bsd_glob( $id_file );
++ $id_file = File::Spec->canonpath(File::Glob::bsd_glob( $id_file ));
+ }
+ unless ( File::Spec->file_name_is_absolute( $id_file ) ) {
+ $id_file = File::Spec->catfile(
+@@ -661,7 +661,7 @@
+
+ =head1 VERSION
+
+-version 1.2004
++version 1.2004_01
+
+ =head1 SYNOPSIS
+
+diff -Naur CPAN-Reporter-1.2004/lib/CPAN/Reporter/FAQ.pm CPAN-Reporter-1.2004_01/lib/CPAN/Reporter/FAQ.pm
+--- CPAN-Reporter-1.2004/lib/CPAN/Reporter/FAQ.pm 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/lib/CPAN/Reporter/FAQ.pm 2012-03-02 11:33:56.920329460 +1300
+@@ -1,6 +1,6 @@
+ use strict; # make CPANTS happy
+ package CPAN::Reporter::FAQ;
+-our $VERSION = '1.2004'; # VERSION
++our $VERSION = '1.2004_01'; # VERSION
+
+ 1;
+
+@@ -16,7 +16,7 @@
+
+ =head1 VERSION
+
+-version 1.2004
++version 1.2004_01
+
+ =head1 REPORT GRADES
+
+diff -Naur CPAN-Reporter-1.2004/lib/CPAN/Reporter/History.pm CPAN-Reporter-1.2004_01/lib/CPAN/Reporter/History.pm
+--- CPAN-Reporter-1.2004/lib/CPAN/Reporter/History.pm 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/lib/CPAN/Reporter/History.pm 2012-03-02 11:33:56.920329460 +1300
+@@ -1,6 +1,6 @@
+ use strict;
+ package CPAN::Reporter::History;
+-our $VERSION = '1.2004'; # VERSION
++our $VERSION = '1.2004_01'; # VERSION
+
+ use vars qw/@ISA @EXPORT_OK/;
+
+@@ -320,7 +320,7 @@
+
+ =head1 VERSION
+
+-version 1.2004
++version 1.2004_01
+
+ =head1 SYNOPSIS
+
+diff -Naur CPAN-Reporter-1.2004/lib/CPAN/Reporter/PrereqCheck.pm CPAN-Reporter-1.2004_01/lib/CPAN/Reporter/PrereqCheck.pm
+--- CPAN-Reporter-1.2004/lib/CPAN/Reporter/PrereqCheck.pm 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/lib/CPAN/Reporter/PrereqCheck.pm 2012-03-02 11:33:56.919329455 +1300
+@@ -1,6 +1,6 @@
+ use strict;
+ package CPAN::Reporter::PrereqCheck;
+-our $VERSION = '1.2004'; # VERSION
++our $VERSION = '1.2004_01'; # VERSION
+
+ use ExtUtils::MakeMaker 6.36;
+ use File::Spec;
+@@ -128,7 +128,7 @@
+
+ =head1 VERSION
+
+-version 1.2004
++version 1.2004_01
+
+ =head1 SYNOPSIS
+
+diff -Naur CPAN-Reporter-1.2004/lib/CPAN/Reporter.pm CPAN-Reporter-1.2004_01/lib/CPAN/Reporter.pm
+--- CPAN-Reporter-1.2004/lib/CPAN/Reporter.pm 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/lib/CPAN/Reporter.pm 2012-03-02 11:33:56.918329450 +1300
+@@ -1,6 +1,6 @@
+ use strict;
+ package CPAN::Reporter;
+-our $VERSION = '1.2004'; # VERSION
++our $VERSION = '1.2004_01'; # VERSION
+
+ use Config;
+ use Capture::Tiny qw/ capture tee_merged /;
+@@ -1480,7 +1480,7 @@
+
+ =head1 VERSION
+
+-version 1.2004
++version 1.2004_01
+
+ =head1 SYNOPSIS
+
+@@ -1683,7 +1683,7 @@
+
+ =back
+
+-=for :stopwords cpan testmatrix url annocpan anno bugtracker rt cpants kwalitee diff irc mailto metadata placeholders
++=for :stopwords cpan testmatrix url annocpan anno bugtracker rt cpants kwalitee diff irc mailto metadata placeholders metacpan
+
+ =head1 SUPPORT
+
+@@ -1698,9 +1698,9 @@
+ This is open source software. The code repository is available for
+ public review and contribution under the terms of the license.
+
+-L<https://github.com/dagolden/cpan-reporter>
++L<https://github.com/kentfredric/cpan-reporter>
+
+- git clone https://github.com/dagolden/cpan-reporter.git
++ git clone https://github.com/kentfredric/cpan-reporter.git
+
+ =head1 AUTHOR
+
+diff -Naur CPAN-Reporter-1.2004/Makefile.PL CPAN-Reporter-1.2004_01/Makefile.PL
+--- CPAN-Reporter-1.2004/Makefile.PL 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/Makefile.PL 2012-03-02 11:33:56.937329537 +1300
+@@ -55,7 +55,7 @@
+ "strict" => 0,
+ "vars" => 0
+ },
+- "VERSION" => "1.2004",
++ "VERSION" => "1.2004_01",
+ "test" => {
+ "TESTS" => "t/*.t"
+ }
+diff -Naur CPAN-Reporter-1.2004/META.json CPAN-Reporter-1.2004_01/META.json
+--- CPAN-Reporter-1.2004/META.json 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/META.json 2012-03-02 11:33:56.936329533 +1300
+@@ -4,7 +4,7 @@
+ "David Golden <dagolden@cpan.org>"
+ ],
+ "dynamic_config" : 0,
+- "generated_by" : "Dist::Zilla version 4.300005, CPAN::Meta::Converter version 2.112621",
++ "generated_by" : "Dist::Zilla version 4.300009, CPAN::Meta::Converter version 2.120530",
+ "license" : [
+ "apache_2_0"
+ ],
+@@ -33,85 +33,85 @@
+ "runtime" : {
+ "requires" : {
+ "CPAN" : "1.9301",
+- "CPAN::Version" : 0,
+- "Capture::Tiny" : 0,
+- "Carp" : 0,
+- "Config" : 0,
++ "CPAN::Version" : "0",
++ "Capture::Tiny" : "0",
++ "Carp" : "0",
++ "Config" : "0",
+ "Config::Tiny" : "2.08",
+ "Devel::Autoflush" : "0.04",
+- "Exporter" : 0,
++ "Exporter" : "0",
+ "ExtUtils::MakeMaker" : "6.36",
+- "Fcntl" : 0,
+- "File::Basename" : 0,
+- "File::Find" : 0,
+- "File::Glob" : 0,
++ "Fcntl" : "0",
++ "File::Basename" : "0",
++ "File::Find" : "0",
++ "File::Glob" : "0",
+ "File::HomeDir" : "0.58",
+- "File::Path" : 0,
++ "File::Path" : "0",
+ "File::Spec" : "3.19",
+ "File::Temp" : "0.16",
+- "IO::File" : 0,
++ "IO::File" : "0",
+ "IPC::Cmd" : "0.46",
+- "Parse::CPAN::Meta" : 0,
+- "Probe::Perl" : 0,
++ "Parse::CPAN::Meta" : "0",
++ "Probe::Perl" : "0",
+ "Test::Reporter" : "1.54",
+- "constant" : 0,
++ "constant" : "0",
+ "perl" : "5.006",
+- "strict" : 0,
+- "vars" : 0
++ "strict" : "0",
++ "vars" : "0"
+ }
+ },
+ "test" : {
+ "requires" : {
+ "Archive::Tar" : "1.54",
+ "File::Copy::Recursive" : "0.35",
+- "File::Spec::Functions" : 0,
++ "File::Spec::Functions" : "0",
+ "File::pushd" : "0.32",
+ "IO::CaptureOutput" : "1.03",
+- "Test::Harness" : 0,
++ "Test::Harness" : "0",
+ "Test::More" : "0.62",
+- "warnings" : 0
++ "warnings" : "0"
+ }
+ }
+ },
+ "provides" : {
+ "CPAN::Reporter" : {
+ "file" : "lib/CPAN/Reporter.pm",
+- "version" : "1.2004"
++ "version" : "1.2004_01"
+ },
+ "CPAN::Reporter::API" : {
+ "file" : "lib/CPAN/Reporter/API.pm",
+- "version" : "1.2004"
++ "version" : "1.2004_01"
+ },
+ "CPAN::Reporter::Config" : {
+ "file" : "lib/CPAN/Reporter/Config.pm",
+- "version" : "1.2004"
++ "version" : "1.2004_01"
+ },
+ "CPAN::Reporter::FAQ" : {
+ "file" : "lib/CPAN/Reporter/FAQ.pm",
+- "version" : "1.2004"
++ "version" : "1.2004_01"
+ },
+ "CPAN::Reporter::History" : {
+ "file" : "lib/CPAN/Reporter/History.pm",
+- "version" : "1.2004"
++ "version" : "1.2004_01"
+ },
+ "CPAN::Reporter::PrereqCheck" : {
+ "file" : "lib/CPAN/Reporter/PrereqCheck.pm",
+- "version" : "1.2004"
++ "version" : "1.2004_01"
+ }
+ },
+- "release_status" : "stable",
++ "release_status" : "testing",
+ "resources" : {
+ "bugtracker" : {
+ "mailto" : "bug-cpan-reporter at rt.cpan.org",
+ "web" : "http://rt.cpan.org/Public/Dist/Display.html?Name=CPAN-Reporter"
+ },
+- "homepage" : "https://github.com/dagolden/cpan-reporter",
++ "homepage" : "https://github.com/kentfredric/cpan-reporter",
+ "repository" : {
+ "type" : "git",
+- "url" : "https://github.com/dagolden/cpan-reporter.git",
+- "web" : "https://github.com/dagolden/cpan-reporter"
++ "url" : "https://github.com/kentfredric/cpan-reporter.git",
++ "web" : "https://github.com/kentfredric/cpan-reporter"
+ }
+ },
+- "version" : "1.2004"
++ "version" : "1.2004_01"
+ }
+
+diff -Naur CPAN-Reporter-1.2004/META.yml CPAN-Reporter-1.2004_01/META.yml
+--- CPAN-Reporter-1.2004/META.yml 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/META.yml 2012-03-02 11:33:56.930329504 +1300
+@@ -14,7 +14,7 @@
+ configure_requires:
+ ExtUtils::MakeMaker: 6.30
+ dynamic_config: 0
+-generated_by: 'Dist::Zilla version 4.300005, CPAN::Meta::Converter version 2.112621'
++generated_by: 'Dist::Zilla version 4.300009, CPAN::Meta::Converter version 2.120530'
+ license: apache
+ meta-spec:
+ url: http://module-build.sourceforge.net/META-spec-v1.4.html
+@@ -31,22 +31,22 @@
+ provides:
+ CPAN::Reporter:
+ file: lib/CPAN/Reporter.pm
+- version: 1.2004
++ version: 1.2004_01
+ CPAN::Reporter::API:
+ file: lib/CPAN/Reporter/API.pm
+- version: 1.2004
++ version: 1.2004_01
+ CPAN::Reporter::Config:
+ file: lib/CPAN/Reporter/Config.pm
+- version: 1.2004
++ version: 1.2004_01
+ CPAN::Reporter::FAQ:
+ file: lib/CPAN/Reporter/FAQ.pm
+- version: 1.2004
++ version: 1.2004_01
+ CPAN::Reporter::History:
+ file: lib/CPAN/Reporter/History.pm
+- version: 1.2004
++ version: 1.2004_01
+ CPAN::Reporter::PrereqCheck:
+ file: lib/CPAN/Reporter/PrereqCheck.pm
+- version: 1.2004
++ version: 1.2004_01
+ requires:
+ CPAN: 1.9301
+ CPAN::Version: 0
+@@ -76,6 +76,6 @@
+ vars: 0
+ resources:
+ bugtracker: http://rt.cpan.org/Public/Dist/Display.html?Name=CPAN-Reporter
+- homepage: https://github.com/dagolden/cpan-reporter
+- repository: https://github.com/dagolden/cpan-reporter.git
+-version: 1.2004
++ homepage: https://github.com/kentfredric/cpan-reporter
++ repository: https://github.com/kentfredric/cpan-reporter.git
++version: 1.2004_01
+diff -Naur CPAN-Reporter-1.2004/README CPAN-Reporter-1.2004_01/README
+--- CPAN-Reporter-1.2004/README 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/README 2012-03-02 11:33:56.937329537 +1300
+@@ -2,7 +2,7 @@
+ CPAN::Reporter - Adds CPAN Testers reporting to CPAN.pm
+
+ VERSION
+- version 1.2004
++ version 1.2004_01
+
+ SYNOPSIS
+ From the CPAN shell:
+@@ -176,9 +176,9 @@
+ This is open source software. The code repository is available for
+ public review and contribution under the terms of the license.
+
+- <https://github.com/dagolden/cpan-reporter>
++ <https://github.com/kentfredric/cpan-reporter>
+
+- git clone https://github.com/dagolden/cpan-reporter.git
++ git clone https://github.com/kentfredric/cpan-reporter.git
+
+ AUTHOR
+ David Golden <dagolden@cpan.org>
+diff -Naur CPAN-Reporter-1.2004/xt/author/pod-spell.t CPAN-Reporter-1.2004_01/xt/author/pod-spell.t
+--- CPAN-Reporter-1.2004/xt/author/pod-spell.t 2012-02-14 10:25:22.000000000 +1300
++++ CPAN-Reporter-1.2004_01/xt/author/pod-spell.t 2012-03-02 11:33:56.922329468 +1300
+@@ -1,4 +1,5 @@
+ #!perl
++
+ # This test is generated by Dist::Zilla::Plugin::Test::PodSpelling
+
+ use Test::More;
+@@ -34,4 +35,12 @@
+ wiki
+ David
+ Golden
++lib
++CPAN
++Reporter
++History
++Config
++PrereqCheck
++API
++FAQ
+