summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Westermann-Clark <dwc@pobox.com>2009-07-09 19:59:15 -0400
committerKent Fredric <kentfredric@gmail.com>2010-08-23 20:32:19 +1200
commit709e51be26d73375e86f7266eb811c1bc96c86e4 (patch)
tree3bc0bfef6d224c7d6a22d48f00e135fff23436cf /dev-perl/Catalyst-Plugin-Session-Store-DBI/Catalyst-Plugin-Session-Store-DBI-0.13.ebuild
parentTweak Text-vCard (diff)
downloadperl-overlay-709e51be26d73375e86f7266eb811c1bc96c86e4.tar.gz
perl-overlay-709e51be26d73375e86f7266eb811c1bc96c86e4.tar.bz2
perl-overlay-709e51be26d73375e86f7266eb811c1bc96c86e4.zip
Add remaining ebuilds from my perl-catalyst overlay
Diffstat (limited to 'dev-perl/Catalyst-Plugin-Session-Store-DBI/Catalyst-Plugin-Session-Store-DBI-0.13.ebuild')
-rw-r--r--dev-perl/Catalyst-Plugin-Session-Store-DBI/Catalyst-Plugin-Session-Store-DBI-0.13.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Catalyst-Plugin-Session-Store-DBI/Catalyst-Plugin-Session-Store-DBI-0.13.ebuild b/dev-perl/Catalyst-Plugin-Session-Store-DBI/Catalyst-Plugin-Session-Store-DBI-0.13.ebuild
new file mode 100644
index 000000000..f28d37c74
--- /dev/null
+++ b/dev-perl/Catalyst-Plugin-Session-Store-DBI/Catalyst-Plugin-Session-Store-DBI-0.13.ebuild
@@ -0,0 +1,25 @@
+# Copyright Daniel Westermann-Clark <daniel at acceleration dot net>
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit perl-module
+
+DESCRIPTION="Store your sessions in a database"
+HOMEPAGE="http://search.cpan.org/dist/${PN}/"
+SRC_URI="mirror://cpan/authors/id/A/AG/AGRUNDMA/${P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc x86"
+RESTRICT="mirror"
+SRC_TEST="do"
+
+IUSE="test"
+RDEPEND="dev-lang/perl
+ >=dev-perl/Catalyst-Runtime-5.49
+ >=dev-perl/Catalyst-Plugin-Session-0.05
+ dev-perl/DBI
+ virtual/perl-MIME-Base64
+ virtual/perl-Storable"
+DEPEND="${RDEPEND}
+ test? ( virtual/perl-Test-Simple )"