summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2015-03-31 23:25:00 +1300
committerKent Fredric <kentfredric@gmail.com>2015-06-14 02:47:51 +1200
commit4c8cd25a14d3881b7e0d5f59ba84e1a6f5957152 (patch)
treeb0e4b41e3396d9bffbe9f351330d15e50794cdf9 /dev-perl/File-ChangeNotify
parent[fixup] EVDB-API: EAPI5, Normalise version, fixup deps (diff)
downloadperl-overlay-4c8cd25a14d3881b7e0d5f59ba84e1a6f5957152.tar.gz
perl-overlay-4c8cd25a14d3881b7e0d5f59ba84e1a6f5957152.tar.bz2
perl-overlay-4c8cd25a14d3881b7e0d5f59ba84e1a6f5957152.zip
[bump] File-ChangeNotify-0.240.0
Package-Manager: portage-2.2.17
Diffstat (limited to 'dev-perl/File-ChangeNotify')
-rw-r--r--dev-perl/File-ChangeNotify/File-ChangeNotify-0.230.0.ebuild83
-rw-r--r--dev-perl/File-ChangeNotify/File-ChangeNotify-0.240.0.ebuild57
-rw-r--r--dev-perl/File-ChangeNotify/Manifest2
3 files changed, 58 insertions, 84 deletions
diff --git a/dev-perl/File-ChangeNotify/File-ChangeNotify-0.230.0.ebuild b/dev-perl/File-ChangeNotify/File-ChangeNotify-0.230.0.ebuild
deleted file mode 100644
index a783b6027..000000000
--- a/dev-perl/File-ChangeNotify/File-ChangeNotify-0.230.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-EAPI=5
-MODULE_AUTHOR=DROLSKY
-MODULE_VERSION=0.23
-inherit perl-module
-
-DESCRIPTION='Watch for changes to files, cross-platform style'
-LICENSE=" Artistic-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test inotify"
-perl_inotify() {
- echo \>=dev-perl/Linux-Inotify2-1.200.0
-}
-perl_meta_configure() {
- # Module::Build 0.3601 ( 0.360.100 )
- echo \>=virtual/perl-Module-Build-0.36.01
-}
-perl_meta_build() {
- # Module::Build 0.3601 ( 0.360.100 )
- echo \>=virtual/perl-Module-Build-0.36.01
-}
-perl_meta_runtime() {
- echo "inotify? ( $(perl_inotify) )"
- # Carp
- # echo dev-lang/perl
- # Class::Load
- echo dev-perl/Class-Load
- # File::Find
- echo dev-lang/perl
- # File::Spec
- echo virtual/perl-File-Spec
- # List::MoreUtils
- echo dev-perl/List-MoreUtils
- # Module::Pluggable::Object
- echo virtual/perl-Module-Pluggable
- # Moose
- echo dev-perl/Moose
- # Moose::Util::TypeConstraints
- echo dev-perl/Moose
- # MooseX::Params::Validate
- echo dev-perl/MooseX-Params-Validate
- # MooseX::SemiAffordanceAccessor
- echo dev-perl/MooseX-SemiAffordanceAccessor
- # Time::HiRes
- echo virtual/perl-Time-HiRes
- # namespace::autoclean
- echo dev-perl/namespace-autoclean
- # strict
- echo dev-lang/perl
- # warnings
- echo dev-lang/perl
-}
-perl_meta_test() {
- # Data::Dumper
- echo virtual/perl-Data-Dumper
- # Exporter
- echo virtual/perl-Exporter
- # File::Path
- echo virtual/perl-File-Path
- # File::Temp
- echo virtual/perl-File-Temp
- # FindBin
- echo dev-lang/perl
- # Test::Exception
- echo dev-perl/Test-Exception
- # Test::More
- echo virtual/perl-Test-Simple
- # base
- # echo virtual/perl-base
-}
-DEPEND="
- $(perl_meta_configure)
- $(perl_meta_build)
- $(perl_meta_runtime)
- test? ( $(perl_meta_test) )
-"
-RDEPEND="
- $(perl_meta_runtime)
-"
-SRC_TEST="do"
diff --git a/dev-perl/File-ChangeNotify/File-ChangeNotify-0.240.0.ebuild b/dev-perl/File-ChangeNotify/File-ChangeNotify-0.240.0.ebuild
new file mode 100644
index 000000000..246c40718
--- /dev/null
+++ b/dev-perl/File-ChangeNotify/File-ChangeNotify-0.240.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=5
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=0.24
+inherit perl-module
+
+DESCRIPTION='Watch for changes to files, cross-platform style'
+LICENSE=" Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test inotify"
+
+# File::Find -> perl
+# Module::Pluggable::Object -> Module-Pluggable
+# Moose::Util::TypeConstraints
+# FindBin -> perl
+# Test::More -> Test-Simple
+RDEPEND_inotify="
+ >=dev-perl/Linux-Inotify2-1.200.0
+"
+PERL_RM_FILES=(
+ t/author-pod-spell.t
+ t/release-cpan-changes.t
+ t/release-eol.t
+ t/release-pod-no404s.t
+ t/release-pod-syntax.t
+ t/release-synopsis.t
+ t/release-try-load.t
+)
+
+RDEPEND="
+ inotify? ( ${RDEPEND_inotify} )
+ virtual/perl-Carp
+ dev-perl/Class-Load
+ virtual/perl-File-Spec
+ dev-perl/List-MoreUtils
+ dev-perl/Module-Pluggable
+ dev-perl/Moose
+ dev-perl/MooseX-Params-Validate
+ dev-perl/MooseX-SemiAffordanceAccessor
+ virtual/perl-Time-HiRes
+ dev-perl/namespace-autoclean
+"
+DEPEND="
+ ${RDEPEND}
+ >=virtual/perl-Module-Build-0.360.100
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-Exporter
+ virtual/perl-File-Path
+ virtual/perl-File-Temp
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/File-ChangeNotify/Manifest b/dev-perl/File-ChangeNotify/Manifest
index db5527378..e199bba96 100644
--- a/dev-perl/File-ChangeNotify/Manifest
+++ b/dev-perl/File-ChangeNotify/Manifest
@@ -1 +1 @@
-DIST File-ChangeNotify-0.23.tar.gz 19200 SHA256 23125b558a6738f41a9675d0f682c2df7894a26415c684028f2cda46193558a1 SHA512 1253cce6cc351ccef549244577314e36e49709aceb9f90a8ca18e9ff50054250cc93f05c8d0d12c96ac84738969979bb283217da23946df4c77320026a0cc992 WHIRLPOOL 23f6b282098826cf632c6900ccb780d7b6b880cefe49480fa332993c60631ed2f13309dda0d2c9f4baa0f5cac924dbdb58cf8fd461516b2fb0df52e6650b2eb8
+DIST File-ChangeNotify-0.24.tar.gz 19450 SHA256 3c8180169de0f97ad852a55942f74e520cbe433aa0889d0b65548ee38a111124 SHA512 e09e6a6b11ad94fcb71e61608cd6b1c1d5c0c3a13a83be7eeca0134bd6e38d459a6670f4c1ada0e92a49b1ac49876c5c7135b811dc27ca2e6a6d4e0326cbc6d9 WHIRLPOOL 40e64ed87e3794614e22f8b3d0c9d219f09c1c303ab4d7b693202238bdbae5309b4e2646051ef0e6657f289fa029cd6552cb823fa17944001c1d2999562c2350