summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2012-05-27 06:58:36 +1200
committerKent Fredric <kentfredric@gmail.com>2012-05-27 06:58:36 +1200
commit9574433e29b8e321f9a2373ef297c5e992d4e44f (patch)
treedff42d5a164ea86c9526591eb2147146e5dbed73 /dev-perl/Glib-Object-Introspection
parent[newversion] Git-CPAN-Patch-0.8.0 (diff)
downloadperl-overlay-9574433e29b8e321f9a2373ef297c5e992d4e44f.tar.gz
perl-overlay-9574433e29b8e321f9a2373ef297c5e992d4e44f.tar.bz2
perl-overlay-9574433e29b8e321f9a2373ef297c5e992d4e44f.zip
[newversion] Glib-Object-Introspection-0.9.0
(Portage version: 2.2.0_alpha101/git/Linux x86_64, signed Manifest commit with key 4132B87441EA24A4EB5E6DE181EC638ED7AE97A6)
Diffstat (limited to 'dev-perl/Glib-Object-Introspection')
-rw-r--r--dev-perl/Glib-Object-Introspection/ChangeLog6
-rw-r--r--dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.9.0.ebuild47
-rw-r--r--dev-perl/Glib-Object-Introspection/Manifest20
3 files changed, 69 insertions, 4 deletions
diff --git a/dev-perl/Glib-Object-Introspection/ChangeLog b/dev-perl/Glib-Object-Introspection/ChangeLog
index a06e1c08f..79a3f9130 100644
--- a/dev-perl/Glib-Object-Introspection/ChangeLog
+++ b/dev-perl/Glib-Object-Introspection/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*Glib-Object-Introspection-0.9.0 (26 May 2012)
+
+ 26 May 2012; Kent Fredric <kentfredric@gmail.com>
+ +Glib-Object-Introspection-0.9.0.ebuild:
+ Version Bump
+
*Glib-Object-Introspection-0.8.0 (28 Apr 2012)
28 Apr 2012; Torsten Veller <tove@gentoo.org>
diff --git a/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.9.0.ebuild b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.9.0.ebuild
new file mode 100644
index 000000000..99dd9468c
--- /dev/null
+++ b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.9.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=4
+MODULE_AUTHOR=XAOC
+MODULE_VERSION=0.009
+inherit perl-module
+
+DESCRIPTION='Dynamically create Perl language bindings'
+LICENSE="|| ( LGPL-2.1 LGPL-3 )" # LGPL-2.1 or later
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+extra_deps() {
+ echo \>=dev-libs/gobject-introspection-1.0
+}
+perl_meta_configure() {
+ # ExtUtils::Depends 0.3 ( 0.300.0 )
+ echo \>=dev-perl/extutils-depends-0.300.0
+ # ExtUtils::MakeMaker
+ echo virtual/perl-ExtUtils-MakeMaker
+ # ExtUtils::PkgConfig 1 ( 1.0.0 )
+ echo \>=dev-perl/extutils-pkgconfig-1.0.0
+ # Glib 1.24 ( 1.240.0 )
+ echo \>=dev-perl/glib-perl-1.240.0
+}
+perl_meta_build() {
+ # ExtUtils::MakeMaker
+ echo virtual/perl-ExtUtils-MakeMaker
+}
+perl_meta_runtime() {
+ # ExtUtils::Depends 0.3 ( 0.300.0 )
+ echo \>=dev-perl/extutils-depends-0.300.0
+ # Glib 1.24 ( 1.240.0 )
+ echo \>=dev-perl/glib-perl-1.240.0
+}
+DEPEND="
+ $(extra_deps)
+ $(perl_meta_configure)
+ $(perl_meta_build)
+ $(perl_meta_runtime)
+"
+RDEPEND="
+ $(extra_deps)
+ $(perl_meta_runtime)
+"
+SRC_TEST="do"
diff --git a/dev-perl/Glib-Object-Introspection/Manifest b/dev-perl/Glib-Object-Introspection/Manifest
index 5f70f3cf4..6af83650b 100644
--- a/dev-perl/Glib-Object-Introspection/Manifest
+++ b/dev-perl/Glib-Object-Introspection/Manifest
@@ -2,13 +2,25 @@
Hash: SHA256
DIST Glib-Object-Introspection-0.008.tar.gz 45014 RMD160 bf3d4ba8722ee7a019352d8be3c7efaf62630b36 SHA1 69611e14786ab6e7ea1b89aab03991cab6cf0edd SHA256 d7f06cf28e5a74fb4f18dc04dc1c2919ba0995ce005608b076777c6f2f82e239
+DIST Glib-Object-Introspection-0.009.tar.gz 45826 RMD160 d26464e0a437383e7047b4d612f570f4b7d138b8 SHA1 b160927945d3194d0cf3f0768835500319e8c501 SHA256 46f1ecc98376ecefc60294f6318ae09cc186a4f3a6744ba5c60156325da71189
EBUILD Glib-Object-Introspection-0.8.0.ebuild 592 RMD160 98a1cdd9b2894fa42e5b51f8f6bcd06fe53ffa89 SHA1 7434cbc836fd1b905da99213dbe47afe9397ca88 SHA256 0a34578f0e1df490ae25ceb530f4b37aaa0f4b1380732db401b027d2f0aae1b6
-MISC ChangeLog 307 RMD160 8688538d5b3ebf193983a8ef239f888578e8fd7d SHA1 232e3003e9235886bee2c49457334e5c6dd9b89c SHA256 33d7083524f51674e7f66c1123d8f96b558baeb235e8d229bb0de801c42789f0
+EBUILD Glib-Object-Introspection-0.9.0.ebuild 1107 RMD160 88b9755c85ab400461122f7655824929d55ca5c7 SHA1 0787a5029faa52267914a8a6859b7a6cf4f13e81 SHA256 7d8ce26708d07089539e75dce60b26f81216ea8b7c7c3eb0cb1c8c6b86c525b7
+MISC ChangeLog 466 RMD160 4c851a6888366c091eacb9a99ad705ae7c90e989 SHA1 ac4184caf9003aa4e6640fb7be59eefbddbf7ff2 SHA256 4a6831791dcbafc57c6ed4085aa7b0b529734d29d6c93f6a8fd1d7f6ba784f4d
MISC metadata.xml 251 RMD160 5f2e02306783f15c5348191ef8943413a68b88ae SHA1 e015a546dd24d7eee055ac430e76f57d13cbac64 SHA256 024b2ea682edd84cd39d7cc86875a0642297a10bb0129b74c7951b62fd598ba1
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
-iEYEAREIAAYFAk+brwwACgkQV3J2n04EauwaZgCeKMHcFNRkfw9PAyDTnzFtYqUE
-JfcAoLdrN55rLEprAwsYklS8ECkx2ipe
-=hW2j
+iQIcBAEBCAAGBQJPwSfcAAoJEE321xbMTOIUjooP/RdG+36Nd+saHGbLtNBH47Xh
+yUxi0MTL5ExOMXb/ij8aF0oNCKf2mDdjRAHnrcfqc0HUIsbt2zh8lQP0F/EJsE57
+Ag3zNwCBW9u8QweJjMNtEQemdi3WNDn/Kxw9NYSrhZ+bGAtJODqFzvGH6zlbOQUb
+JsPGTSUs1ceR2qvA1q8hsBVDNlafxc1uzTW6Fkgw8mQ8YaOHRdJbF+MvIWsWKZeO
+U//EK1WH+3Kg+GDLKCaq7FmqFOzn38HoedI8Nc1InuOxLrHU9DviS+WBzorCzLzY
+sVPx5ZhWGaJn+IYe6CeVLoWhzI8v8X5jMwOVwbFTDdoV+0D3/KIXrzYuCu7e4xMM
+7IjfnPthlT2h3gEMr2O3dVVHcAQgECAyOIF4VG+MIyEWnUCQb2H4AcMwA7VAVW8B
+19I+GLq3HqoOY01Mg6dETOTghKtfBGialsDRDEBF+ujygI0Ikf/6e+uJhjcsG1fu
+GwrScBZFGGao8XT6IZcld0N3MDbyI7VibMnsomnWuZyWZwGa/zJvVn6syeswaJRP
+l+xy9CV6LRsmHOJa5B871jFYT3SjqqnkqD3OX5UIWdRB7VcNNjOrrG6uFTxE6G6m
+MDfelTUB1TDr0NucljPYNmmFdMGg24rAceSimcwkZIbvlt/d8y7Eef16eRrdKS+M
+29rRy9AS5i5Y1JkhW7Yz
+=Nmmg
-----END PGP SIGNATURE-----