aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-08 20:35:04 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-08 20:35:04 +0200
commit24d0e911a0551e718186598d337ddb0ad74ae865 (patch)
tree29a5400ed62f4b3730e0efe88bd1961a01c6e845
parentrelease.yml: update actions/setup-python to v4 (diff)
downloadsnakeoil-24d0e911a0551e718186598d337ddb0ad74ae865.tar.gz
snakeoil-24d0e911a0551e718186598d337ddb0ad74ae865.tar.bz2
snakeoil-24d0e911a0551e718186598d337ddb0ad74ae865.zip
pyproject.toml: depend on flit_core >=3.8
Makes it cleaner pyproject.toml and less error prone. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--pyproject.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 3bb5526..c250cee 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,12 +1,12 @@
[build-system]
-requires = ["flit_core >=3.7,<4"]
+requires = ["flit_core >=3.8,<4"]
build-backend = "flit_core.buildapi"
[project]
name = "snakeoil"
description = "misc common functionality and useful optimizations"
readme = "README.rst"
-requires-python = ">=3.8"
+requires-python = "~=3.8"
authors = [
{name = "Tim Harder", email = "radhermit@gmail.com"},
{name = "Arthur Zamarin", email = "arthurzam@gentoo.org"},
@@ -42,7 +42,7 @@ Source = "https://github.com/pkgcore/snakeoil"
[tool.flit.sdist]
include = ["doc", "tox.ini", "tests", "Makefile", "NEWS.rst"]
-exclude = [".github/", ".gitignore", "doc/api/", "tests/__pycache__", "tests/cli/__pycache__"]
+exclude = [".github/", ".gitignore", "doc/api/"]
[tool.pytest.ini_options]
minversion = "6.0"