aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'pmstestsuite/library/standard/eclass_metadata.py')
-rw-r--r--pmstestsuite/library/standard/eclass_metadata.py13
1 files changed, 4 insertions, 9 deletions
diff --git a/pmstestsuite/library/standard/eclass_metadata.py b/pmstestsuite/library/standard/eclass_metadata.py
index d7b6cf6..18a4686 100644
--- a/pmstestsuite/library/standard/eclass_metadata.py
+++ b/pmstestsuite/library/standard/eclass_metadata.py
@@ -4,9 +4,9 @@
from abc import abstractproperty
-from .dbus_case import DBusEclassTestCase
+from pmstestsuite.library.case import EclassTestCase
-class VariableInheritanceTest(DBusEclassTestCase):
+class VariableInheritanceTest(EclassTestCase):
""" Eclass variable inheritance test. """
@abstractproperty
@@ -29,7 +29,7 @@ class VariableInheritanceTest(DBusEclassTestCase):
return '%s=%s\n' % (self.var_name, repr(self.var_eclass_value))
def __init__(self, *args, **kwargs):
- DBusEclassTestCase.__init__(self, *args, **kwargs)
+ EclassTestCase.__init__(self, *args, **kwargs)
self.ebuild_vars[self.var_name] = self.var_ebuild_value
class IUseInheritanceTest(VariableInheritanceTest):
@@ -40,16 +40,13 @@ class IUseInheritanceTest(VariableInheritanceTest):
var_ebuild_value = 'bar'
def check_dbus_result(self, output, pm):
- # ensure it got installed first
- DBusEclassTestCase.check_dbus_result(self, output, pm)
-
spl = pm.installed[self.atom(pm)].use
self.assertContains(self.var_eclass_value, spl, 'IUSE (eclass)')
self.assertContains(self.var_ebuild_value, spl, 'IUSE (ebuild)')
# XXX: REQUIRED_USE
-class EclassDefinedPhasesTest(DBusEclassTestCase):
+class EclassDefinedPhasesTest(EclassTestCase):
""" Check whether eclasses set DEFINED_PHASES as well. """
supported_eapis = ((4,),)
@@ -70,8 +67,6 @@ EXPORT_FUNCTIONS src_compile
''' % self.pn
def check_dbus_result(self, output, pm):
- DBusEclassTestCase.check_dbus_result(self, output, pm)
-
phases = pm.installed[self.atom(pm)].defined_phases
self.assertContains('compile', phases, 'DEFINED_PHASES (eclass)')
self.assertContains('install', phases, 'DEFINED_PHASES (ebuild)')