aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-11 05:49:22 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-11 05:49:22 +0000
commit141f03f931699bb60b1de162fd472616a5947050 (patch)
tree1842bc9f062ce992a14a742aa4ea13a8f20b0e55
parentfix autotools target name (diff)
downloadportage-utils-0.7.tar.gz
portage-utils-0.7.tar.bz2
portage-utils-0.7.zip
fix up dist targetv0.7
-rw-r--r--Makefile4
-rwxr-xr-xautogen.sh4
-rwxr-xr-xmake-tarball.sh2
3 files changed, 6 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 3a8d9866..b760abff 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2005-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.69 2011/12/11 05:46:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-projects/portage-utils/Makefile,v 1.70 2011/12/11 05:49:22 vapier Exp $
####################################################################
check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
@@ -61,7 +61,7 @@ autotools-update:
-e '/^dist_man_MANS =/s:=.*:= $(wildcard man/*.1):' \
Makefile.am
autotools: autotools-update
- ./autogen.sh
+ ./autogen.sh --from=make
debug:
$(MAKE) CFLAGS="$(CFLAGS) -O0 -DEBUG -g3 -ggdb -fno-pie" clean symlinks
diff --git a/autogen.sh b/autogen.sh
index 972cd656..fda98b7b 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -5,7 +5,9 @@ v() { echo "$@"; "$@"; }
m4dir="autotools/m4"
v rm -rf autotools
-v ${MAKE:-make} autotools-update
+if [[ $1 != "--from=make" ]] ; then
+ v ${MAKE:-make} autotools-update
+fi
# reload the gnulib code if possible
PATH=/usr/local/src/gnu/gnulib:${PATH}
diff --git a/make-tarball.sh b/make-tarball.sh
index bf59cd70..e9f6d50c 100755
--- a/make-tarball.sh
+++ b/make-tarball.sh
@@ -20,7 +20,7 @@ cd "${p}"
cvs -Q up
sed -i "/^AC_INIT/s:cvs:${ver}:" configure.ac
sed -i "1iPV := ${ver}" Makefile
-make autotools-update
+make autotools
rm -rf autom4te.cache
cd ..