aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-05-20 19:53:48 +0200
committerFabian Groffen <grobian@gentoo.org>2019-05-20 19:53:48 +0200
commitd16f69568285d76dfa8a367f2458bc16f9e049e4 (patch)
treef7795e5bc4804f644ed2f4f363388e7e5bac6f3e /Makefile.am
parenttest/source: utime is obsolete, utimes is POSIX.1.2001 (diff)
downloadportage-utils-d16f69568285d76dfa8a367f2458bc16f9e049e4.tar.gz
portage-utils-d16f69568285d76dfa8a367f2458bc16f9e049e4.tar.bz2
portage-utils-d16f69568285d76dfa8a367f2458bc16f9e049e4.zip
qmanifest: new applet to verify and generate thick Manifests
This incorporates https://github.com/grobian/hashgen into portage-utils as qmanifest. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b36173c..f28a073 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,6 +17,7 @@ APPLETS = \
qkeyword \
qlist \
qlop \
+ qmanifest \
qmerge \
qpkg \
qsearch \
@@ -37,6 +38,7 @@ dist_man_MANS = \
man/qkeyword.1 \
man/qlist.1 \
man/qlop.1 \
+ man/qmanifest.1 \
man/qmerge.1 \
man/qpkg.1 \
man/qsearch.1 \
@@ -59,6 +61,7 @@ q_SOURCES = \
qkeyword.c \
qlist.c \
qlop.c \
+ qmanifest.c \
qmerge.c \
qpkg.c \
qsearch.c \
@@ -69,14 +72,21 @@ q_SOURCES = \
qxpak.c \
$(NULL)
q_CPPFLAGS = \
+ $(OPENMP_CFLAGS) \
+ $(GPGME_CFLAGS) \
-I$(top_srcdir)/libq \
-I$(top_builddir)/autotools/gnulib \
-I$(top_srcdir)/autotools/gnulib \
$(NULL)
q_LDADD = \
+ $(OPENMP_CFLAGS) \
$(top_builddir)/libq/libq.la \
$(top_builddir)/autotools/gnulib/libgnu.a \
-liniparser \
+ $(LIBSSL) \
+ $(LIBBL2) \
+ $(LIBZ) \
+ $(GPGME_LIBS) \
$(LIB_CLOCK_GETTIME) \
$(LIB_EACCESS) \
$(NULL)