aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--main.c13
-rwxr-xr-xmake-tarball.sh4
2 files changed, 10 insertions, 7 deletions
diff --git a/main.c b/main.c
index 9103dc42..7dbdbe72 100644
--- a/main.c
+++ b/main.c
@@ -189,21 +189,24 @@ usage(int status, const char *flags, struct option const opts[],
static void
version_barf(void)
{
+ const char *vcsid = "";
const char *eprefixid = "";
#ifndef VERSION
# define VERSION "git"
#endif
-#ifndef VCSID
-# define VCSID "<unknown>"
+
+#ifdef VCSID
+ vcsid = " (" VCSID ")";
#endif
if (strlen(CONFIG_EPREFIX) > 1)
eprefixid = "configured for " CONFIG_EPREFIX "\n";
- printf("portage-utils-%s: %s\n"
+
+ printf("portage-utils-%s%s\n"
"%s"
- "%s written for Gentoo by <solar and vapier @ gentoo.org>\n",
- VERSION, VCSID, eprefixid, argv0);
+ "written for Gentoo by solar, vapier and grobian\n",
+ VERSION, vcsid, eprefixid);
exit(EXIT_SUCCESS);
}
diff --git a/make-tarball.sh b/make-tarball.sh
index 4f8eed7a..ce25579d 100755
--- a/make-tarball.sh
+++ b/make-tarball.sh
@@ -36,8 +36,8 @@ git archive "${ver}" | tar xf - -C "${p}"
cd "${p}"
einfo "Building autotools ..."
-sed -i "/^AC_INIT/s:git:${ver}:" configure.ac
-sed -i "1iPV := ${ver}" Makefile
+sed -i "/^AC_INIT/s:git:${ver#v}:" configure.ac
+sed -i "1iPV := ${ver#v}" Makefile
LC_ALL=C ${MAKE} -s autotools >/dev/null
rm -rf autom4te.cache
cd ..