summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2014-12-03 16:29:54 -0800
committerBrian Dolbec <dolsen@gentoo.org>2014-12-03 16:29:54 -0800
commitfd5214913b6b3ab1cc251fab58c455e7a853a739 (patch)
tree0ff77f2e759633d8a156d0d34ea76fbf8c4fac31
parentportage.os.waitpid: handle EINTR for bug #525552 (diff)
downloadportage-2.2.15.tar.gz
portage-2.2.15.tar.bz2
portage-2.2.15.zip
Update RELEASE-NOTES and versionv2.2.15
-rw-r--r--RELEASE-NOTES48
-rwxr-xr-xsetup.py2
2 files changed, 49 insertions, 1 deletions
diff --git a/RELEASE-NOTES b/RELEASE-NOTES
index 791239896..800beee56 100644
--- a/RELEASE-NOTES
+++ b/RELEASE-NOTES
@@ -4,6 +4,54 @@ Features/major bugfixes are listed in NEWS
portage-2.2.15
==================================
* New option --rage-clean that does --unmerge without delay.
+* package.bashrc: per profile, per-package bashrc mechanism
+* Introduce eqalog and eqawarnlog functions.
+* Introduce eqatag to output proper machine-readable QA logs
+* Bug Fixes:
+ - Bug 517310 emerge --read-news: prompt only if --ask
+ - Bug 433453 Support unprivileged mode
+ - Bug 519566 Remove g+w bit from $T for TPE
+ - Bug 433453 portage.data._get_global: fix UnboundLocalError
+ - Bug 526160 This fixes _dep_check_composite_db to mask packages
+ that aren't the highest visible match, but only if an
+ update is desirable.
+ - Bug 523684 This fixes the ConfigProtect class, etc-update, and
+ dispatch-conf to account for non-existent files (rather than
+ directories) that are listed directly in CONFIG_PROTECT.
+ - Bug 524964 bin/bashrc-functions.sh: remove portageq function
+ - Bug 527636 Add btrfs.* to default PORTAGE_XATTR_EXCLUDE
+ - Bug 485598 etc-update & dispatch-conf: symlink and protected
+ symlink support
+ - Bug 527636 Remove redundant PORTAGE_XATTR_EXCLUDE defaults
+ - Bug 528272 This fixes incorrect behavior of the "fetch" phase
+ - Bug 456128 Add support for SUSE based distros in etc-update
+ - Bug 528760 man/ebuild.5: document assert fix
+ - Bug 525726 _selinux.setexec: improve failure message
+ - Bug 529200 portageq: fix eroot parameter
+ - Bug 529120 fs_template._ensure_dirs: handle EEXIST
+ - Bug 528610 This fixes a case inside _slot_operator_update_probe where
+ it would select an inappropriate replacement_parent of a
+ lower version than desired.
+ - Bug 490732 NewsManager.getUnreadItems: handle EROFS
+ - Bug 524236 dblink: case insensitive support
+ - Bug 515584 dep_zapdeps: avoid use.mask/force changes
+ - Bug 490732 check for writable /var/db/pkg
+ - Bug 520652 Add emerge --with-test-deps option
+ - Bug 490732 check for writable PKGDIR
+ - Bug 529660 Memoize the results of use_reduce calls inside
+ _slot_operator_update_probe, in order to improve performance.
+ - Bug 530010 Implement selective invalidation of cache for the
+ depgraph._select_pkg_highest_available method...
+ - Bug 530982 fix UnicodeDecodeError
+ - Bug 531112 _pkg_use_enabled: return frozenset
+ - Bug 387059 emerge: warn about @installed, don't deprecate
+ - Bug 528274 ebuild.sh: force fresh env for pkg_setup
+ - Bug 527996 emerge --info: show /bin/sh provider
+ - Bug 527486 portage/util/writeable_check.py: Fix IndexError:
+ - Bug 525552 Use a new _eintr_func_wrapper class to wrap waitpid calls and
+ handle EINTR by calling the function as many times as necessary
+ (until it returns without raising EINTR).
+
portage-2.2.14
==================================
diff --git a/setup.py b/setup.py
index 8231c0a94..4388a9968 100755
--- a/setup.py
+++ b/setup.py
@@ -611,7 +611,7 @@ def get_manpages():
setup(
name = 'portage',
- version = '2.2.14',
+ version = '2.2.15',
url = 'https://wiki.gentoo.org/wiki/Project:Portage',
author = 'Gentoo Portage Development Team',
author_email = 'dev-portage@gentoo.org',