summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-server/files/postgresql-7.4-server.patch')
-rw-r--r--dev-db/postgresql-server/files/postgresql-7.4-server.patch62
1 files changed, 29 insertions, 33 deletions
diff --git a/dev-db/postgresql-server/files/postgresql-7.4-server.patch b/dev-db/postgresql-server/files/postgresql-7.4-server.patch
index 3661c6d..972dce8 100644
--- a/dev-db/postgresql-server/files/postgresql-7.4-server.patch
+++ b/dev-db/postgresql-server/files/postgresql-7.4-server.patch
@@ -1,8 +1,8 @@
-diff --git a/GNUmakefile.in b/GNUmakefile.in
-index 563532a..607dc8a 100644
---- a/GNUmakefile.in
-+++ b/GNUmakefile.in
-@@ -23,7 +23,6 @@ installdirs uninstall distprep:
+=== GNUmakefile.in
+==================================================================
+--- GNUmakefile.in (revision 12)
++++ GNUmakefile.in (local)
+@@ -23,7 +23,6 @@
$(MAKE) -C src $@
install-all-headers:
@@ -10,11 +10,11 @@ index 563532a..607dc8a 100644
# clean, distclean, etc should apply to contrib too, even though
# it's not built by default
-diff --git a/contrib/Makefile b/contrib/Makefile
-index 74310cf..fae6422 100644
---- a/contrib/Makefile
-+++ b/contrib/Makefile
-@@ -13,7 +13,6 @@ WANTED_DIRS = \
+=== contrib/Makefile
+==================================================================
+--- contrib/Makefile (revision 12)
++++ contrib/Makefile (local)
+@@ -13,7 +13,6 @@
dbmirror \
dbsize \
earthdistance \
@@ -22,7 +22,7 @@ index 74310cf..fae6422 100644
fulltextindex \
fuzzystrmatch \
intagg \
-@@ -23,11 +22,7 @@ WANTED_DIRS = \
+@@ -23,11 +22,7 @@
ltree \
miscutil \
noupdate \
@@ -34,7 +34,7 @@ index 74310cf..fae6422 100644
pgcrypto \
pgstattuple \
rserv \
-@@ -39,8 +34,7 @@ WANTED_DIRS = \
+@@ -39,8 +34,7 @@
tips \
tsearch \
tsearch2 \
@@ -44,11 +44,11 @@ index 74310cf..fae6422 100644
# Missing:
# array \ (removed all but the README)
-diff --git a/src/Makefile b/src/Makefile
-index cd6e5e6..0b23160 100644
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -14,11 +14,8 @@ include Makefile.global
+=== src/Makefile
+==================================================================
+--- src/Makefile (revision 12)
++++ src/Makefile (local)
+@@ -14,11 +14,8 @@
all install installdirs uninstall dep depend distprep:
@@ -60,11 +60,11 @@ index cd6e5e6..0b23160 100644
$(MAKE) -C bin $@
$(MAKE) -C pl $@
-diff --git a/src/Makefile.global.in b/src/Makefile.global.in
-index 19c49d1..c968a2e 100644
---- a/src/Makefile.global.in
-+++ b/src/Makefile.global.in
-@@ -291,10 +291,10 @@ libpq_builddir = $(top_builddir)/src/interfaces/libpq
+=== src/Makefile.global.in
+==================================================================
+--- src/Makefile.global.in (revision 12)
++++ src/Makefile.global.in (local)
+@@ -291,10 +291,10 @@
libpq = -L$(libpq_builddir) -lpq
submake-libpq:
@@ -77,23 +77,19 @@ index 19c49d1..c968a2e 100644
.PHONY: submake-libpq submake-libpgport
-diff --git a/src/bin/Makefile b/src/bin/Makefile
-index 3035f61..6cc968c 100644
---- a/src/bin/Makefile
-+++ b/src/bin/Makefile
-@@ -13,13 +13,8 @@ subdir = src/bin
+=== src/bin/Makefile
+==================================================================
+--- src/bin/Makefile (revision 12)
++++ src/bin/Makefile (local)
+@@ -13,9 +13,8 @@
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
-DIRS := initdb initlocation ipcclean pg_ctl pg_dump pg_id \
- psql scripts pg_config pg_controldata pg_resetxlog \
- pg_encoding
--
--ifeq ($(with_tcl), yes)
-- DIRS += pgtclsh
--endif
+DIRS := initdb initlocation ipcclean pg_ctl pg_id \
+ pg_controldata pg_resetxlog
- all install installdirs uninstall depend distprep:
- @for dir in $(DIRS); do $(MAKE) -C $$dir $@ || exit; done
+ ifeq ($(with_tcl), yes)
+ DIRS += pgtclsh