aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-10-23 18:54:14 +0100
committerMarkos Chandras <hwoarang@gentoo.org>2012-10-23 18:54:14 +0100
commit0e39a47821ad0f6252f61b97f9addd5ed42fb018 (patch)
treef177379e2abc23079adacdcad6423dd746349709 /Documentation
parentPyQt4/sip: Automated version bump, remove old (diff)
downloadqt-0e39a47821ad0f6252f61b97f9addd5ed42fb018.tar.gz
qt-0e39a47821ad0f6252f61b97f9addd5ed42fb018.tar.bz2
qt-0e39a47821ad0f6252f61b97f9addd5ed42fb018.zip
bump-python-revision: Fix detection for pyqt4/sip revisions
Diffstat (limited to 'Documentation')
-rwxr-xr-xDocumentation/maintainers/bump-python-revisions8
1 files changed, 4 insertions, 4 deletions
diff --git a/Documentation/maintainers/bump-python-revisions b/Documentation/maintainers/bump-python-revisions
index 6d201990..87c267b4 100755
--- a/Documentation/maintainers/bump-python-revisions
+++ b/Documentation/maintainers/bump-python-revisions
@@ -96,12 +96,12 @@ commit() {
getrevisions() {
pushd ${OVERLAY}/dev-python/PyQt4/ > /dev/null
pyqt4_tomove=$(find '.' -type f -name "PyQt4-*_pre*.ebuild"|tail -1)
- pyqt4_revision=$(grep ^REVISION ${pyqt4_tomove}|sed "s:^REVISION=::")
+ pyqt4_revision=$(grep ^REVISION ${pyqt4_tomove}|cut -d "=" -f 2)
PVER=$(echo ${pyqt4_tomove/\.\//}|sed "s:PyQt4-\(.*\)_pre.*:\1:")
popd > /dev/null
pushd ${OVERLAY}/dev-python/sip/ > /dev/null
sip_tomove=$(find '.' -type f -name "sip-*_pre*.ebuild"|tail -1)
- sip_revision=$(grep "HG_REVISION=" ${sip_tomove}|sed "s:HG_REVISION=::")
+ sip_revision=$(grep "HG_REVISION=" ${sip_tomove}|cut -d "=" -f 2)
SVER=$(echo ${sip_tomove/\.\//}|sed "s:sip-\(.*\)_pre.*:\1:")
popd > /dev/null
@@ -130,10 +130,10 @@ getrevisions() {
einfo "New sip snapshot@rev: ${new_sip}@${new_sip_rev}"
# Decide what to bump"
[[ -z ${new_pyqt4_rev} ]] || \
- { [[ ${pyqt4_revision} != ${new_pyqt4_rev} ]] \
+ { [[ "${pyqt4_revision}" != "${new_pyqt4_rev}" ]] \
&& dopyqt4 && FOUND=true; }
[[ -z ${new_sip_rev} ]] || \
- { [[ ${sip_revision} != ${new_sip_rev} ]] \
+ { [[ "${sip_revision}" != "${new_sip_rev}" ]] \
&& dosip && FOUND=true; }
if [[ -n ${FOUND} ]]; then