aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-02-23 09:50:07 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-02-23 09:50:07 +0000
commit32316aa20e9be20dd569153fc11e4e6cbf37801b (patch)
tree4ef2522db7c9e593702d680bc0bab5eb3a685a52 /Documentation
parentpackage.mask: Update mask entry (diff)
downloadqt-32316aa20e9be20dd569153fc11e4e6cbf37801b.tar.gz
qt-32316aa20e9be20dd569153fc11e4e6cbf37801b.tar.bz2
qt-32316aa20e9be20dd569153fc11e4e6cbf37801b.zip
PyQt4/sip: Automatic version bump, remove old
Diffstat (limited to 'Documentation')
-rwxr-xr-xDocumentation/maintainers/bump-python-revisions8
1 files changed, 4 insertions, 4 deletions
diff --git a/Documentation/maintainers/bump-python-revisions b/Documentation/maintainers/bump-python-revisions
index b06951ff..5bb5abc1 100755
--- a/Documentation/maintainers/bump-python-revisions
+++ b/Documentation/maintainers/bump-python-revisions
@@ -41,8 +41,8 @@ esac
########################## VARIABLES ############################
PREV="${1}" # PyQt4 Revision
SREV="${2}" # Sip Revision
-PVER="4.8.3" # PyQt4 current working version
-SVER="4.12.1" #$ Sip current working version
+PVER="4.8.4" # PyQt4 current working version
+SVER="4.12.2" #$ Sip current working version
PYPKG="PyQt-x11-gpl-snapshot-${PVER}-${PREV}" #Format PyQt4 package
SIPKG="sip-${SVER}-snapshot-${SREV}" # Format Sip package
DATE="$(date +%F|sed 's/-//g')" # date to be added to ebuilds
@@ -101,7 +101,7 @@ einfo "Bumping ebuilds..."
# PyQt4
pushd ${OVERLAY}/dev-python/PyQt4/
-tomove=$(find '.' -type f -name "PyQt4-${PVER}*.ebuild"|tail -1)
+tomove=$(find '.' -type f -name "PyQt4-*_pre*.ebuild"|tail -1)
einfo "Previous ebuild to use: ${tomove#./}"
mv ${tomove#./} PyQt4-${PVER}_pre${DATE}.ebuild || exit "Failed to bump PyQt4"
ebegin "Changing revision number to ${PREV}"
@@ -113,7 +113,7 @@ popd
# sip
pushd ${OVERLAY}/dev-python/sip/
-tomove=$(find '.' -type f -name "sip-${SVER}*.ebuild"|tail -1)
+tomove=$(find '.' -type f -name "sip-*_pre*.ebuild"|tail -1)
einfo "Previous ebuild to use: ${tomove#./}"
mv ${tomove#./} sip-${SVER}_pre${DATE}.ebuild || exit "Failed to bump sip"
ebegin "Changing revision number to ${SREV}"