aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-02-04 01:05:29 +0200
committerMarkos Chandras <hwoarang@gentoo.org>2012-02-04 01:05:29 +0200
commitfaa097cb192fe4b68df01667ebd3171bc0c58c80 (patch)
tree28452689214b34c06978569e57b6499d9c5ddce1 /dev-util
parent[media-gfx/photivo] Fix several repoman issues. (diff)
downloadqt-faa097cb192fe4b68df01667ebd3171bc0c58c80.tar.gz
qt-faa097cb192fe4b68df01667ebd3171bc0c58c80.tar.bz2
qt-faa097cb192fe4b68df01667ebd3171bc0c58c80.zip
dev-util/qt-creator: Refactor ebuild so we can use it for future version bumps
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/qt-creator/qt-creator-9999.ebuild24
1 files changed, 18 insertions, 6 deletions
diff --git a/dev-util/qt-creator/qt-creator-9999.ebuild b/dev-util/qt-creator/qt-creator-9999.ebuild
index 12466bfa..6d386630 100644
--- a/dev-util/qt-creator/qt-creator-9999.ebuild
+++ b/dev-util/qt-creator/qt-creator-9999.ebuild
@@ -4,19 +4,31 @@
EAPI="4"
LANGS="cs de es fr hu it ja pl ru sl uk zh_CN"
+MY_P=${PN}-${PV/_/-}-src
-inherit multilib eutils flag-o-matic qt4-edge git-2
+inherit multilib eutils flag-o-matic
-MY_P=${PN}-${PV/_/-}-src
+if [[ ${PV} = 9999 ]]; then
+ inherit git-2
+ QTCREATOR_SUFFIX="-edge"
+ EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git
+ https://git.gitorious.org/${PN}/${PN}.git"
+else
+ QTCREATOR_SUFFIX="-r2"
+ SRC_URI="http://get.qt.nokia.com/qtcreator/${MY_P}.tar.gz"
+fi
+inherit qt4${QTCREATOR_SUFFIX}
DESCRIPTION="Lightweight IDE for C++ development centering around Qt"
HOMEPAGE="http://qt.nokia.com/products/developer-tools"
-EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git
- https://git.gitorious.org/${PN}/${PN}.git"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS=""
+if [[ ${PV} == 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
QTC_PLUGINS=(bazaar cmake:cmakeprojectmanager cvs fakevim
git madde mercurial perforce subversion valgrind)
@@ -52,7 +64,7 @@ PDEPEND="
"
src_prepare() {
- qt4-edge_src_prepare
+ qt4${QTCREATOR_SUFFIX}_src_prepare
# disable unwanted plugins
for plugin in "${QTC_PLUGINS[@]#[+-]}"; do