aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-22 20:45:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-22 21:11:01 +0200
commit80bb46f1a3c1c40e18bfe9da6d6e865b727ae29d (patch)
tree3a37b4d6e0e7e41da406a6e545745fba07e4e27d /lxqt-base/lxqt-powermanagement
parentlxqt-base/lxqt-policykit: Sync with Gentoo ebuild repo (diff)
downloadqt-80bb46f1a3c1c40e18bfe9da6d6e865b727ae29d.tar.gz
qt-80bb46f1a3c1c40e18bfe9da6d6e865b727ae29d.tar.bz2
qt-80bb46f1a3c1c40e18bfe9da6d6e865b727ae29d.zip
lxqt-base/lxqt-powermanagement: Sync with Gentoo ebuild repo
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-powermanagement')
-rw-r--r--lxqt-base/lxqt-powermanagement/lxqt-powermanagement-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-9999.ebuild b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-9999.ebuild
index 9945ca71..06602f9a 100644
--- a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-9999.ebuild
+++ b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-9999.ebuild
@@ -8,7 +8,9 @@ inherit cmake
DESCRIPTION="LXQt daemon for power management and auto-suspend"
HOMEPAGE="https://lxqt.github.io/"
-if [[ ${PV} = *9999* ]]; then
+LXQTPV="$(ver_cut 1-2)*"
+
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
@@ -16,15 +18,15 @@ else
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
fi
-LICENSE="LGPL-2.1+"
+LICENSE="LGPL-2.1 LGPL-2.1+"
SLOT="0"
BDEPEND="
dev-qt/linguist-tools:5
- >=dev-util/lxqt-build-tools-0.6.0
+ >=dev-util/lxqt-build-tools-0.9.0
virtual/pkgconfig
"
-RDEPEND="
+DEPEND="
>=dev-libs/libqtxdg-3.3.1
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -34,7 +36,8 @@ RDEPEND="
dev-qt/qtx11extras:5
kde-frameworks/kidletime:5
kde-frameworks/solid:5
- =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ =lxqt-base/liblxqt-${LXQTPV}
+ =lxqt-base/lxqt-globalkeys-${LXQTPV}
sys-power/upower
"
-DEPEND="${RDEPEND}"
+RDEPEND="${DEPEND}"