aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-runner/lxqt-runner-2.0.0.ebuild')
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-2.0.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-2.0.0.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-2.0.0.ebuild
deleted file mode 100644
index df4effbd..00000000
--- a/lxqt-base/lxqt-runner/lxqt-runner-2.0.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="LXQt quick launcher"
-HOMEPAGE="https://lxqt-project.org/"
-
-MY_PV="$(ver_cut 1-2)"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
-else
- SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="LGPL-2.1 LGPL-2.1+"
-SLOT="0"
-
-BDEPEND="
- >=dev-qt/qttools-6.6:6[linguist]
- >=dev-util/lxqt-build-tools-2.0.0
- virtual/pkgconfig
-"
-DEPEND="
- >=dev-cpp/muParser-2.2.3
- >=dev-libs/libqtxdg-4.0.0
- >=dev-qt/qtbase-6.6:6[dbus,gui,widgets,xml]
- kde-frameworks/kwindowsystem:6
- >=kde-plasma/layer-shell-qt-6.0:6
- =lxqt-base/liblxqt-${MY_PV}*:=
- =lxqt-base/lxqt-globalkeys-${MY_PV}*
-"
-RDEPEND="${DEPEND}"
-
-src_install() {
- cmake_src_install
- doman man/*.1
-}