aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'prefix/dev-lang/ruby/ruby-1.9.1_rc1.ebuild')
-rw-r--r--prefix/dev-lang/ruby/ruby-1.9.1_rc1.ebuild191
1 files changed, 0 insertions, 191 deletions
diff --git a/prefix/dev-lang/ruby/ruby-1.9.1_rc1.ebuild b/prefix/dev-lang/ruby/ruby-1.9.1_rc1.ebuild
deleted file mode 100644
index b00783d..0000000
--- a/prefix/dev-lang/ruby/ruby-1.9.1_rc1.ebuild
+++ /dev/null
@@ -1,191 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="prefix"
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-# ruby-1.9.1_preX -> ruby-1.9.0-previewX
-MY_PV=$(replace_version_separator 3 '-')
-MY_P="${PN}-${MY_PV/pre/preview}"
-
-# 1.9.1.0 -> 1.9
-SLOT=$(get_version_component_range 1-2)
-
-# 1.9 -> 19
-MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
-
-DESCRIPTION="An object-oriented scripting language"
-HOMEPAGE="http://www.ruby-lang.org/"
-SRC_URI="mirror://ruby/${MY_P}.tar.bz2"
-
-LICENSE="Ruby"
-KEYWORDS="~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-IUSE="berkdb debug doc emacs examples gdbm ipv6 rubytests socks5 ssl tk xemacs"
-
-RDEPEND="
- berkdb? ( sys-libs/db )
- gdbm? ( sys-libs/gdbm )
- ssl? ( dev-libs/openssl )
- socks5? ( >=net-proxy/dante-1.1.13 )
- tk? ( dev-lang/tk )
- >=app-admin/eselect-ruby-20080921
- !=dev-lang/ruby-cvs-${SLOT}*
- !dev-ruby/rdoc
- !dev-ruby/rexml"
-DEPEND="${RDEPEND}"
-PDEPEND="emacs? ( app-emacs/ruby-mode )
- xemacs? ( app-xemacs/ruby-modes )"
-
-PROVIDE="virtual/ruby"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- # Patch wrt bug #238061
- epatch "${FILESDIR}/${P}-rubygems-proxy.patch"
- # Patch for rubygems to find installed gems outside of the sandbox
- epatch "${FILESDIR}/${P}-rubygems-gentoo.patch"
-
- # Strip rake
- rm "bin/rake"
- rm "lib/rake.rb"
- rm -rf "lib/rake"
-
- # Fix a hardcoded lib path in configure script
- sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
- configure.in || die "sed failed"
-
- eautoreconf
-}
-
-src_compile() {
- # -fomit-frame-pointer makes ruby segfault, see bug #150413.
- filter-flags -fomit-frame-pointer
- # In many places aliasing rules are broken; play it safe
- # as it's risky with newer compilers to leave it as it is.
- append-flags -fno-strict-aliasing
-
- # Socks support via dante
- if use socks5 ; then
- # Socks support can't be disabled as long as SOCKS_SERVER is
- # set and socks library is present, so need to unset
- # SOCKS_SERVER in that case.
- unset SOCKS_SERVER
- fi
-
- # Increase GC_MALLOC_LIMIT if set (default is 8000000)
- if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
- append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
- fi
-
- econf --program-suffix=${MY_SUFFIX} --enable-shared --enable-pthread \
- $(use_enable socks5 socks) \
- $(use_enable doc install-doc) \
- $(use_enable ipv6) \
- $(use_enable debug) \
- $(use_with berkdb dbm) \
- $(use_with gdbm) \
- $(use_with ssl openssl) \
- $(use_with tk) \
- ${myconf} \
- --enable-option-checking=no \
- --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
- || die "econf failed"
-
- emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
-}
-
-src_test() {
- emake test || die "make test failed"
-
- elog "Ruby's make test has been run. Ruby also ships with a make check"
- elog "that cannot be run until after ruby has been installed."
- elog
- if use rubytests; then
- elog "You have enabled rubytests, so they will be installed to"
- elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
- elog "than root, and you must place them into a writeable directory."
- elog "Then call: "
- elog
- elog "ruby -C /location/of/tests runner.rb"
- else
- elog "Enable the rubytests USE flag to install the make check tests"
- fi
-}
-
-src_install() {
- # Ruby is involved in the install proces, we don't want interference here.
- unset RUBYOPT
-
- # Creating the rubygems directories, bug #230163 once more.
- local MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
- local ver=$(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['ruby_version']")
- keepdir /usr/$(get_libdir)/ruby${MY_SUFFIX}/gems/${ver}/{doc,gems,cache,specifications}
-
- export GEM_HOME="${ED}/usr/$(get_libdir)/ruby/gems/${ver}"
- export GEM_PATH="${GEM_HOME}/"
-
- LD_LIBRARY_PATH="${ED}/usr/$(get_libdir)"
- RUBYLIB="${S}:${ED}/usr/$(get_libdir)/ruby/${SLOT}"
- for d in $(find "${S}/ext" -type d) ; do
- RUBYLIB="${RUBYLIB}:$d"
- done
- export LD_LIBRARY_PATH RUBYLIB
-
- emake DESTDIR="${D}" install || die "make install failed"
-
-# Workaround for buggy install
-# see http://redmine.ruby-lang.org/issues/show/951
-rm -rf "${D}"/usr
-
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
-
- if use doc; then
- make DESTDIR="${D}" install-doc || die "make install-doc failed"
- fi
-
- if use examples; then
- dodir /usr/share/doc/${PF}
- cp -pPR sample "${ED}/usr/share/doc/${PF}"
- fi
-
- dosym "libruby${MY_SUFFIX}$(get_libname ${PV%_*})" \
- "/usr/$(get_libdir)/libruby$(get_libname ${PV%.*})"
- dosym "libruby${MY_SUFFIX}$(get_libname ${PV%_*})" \
- "/usr/$(get_libdir)/libruby$(get_libname ${PV%_*})"
-
- dodoc ChangeLog doc/NEWS-1.8.7 README* ToDo
-
- if use rubytests; then
- dodir /usr/share/${PN}-${SLOT}
- cp -pPR test "${ED}/usr/share/${PN}-${SLOT}"
- fi
-}
-
-pkg_postinst() {
- if [[ ! -n $(readlink "${EROOT}"usr/bin/ruby) ]] ; then
- eselect ruby set ruby${MY_SUFFIX}
- fi
-
- elog
- elog "This ebuild is compatible to eselect-ruby"
- elog "To switch between available Ruby profiles, execute as root:"
- elog "\teselect ruby set ruby(18|19|...)"
- elog
-}
-
-pkg_postrm() {
- if [[ ! -n $(readlink "${EROOT}"usr/bin/ruby) ]] ; then
- eselect ruby set ruby${MY_SUFFIX}
- fi
-}