summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'patchsets/patches-2.0.0_p647-r1/012_no_forced_sse2.patch')
-rw-r--r--patchsets/patches-2.0.0_p647-r1/012_no_forced_sse2.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/patchsets/patches-2.0.0_p647-r1/012_no_forced_sse2.patch b/patchsets/patches-2.0.0_p647-r1/012_no_forced_sse2.patch
new file mode 100644
index 0000000..dafb644
--- /dev/null
+++ b/patchsets/patches-2.0.0_p647-r1/012_no_forced_sse2.patch
@@ -0,0 +1,27 @@
+*** configure.in.orig Wed Nov 5 23:42:58 2014
+--- configure.in Wed Nov 5 23:56:37 2014
+***************
+*** 771,792 ****
+ for oflag in -fno-fast-math; do
+ RUBY_TRY_CFLAGS($oflag, [RUBY_APPEND_OPTION(optflags, $oflag)])
+ done
+- AS_CASE(["$target"],
+- [*-darwin*], [
+- # doesn't seem necessary on Mac OS X
+- ],
+- [[i[4-6]86*|i386*mingw*]], [
+- RUBY_TRY_CFLAGS(-msse2 -mfpmath=sse, [
+- RUBY_APPEND_OPTION(XCFLAGS, -msse2 -mfpmath=sse)
+- ])
+- AS_CASE(["$XCFLAGS"],
+- [[*-msse2*]], [
+- RUBY_TRY_CFLAGS(-mstackrealign, [
+- RUBY_APPEND_OPTION(XCFLAGS, -mstackrealign)
+- ])
+- ])
+- ]
+- )
+ fi
+
+ test -z "${ac_env_CFLAGS_set}" -a -n "${cflags+set}" && eval CFLAGS="\"$cflags $ARCH_FLAG\""
+--- 771,776 ----