aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-06-22 23:14:58 -0400
committerMike Gilbert <floppym@gentoo.org>2023-06-23 11:47:36 -0400
commit3ccc775d6f98c1917408bc3a370cfd6d3d789d50 (patch)
treebc7f49bfe6ba819beb50591e85b89df3ec6f85af
parentlibsandbox: wrap musl time64 functions (diff)
downloadsandbox-3ccc775d6f98c1917408bc3a370cfd6d3d789d50.tar.gz
sandbox-3ccc775d6f98c1917408bc3a370cfd6d3d789d50.tar.bz2
sandbox-3ccc775d6f98c1917408bc3a370cfd6d3d789d50.zip
configure: update libc grep expression
On Alpine, libc's SONAME is 'libc.musl-x86_64.so.1'. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a2a0355..5746702 100644
--- a/configure.ac
+++ b/configure.ac
@@ -378,7 +378,7 @@ echo "int main(void) { return 0; }" > libctest.c
$CC $CFLAGS $CPPFLAGS $LDFLAGS -o libctest libctest.c
LIBC_VERSION=$(
$READELF -d libctest | \
- $EGREP 'NEEDED.* \@<:@libc\.so' | \
+ $EGREP 'NEEDED.* \@<:@libc\..*so' | \
$AWK '{print $NF}' | [sed -e 's:\[::' -e 's:\]::']
)
rm -f libctest*