aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-21 15:57:05 +0100
committerSam James <sam@gentoo.org>2023-08-05 05:32:14 +0100
commitf342efa52fb54c55f009b694af1899e431300629 (patch)
treec817c32b45bf447d63032c8858ad08d518db4151 /libsandbox
parentlibsbutil: add sbio_faccessat and use it in sb_exists (diff)
downloadsandbox-f342efa52fb54c55f009b694af1899e431300629.tar.gz
sandbox-f342efa52fb54c55f009b694af1899e431300629.tar.bz2
sandbox-f342efa52fb54c55f009b694af1899e431300629.zip
Rename multiple personalities feature
"schizo" isn't a particularly sensitive term, and it's not very clear what it means to non-native English speakers anyway. Name it after what the feature really does: multiple (Linux) personality support using ptrace. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'libsandbox')
-rw-r--r--libsandbox/local.mk8
-rw-r--r--libsandbox/trace/common.c2
-rw-r--r--libsandbox/trace/linux/i386.c2
-rw-r--r--libsandbox/trace/linux/s390.c6
-rw-r--r--libsandbox/trace/linux/sparc.c6
-rw-r--r--libsandbox/trace/linux/x86_64.c8
6 files changed, 16 insertions, 16 deletions
diff --git a/libsandbox/local.mk b/libsandbox/local.mk
index 50bc54d..dd78a76 100644
--- a/libsandbox/local.mk
+++ b/libsandbox/local.mk
@@ -76,17 +76,17 @@ TRACE_MAKE_HEADER = \
$(SB_AWK) $(GEN_TRACE_SCRIPT) -v MODE=gen | \
$(COMPILE) -E -P -include $(top_srcdir)/headers.h - $$f | \
$(SB_AWK) $(GEN_TRACE_SCRIPT) -v syscall_prefix=$$t > $$header
-%D%/trace_syscalls.h: $(SYMBOLS_FILE) $(GEN_TRACE_SCRIPT) $(SB_SCHIZO_HEADERS)
+%D%/trace_syscalls.h: $(SYMBOLS_FILE) $(GEN_TRACE_SCRIPT) $(SB_PERSONALITIES_HEADERS)
@$(MKDIR_P) %D%
-if SB_SCHIZO
+if SB_PERSONALITIES
$(AM_V_GEN)touch $@
else
$(AM_V_GEN)t= f= header=$@; $(TRACE_MAKE_HEADER)
endif
-$(SB_SCHIZO_HEADERS): $(SYMBOLS_FILE) $(GEN_TRACE_SCRIPT)
+$(SB_PERSONALITIES_HEADERS): $(SYMBOLS_FILE) $(GEN_TRACE_SCRIPT)
@$(MKDIR_P) %D%
- $(AM_V_GEN)for pers in $(SB_SCHIZO_SETTINGS) ; do \
+ $(AM_V_GEN)for pers in $(SB_PERSONALITIES_SETTINGS) ; do \
t=_$${pers%:*}; \
f=$${pers#*:}; \
header="%D%/trace_syscalls$${t}.h"; \
diff --git a/libsandbox/trace/common.c b/libsandbox/trace/common.c
index f426887..767839a 100644
--- a/libsandbox/trace/common.c
+++ b/libsandbox/trace/common.c
@@ -7,7 +7,7 @@ static int trace_get_sysnum(void *vregs);
static long trace_raw_ret(void *vregs);
static unsigned long trace_arg(void *vregs, int num);
-#ifndef SB_SCHIZO
+#ifndef SB_PERSONALITIES
static const struct syscall_entry syscall_table[] = {
#define S(s) { SB_SYS_##s, SB_NR_##s, #s },
#include "trace_syscalls.h"
diff --git a/libsandbox/trace/linux/i386.c b/libsandbox/trace/linux/i386.c
index f9476aa..722efb4 100644
--- a/libsandbox/trace/linux/i386.c
+++ b/libsandbox/trace/linux/i386.c
@@ -8,7 +8,7 @@ static bool _trace_possible(const void *data)
(ehdr->e_machine == EM_386);
}
-#ifdef SB_SCHIZO
+#ifdef SB_PERSONALITIES
static const struct syscall_entry syscall_table[] = {
#define S(s) { SB_SYS_x86_##s, SB_NR_##s, #s },
#include "trace_syscalls_x86.h"
diff --git a/libsandbox/trace/linux/s390.c b/libsandbox/trace/linux/s390.c
index acbf894..2c7a9be 100644
--- a/libsandbox/trace/linux/s390.c
+++ b/libsandbox/trace/linux/s390.c
@@ -1,10 +1,10 @@
#undef _trace_possible
#define _trace_possible _trace_possible
-#ifdef SB_SCHIZO
+#ifdef SB_PERSONALITIES
static const struct syscall_entry syscall_table_32[] = {
-#ifdef SB_SCHIZO_s390
+#ifdef SB_PERSONALITIES_s390
#define S(s) { SB_SYS_s390_##s, SB_NR_##s, #s },
#include "trace_syscalls_s390.h"
#undef S
@@ -12,7 +12,7 @@ static const struct syscall_entry syscall_table_32[] = {
{ SB_NR_UNDEF, SB_NR_UNDEF, NULL },
};
static const struct syscall_entry syscall_table_64[] = {
-#ifdef SB_SCHIZO_s390x
+#ifdef SB_PERSONALITIES_s390x
#define S(s) { SB_SYS_s390x_##s, SB_NR_##s, #s },
#include "trace_syscalls_s390x.h"
#undef S
diff --git a/libsandbox/trace/linux/sparc.c b/libsandbox/trace/linux/sparc.c
index 36d737a..6050dc9 100644
--- a/libsandbox/trace/linux/sparc.c
+++ b/libsandbox/trace/linux/sparc.c
@@ -16,10 +16,10 @@
#undef _trace_possible
#define _trace_possible _trace_possible
-#ifdef SB_SCHIZO
+#ifdef SB_PERSONALITIES
static const struct syscall_entry syscall_table_32[] = {
-#ifdef SB_SCHIZO_sparc
+#ifdef SB_PERSONALITIES_sparc
#define S(s) { SB_SYS_sparc_##s, SB_NR_##s, #s },
#include "trace_syscalls_sparc.h"
#undef S
@@ -27,7 +27,7 @@ static const struct syscall_entry syscall_table_32[] = {
{ SB_NR_UNDEF, SB_NR_UNDEF, NULL },
};
static const struct syscall_entry syscall_table_64[] = {
-#ifdef SB_SCHIZO_sparc64
+#ifdef SB_PERSONALITIES_sparc64
#define S(s) { SB_SYS_sparc64_##s, SB_NR_##s, #s },
#include "trace_syscalls_sparc64.h"
#undef S
diff --git a/libsandbox/trace/linux/x86_64.c b/libsandbox/trace/linux/x86_64.c
index aff1edb..d01e00f 100644
--- a/libsandbox/trace/linux/x86_64.c
+++ b/libsandbox/trace/linux/x86_64.c
@@ -1,10 +1,10 @@
#undef _trace_possible
#define _trace_possible _trace_possible
-#ifdef SB_SCHIZO
+#ifdef SB_PERSONALITIES
static const struct syscall_entry syscall_table_32[] = {
-#ifdef SB_SCHIZO_x86
+#ifdef SB_PERSONALITIES_x86
#define S(s) { SB_SYS_x86_##s, SB_NR_##s, #s },
#include "trace_syscalls_x86.h"
#undef S
@@ -12,7 +12,7 @@ static const struct syscall_entry syscall_table_32[] = {
{ SB_NR_UNDEF, SB_NR_UNDEF, NULL },
};
static const struct syscall_entry syscall_table_64[] = {
-#ifdef SB_SCHIZO_x86_64
+#ifdef SB_PERSONALITIES_x86_64
#define S(s) { SB_SYS_x86_64_##s, SB_NR_##s, #s },
#include "trace_syscalls_x86_64.h"
#undef S
@@ -20,7 +20,7 @@ static const struct syscall_entry syscall_table_64[] = {
{ SB_NR_UNDEF, SB_NR_UNDEF, NULL },
};
static const struct syscall_entry syscall_table_x32[] = {
-#ifdef SB_SCHIZO_x32
+#ifdef SB_PERSONALITIES_x32
#define S(s) { SB_SYS_x32_##s, SB_NR_##s, #s },
#include "trace_syscalls_x32.h"
#undef S