aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-10-21 02:50:34 -0400
committerMike Frysinger <vapier@gentoo.org>2021-10-21 02:50:34 -0400
commite20993aae51de13bfc4028105aa7756771046c64 (patch)
tree8e56347ad5c050a8e026aeffbe687600081187d8 /libsbutil
parentbuild: require automake-1.15 (diff)
downloadsandbox-e20993aae51de13bfc4028105aa7756771046c64.tar.gz
sandbox-e20993aae51de13bfc4028105aa7756771046c64.tar.bz2
sandbox-e20993aae51de13bfc4028105aa7756771046c64.zip
build: flatten build a bit to avoid (most) recursive make
Provides a bit of a speed up. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'libsbutil')
-rw-r--r--libsbutil/Makefile4
-rw-r--r--libsbutil/Makefile.am71
-rw-r--r--libsbutil/local.mk65
3 files changed, 69 insertions, 71 deletions
diff --git a/libsbutil/Makefile b/libsbutil/Makefile
new file mode 100644
index 0000000..608bccf
--- /dev/null
+++ b/libsbutil/Makefile
@@ -0,0 +1,4 @@
+# Helper for developers.
+all libsbutil: libsbutil/libsbutil.la ;
+clean: ; rm -f *.o *.l[ao] .libs/*
+%: ; $(MAKE) -C .. $@
diff --git a/libsbutil/Makefile.am b/libsbutil/Makefile.am
deleted file mode 100644
index 06de7d3..0000000
--- a/libsbutil/Makefile.am
+++ /dev/null
@@ -1,71 +0,0 @@
-AUTOMAKE_OPTIONS = foreign
-
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -I$(srcdir)/include \
- $(SANDBOX_DEFINES)
-
-LOCAL_INCLUDES = $(top_srcdir)/localdecls.h
-
-noinst_LTLIBRARIES = libsbutil.la
-
-libsbutil_la_LDFLAGS = -no-undefined
-libsbutil_la_SOURCES = \
- sbutil.h \
- get_sandbox_conf.c \
- get_sandbox_confd.c \
- get_sandbox_lib.c \
- get_sandbox_rc.c \
- get_sandbox_log.c \
- get_tmp_dir.c \
- environment.c \
- sb_backtrace.c \
- sb_efuncs.c \
- sb_gdb.c \
- sb_method.c \
- sb_open.c \
- sb_read.c \
- sb_write.c \
- sb_write_fd.c \
- sb_close.c \
- sb_printf.c \
- sb_proc.c \
- sb_memory.c \
- include/rcscripts/rcutil.h \
- include/rcscripts/util/str_list.h \
- include/rcscripts/util/debug.h \
- src/debug.c \
- include/rcscripts/util/string.h \
- src/string.c \
- include/rcscripts/util/file.h \
- src/file.c \
- include/rcscripts/util/config.h \
- src/config.c \
- include/rcscripts/util/dynbuf.h \
- src/dynbuf.c \
- gnulib/areadlink.h \
- gnulib/areadlink-with-size.c \
- gnulib/bitrotate.c \
- gnulib/bitrotate.h \
- gnulib/canonicalize.c \
- gnulib/canonicalize.h \
- gnulib/careadlinkat.h \
- gnulib/dosname.h \
- gnulib/file-set.c \
- gnulib/file-set.h \
- gnulib/gl-inline.h \
- gnulib/glue.h \
- gnulib/hash.c \
- gnulib/hash.h \
- gnulib/hash-pjw.c \
- gnulib/hash-pjw.h \
- gnulib/hash-triple.c \
- gnulib/hash-triple.h \
- gnulib/pathmax.h \
- gnulib/same-inode.h \
- gnulib/xalloc.h \
- gnulib/xalloc-oversized.h \
- gnulib/xgetcwd.h \
- $(LOCAL_INCLUDES)
-
-EXTRA_DIST = headers.h
diff --git a/libsbutil/local.mk b/libsbutil/local.mk
new file mode 100644
index 0000000..d1a9ffd
--- /dev/null
+++ b/libsbutil/local.mk
@@ -0,0 +1,65 @@
+noinst_LTLIBRARIES += %D%/libsbutil.la
+
+%C%_libsbutil_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/%D% \
+ -I$(top_srcdir)/%D%/include
+%C%_libsbutil_la_LDFLAGS = -no-undefined
+%C%_libsbutil_la_SOURCES = \
+ %D%/sbutil.h \
+ %D%/get_sandbox_conf.c \
+ %D%/get_sandbox_confd.c \
+ %D%/get_sandbox_lib.c \
+ %D%/get_sandbox_rc.c \
+ %D%/get_sandbox_log.c \
+ %D%/get_tmp_dir.c \
+ %D%/environment.c \
+ %D%/headers.h \
+ %D%/sb_backtrace.c \
+ %D%/sb_efuncs.c \
+ %D%/sb_gdb.c \
+ %D%/sb_method.c \
+ %D%/sb_open.c \
+ %D%/sb_read.c \
+ %D%/sb_write.c \
+ %D%/sb_write_fd.c \
+ %D%/sb_close.c \
+ %D%/sb_printf.c \
+ %D%/sb_proc.c \
+ %D%/sb_memory.c \
+ %D%/include/rcscripts/rcutil.h \
+ %D%/include/rcscripts/util/str_list.h \
+ %D%/include/rcscripts/util/debug.h \
+ %D%/src/debug.c \
+ %D%/include/rcscripts/util/string.h \
+ %D%/src/string.c \
+ %D%/include/rcscripts/util/file.h \
+ %D%/src/file.c \
+ %D%/include/rcscripts/util/config.h \
+ %D%/src/config.c \
+ %D%/include/rcscripts/util/dynbuf.h \
+ %D%/src/dynbuf.c \
+ %D%/gnulib/areadlink.h \
+ %D%/gnulib/areadlink-with-size.c \
+ %D%/gnulib/bitrotate.c \
+ %D%/gnulib/bitrotate.h \
+ %D%/gnulib/canonicalize.c \
+ %D%/gnulib/canonicalize.h \
+ %D%/gnulib/careadlinkat.h \
+ %D%/gnulib/dosname.h \
+ %D%/gnulib/file-set.c \
+ %D%/gnulib/file-set.h \
+ %D%/gnulib/gl-inline.h \
+ %D%/gnulib/glue.h \
+ %D%/gnulib/hash.c \
+ %D%/gnulib/hash.h \
+ %D%/gnulib/hash-pjw.c \
+ %D%/gnulib/hash-pjw.h \
+ %D%/gnulib/hash-triple.c \
+ %D%/gnulib/hash-triple.h \
+ %D%/gnulib/pathmax.h \
+ %D%/gnulib/same-inode.h \
+ %D%/gnulib/xalloc.h \
+ %D%/gnulib/xalloc-oversized.h \
+ %D%/gnulib/xgetcwd.h