aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Schubert <mschu.dev@gmail.com>2024-06-17 21:41:28 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-06-19 12:14:20 +0200
commit3b35ba4701f827a3a101f3517d0eb2122b41785c (patch)
tree8b37e2c97bd7f3b95b2d81d88b61f1f31ef380d0
parentdev-python/google-cloud-storage: version bump 2.17.0 (diff)
downloadsci-3b35ba4701f827a3a101f3517d0eb2122b41785c.tar.gz
sci-3b35ba4701f827a3a101f3517d0eb2122b41785c.tar.bz2
sci-3b35ba4701f827a3a101f3517d0eb2122b41785c.zip
dev-python/smart-open: py3.12 compat; disable tests (broken in py3.11)
upstream URL update is automatic forward Signed-off-by: Michael Schubert <mschu.dev@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/smart-open/smart-open-6.3.0.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/smart-open/smart-open-6.3.0.ebuild b/dev-python/smart-open/smart-open-6.3.0.ebuild
index b585f1d4b..f61752492 100644
--- a/dev-python/smart-open/smart-open-6.3.0.ebuild
+++ b/dev-python/smart-open/smart-open-6.3.0.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
DESCRIPTION="Utils for streaming large files (S3, HDFS, gzip, bz2...) "
-HOMEPAGE="https://github.com/RaRe-Technologies/smart_open"
-SRC_URI="https://github.com/RaRe-Technologies/smart_open/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="https://github.com/piskvorky/smart_open"
+SRC_URI="https://github.com/piskvorky/smart_open/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
S="${WORKDIR}/${PN//-/_}-${PV}"
LICENSE="MIT"
@@ -26,10 +26,11 @@ RDEPEND="
BDEPEND="
test? (
- dev-python/moto[${PYTHON_USEDEP}]
+ <dev-python/moto-5[${PYTHON_USEDEP}]
dev-python/responses[${PYTHON_USEDEP}]
dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
)
"
+RESTRICT="test" # 329 tests, 1 error: missing azure-storage-blob, azure-common[no ebuild], azure-core
distutils_enable_tests pytest