aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Schubert <mschu.dev@gmail.com>2024-06-12 11:21:56 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-06-19 11:24:02 +0200
commit968ecda4bf1c56d55a2812fc8f9a2a4918030255 (patch)
treeee8db8f55c980e99a48aba7ac413abf6d29c643e
parent*/*: drop distutils_enable_tests --install (diff)
downloadsci-968ecda4bf1c56d55a2812fc8f9a2a4918030255.tar.gz
sci-968ecda4bf1c56d55a2812fc8f9a2a4918030255.tar.bz2
sci-968ecda4bf1c56d55a2812fc8f9a2a4918030255.zip
sci-biology/multiqc: version bump 1.22.2
Signed-off-by: Michael Schubert <mschu.dev@gmail.com> Closes: https://github.com/gentoo/sci/pull/1277 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--profiles/package.mask4
-rw-r--r--sci-biology/multiqc/Manifest2
-rw-r--r--sci-biology/multiqc/multiqc-1.19.ebuild40
-rw-r--r--sci-biology/multiqc/multiqc-1.22.2.ebuild42
4 files changed, 43 insertions, 45 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 48068ccf9..1b622a85b 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -31,8 +31,4 @@
#--- END OF EXAMPLES ---
# Andrew Ammerlaan <andrewammerlaan@gentoo.org> (2024-04-24)
-# Dependencies dev-python/future removed
-sci-biology/multiqc
-
-# Andrew Ammerlaan <andrewammerlaan@gentoo.org> (2024-04-24)
# reverse deps
diff --git a/sci-biology/multiqc/Manifest b/sci-biology/multiqc/Manifest
index 3585038a3..77bfbc723 100644
--- a/sci-biology/multiqc/Manifest
+++ b/sci-biology/multiqc/Manifest
@@ -1 +1 @@
-DIST multiqc-1.19.tar.gz 1159781 BLAKE2B 32d592dba5675f8cb673c8fced9f8ed32977ecd2baf1407aff4ef16b88d8bdad6a9541748717b90d5ab755f6354166e2de62cb1abd282d0e5ce9d1c89529d249 SHA512 75ef5a1b6c6433d68b878e2a1d51b6f420b8c77831cb1279a0b87aff5d6dee7a65bcca5d1f4deb04d4957feef0f27a1155198e244bd165404b08a23bfc8a9354
+DIST multiqc-1.22.2.gh.tar.gz 5611004 BLAKE2B 238af92830fe903b09651701072053a4d09de7ff626894b51d246ac53c02e86955690d3b072961833648574ae07412f03fdafd0f39e629c574eb0346cdd95710 SHA512 cf4a448bd353cbd38e7f585c9c62f68481d3fa919edf0a974d3448782134e14e6f210cedbac0e59235a2813166d07b9a407e17e7eb1904176406cc4326182699
diff --git a/sci-biology/multiqc/multiqc-1.19.ebuild b/sci-biology/multiqc/multiqc-1.19.ebuild
deleted file mode 100644
index 187f06c22..000000000
--- a/sci-biology/multiqc/multiqc-1.19.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit pypi distutils-r1
-
-DESCRIPTION="Aggregate bioinformatics results across many samples into a single report"
-HOMEPAGE="https://multiqc.info/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~amd64-linux"
-
-RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/coloredlogs[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/lzstring[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- dev-python/rich-click[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/spectra[${PYTHON_USEDEP}]
- dev-python/importlib-metadata[$PYTHON_USEDEP]
- dev-python/humanize[$PYTHON_USEDEP]
- dev-python/pyaml-env[$PYTHON_USEDEP]"
-
-# pypi tarball does not include tests
-RESTRICT="test"
-#distutils_enable_tests pytest
diff --git a/sci-biology/multiqc/multiqc-1.22.2.ebuild b/sci-biology/multiqc/multiqc-1.22.2.ebuild
new file mode 100644
index 000000000..bf45065aa
--- /dev/null
+++ b/sci-biology/multiqc/multiqc-1.22.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Aggregate bioinformatics results across many samples into a single report"
+HOMEPAGE="https://multiqc.info/"
+SRC_URI="https://github.com/MultiQC/MultiQC/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/MultiQC-${PV}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.0[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/pillow-10[${PYTHON_USEDEP}]
+ >=dev-python/plotly-5.18[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-4[${PYTHON_USEDEP}]
+ dev-python/pyaml-env[${PYTHON_USEDEP}]
+ >=dev-python/rich-10[${PYTHON_USEDEP}]
+ dev-python/rich-click[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ >=dev-python/spectra-0.0.10[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.7.1[${PYTHON_USEDEP}]
+ dev-python/typeguard[${PYTHON_USEDEP}]"
+# dev-python/kaleido[${PYTHON_USEDEP}] # tested and is optional
+
+RESTRICT="test" # no items collected
+#distutils_enable_tests pytest