aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Schubert <mschu.dev@gmail.com>2024-11-11 13:44:34 +0000
committerNowa Ammerlaan <nowa@gentoo.org>2025-02-06 15:07:05 +0100
commitfd72ee27112668a2c69ec909cc20bf1a19fc24cb (patch)
tree478076097833c04e670e8a37c7b7dc38618b7751
parentdev-python/snakemake-interface-storage-plugins: version bump 3.3.0 (diff)
downloadsci-fd72ee27112668a2c69ec909cc20bf1a19fc24cb.tar.gz
sci-fd72ee27112668a2c69ec909cc20bf1a19fc24cb.tar.bz2
sci-fd72ee27112668a2c69ec909cc20bf1a19fc24cb.zip
dev-python/snakemake: version bump 8.25.3 and enable tests
Signed-off-by: Michael Schubert <mschu.dev@gmail.com> Closes: https://github.com/gentoo/sci/pull/1296 Signed-off-by: Nowa Ammerlaan <nowa@gentoo.org>
-rw-r--r--dev-python/snakemake/Manifest2
-rw-r--r--dev-python/snakemake/snakemake-8.25.3.ebuild (renamed from dev-python/snakemake/snakemake-8.16.0.ebuild)33
2 files changed, 16 insertions, 19 deletions
diff --git a/dev-python/snakemake/Manifest b/dev-python/snakemake/Manifest
index de4027537..48490208a 100644
--- a/dev-python/snakemake/Manifest
+++ b/dev-python/snakemake/Manifest
@@ -1,2 +1,2 @@
DIST snakemake-7.32.4.gh.tar.gz 8885863 BLAKE2B 6bb7ff4722dd06f0edf5e8079b42f5e54d6f55f41e2987b7dae7f9b75df0d4d836138e28340e5977107a5cc0b5afe793b0d7897c501246cc1b4340eb4eca2f17 SHA512 34fef61528b18facab798652c88ed5c698ef02161e023255fdd024b7c7781c4e582cdb04b2740fdff9b6f3600acaec719742984acee57920bb48ef3b5af99d9a
-DIST snakemake-8.16.0.gh.tar.gz 8665306 BLAKE2B 76d3455ce9a7ccc749adb5a729ab954d7a3fd97dc2432c3a0e9aba1ace1cb08e377244a2a2527c676b9709f9bb8b5af29948c0385657755bbbc8449b136fc26d SHA512 29b6ba6da5dbbd347dee45114b949c976973555c9234f8a150dcd83e4af1638c1773590320bc44284cf20ea445efb377dcf9199921ed2b4d62bad3a60a41af3c
+DIST snakemake-8.25.3.gh.tar.gz 8693083 BLAKE2B 8d5070d5c78f560bc714da189454776ea87a8403075da98b45b021ac304053cb08763c929846d4c8f949c71245566bdb012b78d8807f40a584805cd08917af14 SHA512 f769c89e98130c738bb43931f240eaa93482d19403c6bcda65334910ccf4cac2e11257ed8b133d220d645ea39b0af8aa580fe24c57221478ea7dd0fb4d21d4e7
diff --git a/dev-python/snakemake/snakemake-8.16.0.ebuild b/dev-python/snakemake/snakemake-8.25.3.ebuild
index f204537d1..180f32309 100644
--- a/dev-python/snakemake/snakemake-8.16.0.ebuild
+++ b/dev-python/snakemake/snakemake-8.25.3.ebuild
@@ -16,21 +16,6 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-# cannot import name '_helpers' from 'google.cloud'
-RESTRICT="test"
-
-BDEPEND="
- dev-python/tomli[${PYTHON_USEDEP}]
- test? (
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/google-api-python-client[${PYTHON_USEDEP}]
- dev-python/networkx[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
- net-libs/google-cloud-cpp
- )
-"
-
RDEPEND="
dev-python/appdirs[${PYTHON_USEDEP}]
dev-python/immutables[${PYTHON_USEDEP}]
@@ -50,13 +35,12 @@ RDEPEND="
dev-python/reretry[${PYTHON_USEDEP}]
>=dev-python/smart-open-4.0[${PYTHON_USEDEP}]
>=dev-python/snakemake-interface-common-1.17.0[${PYTHON_USEDEP}]
- >=dev-python/snakemake-interface-executor-plugins-9.2.0[${PYTHON_USEDEP}]
+ >=dev-python/snakemake-interface-executor-plugins-9.3.2[${PYTHON_USEDEP}]
>=dev-python/snakemake-interface-storage-plugins-3.2.3[${PYTHON_USEDEP}]
- >=dev-python/snakemake-interface-report-plugins-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/snakemake-interface-report-plugins-1.1.0[${PYTHON_USEDEP}]
dev-python/stopit[${PYTHON_USEDEP}]
dev-python/tabulate[${PYTHON_USEDEP}]
dev-python/throttler[${PYTHON_USEDEP}]
- >=dev-python/toposort-1.10[${PYTHON_USEDEP}]
dev-python/wrapt[${PYTHON_USEDEP}]
>=dev-python/yte-1.5.1[${PYTHON_USEDEP}]
>=dev-python/dpath-2.1.6[${PYTHON_USEDEP}]
@@ -71,4 +55,17 @@ RDEPEND="
# dev-python/docutils \
# dev-python/recommonmark \
# dev-python/myst-parser
+
+EPYTEST_IGNORE=(
+ # __file__ attribute does not match test name ('python_3_7')
+ tests/test_conda_python_3_7_script/test_script.py
+ # ModuleNotFoundError: No module named 'snakemake_executor_plugin_cluster_generic'
+ tests/test_executor_test_suite.py
+ # ImportError: cannot import name 'snakemake' from 'snakemake.script'
+ tests/test_script_py/scripts/test_explicit_import.py
+)
+EPYTEST_DESELECT=(
+ # No module named 'snakemake_storage_plugin_s3'
+ tests/test_api.py::test_deploy_sources
+)
distutils_enable_tests pytest