aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2022-02-12 18:34:21 -0800
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-13 16:55:43 +0100
commit23c143b3221d41a5260b684c721d8d7d557f1dff (patch)
treed7e217734ffc7391d627699809672924a05c281d /app-office
parentsci-biology/mmseqs2: properly respect the cpu flags (diff)
downloadsci-23c143b3221d41a5260b684c721d8d7d557f1dff.tar.gz
sci-23c143b3221d41a5260b684c721d8d7d557f1dff.tar.bz2
sci-23c143b3221d41a5260b684c721d8d7d557f1dff.zip
app-office/visidata: Bump to 2.8
Additional changes in this revision: - drop Python3.7 support - update to EAPI8 Bug: https://bugs.gentoo.org/833255 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/visidata/Manifest1
-rw-r--r--app-office/visidata/visidata-2.8.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/app-office/visidata/Manifest b/app-office/visidata/Manifest
index 42921ce64..26bfdd8a4 100644
--- a/app-office/visidata/Manifest
+++ b/app-office/visidata/Manifest
@@ -1,2 +1,3 @@
DIST visidata-1.5.2.tar.gz 637598 BLAKE2B 47ef05280cec9fdb3620759b7c2089de7d2e42a4a1d1a13d14b5e59555c8de6091ceab1fb72ab4ee45dc7611741ffdc6eeefcab5e4755485b6d18d48327fe639 SHA512 36f11c207f391d06095dfab75fe4a638e562cd20bc29f72a6e5df1dcc87ab46f2834ffbdb561fb9e4e07fdd50dc5b34c619bbc4bc3d34ce350428e7330ea252c
DIST visidata-2.1.1.tar.gz 952448 BLAKE2B c58378b9d653b50532f4f7209d08fbe4146a91907e7ca145580254784ea676b74554e9a8be69f7ae86842bf9548b16e28aa04fc8ecd42bfaee2f28e908cdddb9 SHA512 ade237622a1ac394fa2f287994c439330560062327b32a26adf129e3cae548a883ab1e76698233136aa6368b1823c4914e6912031c5b4221283d224ad2852bc7
+DIST visidata-2.8.tar.gz 1791958 BLAKE2B f7a7dec514bcca37b4ee6ee9c16eb07a625b83e601a5bcf1ca5589a462e50086cbd9997238230ac464b4dc77e9deb421d3ff0bcf0fa39b32f1c1ce0308d2cb7b SHA512 da9bce4e59054ea518024639a1f60d6f19886cd061a52aa49189d7478ea27950e6e97e0d1730456b65815f9298d0225bfcebe4bba5452e1a9a87f5f56aa11dc3
diff --git a/app-office/visidata/visidata-2.8.ebuild b/app-office/visidata/visidata-2.8.ebuild
new file mode 100644
index 000000000..4fe822aa8
--- /dev/null
+++ b/app-office/visidata/visidata-2.8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Terminal spreadsheet multitool for discovering and arranging data"
+HOMEPAGE="http://visidata.org"
+SRC_URI="https://github.com/saulpw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+#distutils_enable_sphinx docs \
+# dev-python/recommonmark \
+# dev-python/sphinx-argparse
+# dev-python/sphinx-markdown-tables
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ rm tests/load-http.vd || die "Could not remove network-dependent test."
+ rm tests/graph-cursor-nosave.vd || die "Could not remove network-dependent test."
+ rm tests/messenger-nosave.vd || die "Could not remove network-dependent test."
+ rm tests/save-benchmarks.vd || die "Could not benchmarks test"
+ rm tests/graph-sincos-nosave.vd || die "Could not benchmarks test"
+ rm tests/graphpr-nosave.vd || die "Could not benchmarks test"
+ rm tests/describe-error.vd || die "Could not remove network-dependent test"
+ rm tests/describe.vd || die "Could not remove network-dependent test"
+ rm tests/edit-type.vd || die "Could not remove network-dependent test"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ git init || die "Git init failed."
+ git add tests/golden/ || die "Git add failed."
+ # this test script eventually calls pytest under the hood
+ dev/test.sh || die "Tests failed."
+ rm .git -rf || die "Could not clean up git test directory."
+}
+
+pkg_postinst() {
+ optfeature "integration with yaml" >=dev-python/pyyaml-5.1
+ optfeature "integration with pcap" dev-python/dnslib #dpkt pypcapkit
+ optfeature "integration with png" dev-python/pypng
+ optfeature "integration with http" dev-python/requests
+ optfeature "integration with postgres" dev-python/psycopg-binary
+ optfeature "integration with xlsx" dev-python/openpyxl
+ optfeature "integration with xls" dev-python/xlrd
+ optfeature "integration with hdf5" dev-python/h5py
+ optfeature "integration with ttf/otf" dev-python/fonttools
+ optfeature "integration with xml/htm/html" dev-python/lxml
+ optfeature "integration with dta (Stata)" dev-python/pandas
+ optfeature "integration with shapefiles" sci-libs/pyshp
+ optfeature "integration with namestand" dev-python/graphviz
+ optfeature "integration with pdfminer.six" dev-python/pdfminer-six # in guru
+ optfeature "integration with vobject" dev-python/vobject
+ optfeature "integration with tabulate" dev-python/tabulate
+ optfeature "integration with tabulate (with unicode)" dev-python/wcwidth
+ # optfeature "pdf tables" tabula # no package presently
+ #optfeature "integration with mbtiles" mapbox-vector-tile
+ #optfeature "integration with xpt (SAS)" xport
+ #optfeature "integration with sas7bdat (SAS)" sas7bdat
+ #optfeature "integration with sav (SPSS)" savReaderWriter
+}