aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-25 01:03:13 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-09-25 01:03:13 +0000
commit7ce5b720ea7f349099011709d47e0ff67b3087cd (patch)
tree7f78b522ec7d365a1f59d12bc28527c63abed1ea /dev-cpp
parentdev-ml/mlgmpidl: drop dead package (diff)
downloadsci-7ce5b720ea7f349099011709d47e0ff67b3087cd.tar.gz
sci-7ce5b720ea7f349099011709d47e0ff67b3087cd.tar.bz2
sci-7ce5b720ea7f349099011709d47e0ff67b3087cd.zip
dev-cpp/thrust: C++ parallel algorithms library
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/thrust/Manifest1
-rw-r--r--dev-cpp/thrust/metadata.xml12
-rw-r--r--dev-cpp/thrust/thrust-1.10.0.ebuild24
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-cpp/thrust/Manifest b/dev-cpp/thrust/Manifest
new file mode 100644
index 000000000..7e9fe43a5
--- /dev/null
+++ b/dev-cpp/thrust/Manifest
@@ -0,0 +1 @@
+DIST thrust-1.10.0.tar.gz 944923 BLAKE2B 25c6728bc1e2e5bcb3647829db69a74d4747181e58d76fcfc9e5d679ea7261b2a4ecb61b67b4655af6b5934a272f57739f1cb1c1f56b872e5a8db1e6f5d24af6 SHA512 0bee941e06247c798a79299dffb1c2952aee1ac1c6ccc8392b17521b8c3f43d7db82ef44aea9917e4f327f62de8fef937c5f0ccdbae13f8a0e85b5f2b40e72b4
diff --git a/dev-cpp/thrust/metadata.xml b/dev-cpp/thrust/metadata.xml
new file mode 100644
index 000000000..0ee446868
--- /dev/null
+++ b/dev-cpp/thrust/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-cpp/thrust/thrust-1.10.0.ebuild b/dev-cpp/thrust/thrust-1.10.0.ebuild
new file mode 100644
index 000000000..e4792c997
--- /dev/null
+++ b/dev-cpp/thrust/thrust-1.10.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ parallel agorithms library"
+HOMEPAGE="https://github.com/NVIDIA/thrust"
+SRC_URI="https://github.com/NVIDIA/thrust/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ local mycmakeargs=(
+ -DTHRUST_ENABLE_HEADER_TESTING=OFF
+ -DTHRUST_ENABLE_TESTING=OFF
+ -DTHRUST_ENABLE_EXAMPLES=OFF
+ -DTHRUST_INCLUDE_CUB_CMAKE=OFF
+ )
+ cmake_src_configure
+}