aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-04 16:19:38 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-04 16:19:38 +0100
commit1a2a8921c045392f417a367a7e90d3ba7d5514ed (patch)
treeb4b9a0202eaecaccaf0e87029dd27db65ed919b9 /dev-java
parentdev-libs/cudnn: 8.3.1.22 TODO: cuda 10.2 support maybe (diff)
downloadsci-1a2a8921c045392f417a367a7e90d3ba7d5514ed.tar.gz
sci-1a2a8921c045392f417a367a7e90d3ba7d5514ed.tar.bz2
sci-1a2a8921c045392f417a367a7e90d3ba7d5514ed.zip
dev-java/lucene: update icu4j requirement
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/lucene/lucene-3.6.2-r2.ebuild6
-rw-r--r--dev-java/lucene/lucene-5.2.1.ebuild8
-rw-r--r--dev-java/lucene/lucene-8.4.0.ebuild8
3 files changed, 11 insertions, 11 deletions
diff --git a/dev-java/lucene/lucene-3.6.2-r2.ebuild b/dev-java/lucene/lucene-3.6.2-r2.ebuild
index 31fd5ed60..bdec54f4c 100644
--- a/dev-java/lucene/lucene-3.6.2-r2.ebuild
+++ b/dev-java/lucene/lucene-3.6.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,7 +31,7 @@ CDEPEND="
dev-java/commons-logging:0
dev-java/commons-beanutils:1.7
dev-java/commons-codec:0
- dev-java/icu4j:52
+ dev-java/icu4j:70
)"
DEPEND="
@@ -119,7 +119,7 @@ src_compile() {
commons-logging
commons-beanutils-1.7
commons-codec
- icu4j-52
+ icu4j-70
"
EANT_BUILD_TARGET+=" build-contrib"
EANT_DOC_TARGET+=" javadocs-all"
diff --git a/dev-java/lucene/lucene-5.2.1.ebuild b/dev-java/lucene/lucene-5.2.1.ebuild
index 6c7e3aed3..e6cea2888 100644
--- a/dev-java/lucene/lucene-5.2.1.ebuild
+++ b/dev-java/lucene/lucene-5.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,7 +35,7 @@ CDEPEND="
dev-java/commons-logging:0
dev-java/commons-beanutils:1.7
dev-java/commons-codec:0
- dev-java/icu4j:52
+ dev-java/icu4j:70
dev-java/log4j:0
)"
@@ -114,7 +114,7 @@ src_prepare() {
if use modules; then
mkdir -p analysis/icu/lib
- java-pkg_jar-from --into analysis/icu/lib icu4j-52
+ java-pkg_jar-from --into analysis/icu/lib icu4j-70
# disable morfologik, dependency does not build
# disable uima, dependency does not build
# disable phonetic, dependency does not exist
@@ -171,7 +171,7 @@ src_compile() {
commons-logging
commons-beanutils-1.7
commons-codec
- icu4j-52
+ icu4j-70
log4j
"
EANT_BUILD_TARGET+=" build-modules"
diff --git a/dev-java/lucene/lucene-8.4.0.ebuild b/dev-java/lucene/lucene-8.4.0.ebuild
index de72b14c6..9d58ad6e6 100644
--- a/dev-java/lucene/lucene-8.4.0.ebuild
+++ b/dev-java/lucene/lucene-8.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,7 +35,7 @@ CDEPEND="
dev-java/commons-logging:0
dev-java/commons-beanutils:1.7
dev-java/commons-codec:0
- dev-java/icu4j:52
+ dev-java/icu4j:70
dev-java/log4j:0
)"
@@ -124,7 +124,7 @@ src_prepare() {
if use modules; then
mkdir -p analysis/icu/lib
- java-pkg_jar-from --into analysis/icu/lib icu4j-52
+ java-pkg_jar-from --into analysis/icu/lib icu4j-70
# disable morfologik, dependency does not build
# disable opennlp, dependency does not exist
# disable phonetic, dependency does not exist
@@ -183,7 +183,7 @@ src_compile() {
commons-logging
commons-beanutils-1.7
commons-codec
- icu4j-52
+ icu4j-70
log4j
"
EANT_BUILD_TARGET+=" build-modules"