aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIsrael Hernandez <israel.a.hernandez@gmail.com>2023-07-23 13:04:41 -0700
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-17 19:03:07 +0200
commit3257f2bcd506046a2abeecf14a7c45512f13b101 (patch)
tree60ff6716d9c36c7b45acd384180c8471b1ad4b91 /dev-java
parentdev-java/scijava-optional: new package, add 1.0.1, 9999 (diff)
downloadsci-3257f2bcd506046a2abeecf14a7c45512f13b101.tar.gz
sci-3257f2bcd506046a2abeecf14a7c45512f13b101.tar.bz2
sci-3257f2bcd506046a2abeecf14a7c45512f13b101.zip
dev-java/scijava-table: new package, add 1.0.2, 9999
Signed-off-by: IAHMCOL <IAHMCOL@thejabberwocky.net> Closes: https://github.com/gentoo/sci/pull/1207 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/scijava-table/Manifest1
-rw-r--r--dev-java/scijava-table/metadata.xml11
-rw-r--r--dev-java/scijava-table/scijava-table-1.0.2.ebuild54
-rw-r--r--dev-java/scijava-table/scijava-table-9999.ebuild54
4 files changed, 120 insertions, 0 deletions
diff --git a/dev-java/scijava-table/Manifest b/dev-java/scijava-table/Manifest
new file mode 100644
index 000000000..ba3cb11b6
--- /dev/null
+++ b/dev-java/scijava-table/Manifest
@@ -0,0 +1 @@
+DIST scijava-table-1.0.2-sources.tar.gz 37037 BLAKE2B 61a6b2da5cb355e00feb49895ae1a9a978ba50ee75e60c4f74d1490d1c167ca3a19452621ba25afccc975f4fbf3636ae09c0d25019e04980c4247fc18d859951 SHA512 17bbb1f798f7ee718fd2fbd9f9c81419cb5054b40d82cac9fa3b9f882e9ba46b410979038d8031d6f6dea53902f0865e68d59e55e1b02ab717da40aed5726b70
diff --git a/dev-java/scijava-table/metadata.xml b/dev-java/scijava-table/metadata.xml
new file mode 100644
index 000000000..d86e34de2
--- /dev/null
+++ b/dev-java/scijava-table/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">scijava/scijava-table</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/scijava-table/scijava-table-1.0.2.ebuild b/dev-java/scijava-table/scijava-table-1.0.2.ebuild
new file mode 100644
index 000000000..c2e06ac37
--- /dev/null
+++ b/dev-java/scijava-table/scijava-table-1.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Table structures for SciJava."
+HOMEPAGE="https://github.com/scijava/scijava-table"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scijava/scijava-table.git"
+ S="${WORKDIR}/${P}"
+ MAVEN_ID="org.scijava:scijava-table:9999"
+else
+ SRC_URI="
+ https://github.com/scijava/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}-sources.tar.gz
+ "
+ S="${WORKDIR}/${PN}-${P}"
+ MAVEN_ID="org.scijava:scijava-table:1.0.3"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+CDEPEND="
+ >=dev-java/scijava-common-2.89.0:0
+ >=dev-java/scijava-optional-1.0.1:0
+"
+
+BDEPEND="
+ >=virtual/jdk-1.8:*
+ ${CDEPEND}
+ test? ( >=dev-java/junit-4.13.2:4 )
+"
+
+DEPEND="${CDEPEND}"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CDEPEND}
+"
+
+JAVA_GENTOO_CLASSPATH="scijava-common,scijava-optional"
+JAVA_SRC_DIR="src/main/java"
+JAVA_MAIN_CLASS=""
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
diff --git a/dev-java/scijava-table/scijava-table-9999.ebuild b/dev-java/scijava-table/scijava-table-9999.ebuild
new file mode 100644
index 000000000..c2e06ac37
--- /dev/null
+++ b/dev-java/scijava-table/scijava-table-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Table structures for SciJava."
+HOMEPAGE="https://github.com/scijava/scijava-table"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scijava/scijava-table.git"
+ S="${WORKDIR}/${P}"
+ MAVEN_ID="org.scijava:scijava-table:9999"
+else
+ SRC_URI="
+ https://github.com/scijava/${PN}/archive/refs/tags/${P}.tar.gz -> ${P}-sources.tar.gz
+ "
+ S="${WORKDIR}/${PN}-${P}"
+ MAVEN_ID="org.scijava:scijava-table:1.0.3"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+CDEPEND="
+ >=dev-java/scijava-common-2.89.0:0
+ >=dev-java/scijava-optional-1.0.1:0
+"
+
+BDEPEND="
+ >=virtual/jdk-1.8:*
+ ${CDEPEND}
+ test? ( >=dev-java/junit-4.13.2:4 )
+"
+
+DEPEND="${CDEPEND}"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CDEPEND}
+"
+
+JAVA_GENTOO_CLASSPATH="scijava-common,scijava-optional"
+JAVA_SRC_DIR="src/main/java"
+JAVA_MAIN_CLASS=""
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"