aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-22 11:42:35 +0100
committerJustin Lecher <jlec@gentoo.org>2013-02-22 11:42:35 +0100
commit15c554704658a3dcb3108bd39c20523d0d22f96a (patch)
treedfc0b647928b0a0a1ae78ade2724c545d7ed2111 /dev-ml/lacaml
parentRevert "Merge branch 'jlec' of github.com:gentoo-science/sci" (diff)
downloadsci-15c554704658a3dcb3108bd39c20523d0d22f96a.tar.gz
sci-15c554704658a3dcb3108bd39c20523d0d22f96a.tar.bz2
sci-15c554704658a3dcb3108bd39c20523d0d22f96a.zip
dev-ml/lacaml: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
Package-Manager: portage-2.2.0_alpha163
Diffstat (limited to 'dev-ml/lacaml')
-rw-r--r--dev-ml/lacaml/ChangeLog6
-rw-r--r--dev-ml/lacaml/lacaml-7.0.3.ebuild12
-rw-r--r--dev-ml/lacaml/metadata.xml4
3 files changed, 14 insertions, 8 deletions
diff --git a/dev-ml/lacaml/ChangeLog b/dev-ml/lacaml/ChangeLog
index d9eb022ae..d66dc0b54 100644
--- a/dev-ml/lacaml/ChangeLog
+++ b/dev-ml/lacaml/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-ml/lacaml
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 22 Feb 2013; Justin Lecher <jlec@gentoo.org> lacaml-7.0.3.ebuild,
+ metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
+
*lacaml-7.0.3 (28 Jul 2012)
28 Jul 2012; Guillaume Horel <guillaume.horel@gmail.com>
diff --git a/dev-ml/lacaml/lacaml-7.0.3.ebuild b/dev-ml/lacaml/lacaml-7.0.3.ebuild
index ad9fbd152..1b6d6f541 100644
--- a/dev-ml/lacaml/lacaml-7.0.3.ebuild
+++ b/dev-ml/lacaml/lacaml-7.0.3.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
OASIS_BUILD_DOCS=1
-inherit oasis
+
+inherit oasis toolchain-funcs
DESCRIPTION="BLAS/LAPACK interface for OCaml"
HOMEPAGE="http://forge.ocamlcore.org/projects/lacaml"
@@ -16,7 +17,8 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
-RDEPEND="virtual/blas
+RDEPEND="
+ virtual/blas
virtual/lapack"
DEPEND="${DEPEND}
virtual/pkgconfig"
@@ -27,10 +29,10 @@ src_prepare() {
if use doc; then
cp "${FILESDIR}/API.odocl" . || die
fi
- cclib="$(pkg-config --libs blas lapack)"
+ cclib="$($(tc-getPKG_CONFIG) --libs blas lapack)"
cclib="[$(echo $cclib|sed -e 's/\(-[a-z0-9]*\) /\"\1\"\;/g' -e \
's/\(-[a-z0-9]*\)$/\"\1\"/')]"
sed -i "s/cclib = \[\]/cclib = ${cclib}/" setup.conf
#would like to do the below, but doesn't work from ebuild
- #oasis_configure_opts="--override conf_cclib $(pkg-config --libs blas lapack)"
+ #oasis_configure_opts="--override conf_cclib $($(tc-getPKG_CONFIG) --libs blas lapack)"
}
diff --git a/dev-ml/lacaml/metadata.xml b/dev-ml/lacaml/metadata.xml
index 8925df672..e0b7a097d 100644
--- a/dev-ml/lacaml/metadata.xml
+++ b/dev-ml/lacaml/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang='en'>
+ <herd>sci</herd>
+ <longdescription lang="en">
BLAS/LAPACK-interface for OCaml
</longdescription>
</pkgmetadata>