aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-08-02 01:46:05 -0400
committerHorea Christian <chr@chymera.eu>2024-08-02 01:46:05 -0400
commit17646d78bb42d7626583a2df97722d36868eb5ff (patch)
tree7759a8c10132d1572eb7dc601671f0e3c4115c10 /dev-python
parentdev-python/annexremote: reordered variables (diff)
downloadsci-17646d78bb42d7626583a2df97722d36868eb5ff.tar.gz
sci-17646d78bb42d7626583a2df97722d36868eb5ff.tar.bz2
sci-17646d78bb42d7626583a2df97722d36868eb5ff.zip
dev-python/wraps: version and PYTHON_COMPAT bump
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wraps/Manifest1
-rw-r--r--dev-python/wraps/wraps-0.13.0.ebuild24
-rw-r--r--dev-python/wraps/wraps-0.2.0.ebuild2
3 files changed, 26 insertions, 1 deletions
diff --git a/dev-python/wraps/Manifest b/dev-python/wraps/Manifest
index 44510a1dd..a41862ec8 100644
--- a/dev-python/wraps/Manifest
+++ b/dev-python/wraps/Manifest
@@ -1 +1,2 @@
+DIST wraps-0.13.0.tar.gz 31074 BLAKE2B 96aee060660765de4efb15e0fc55bbbe7745acd8458781330105c448e85da6cc16b2ec94fbadb78a27690226f0b222bf3c476fde6a4e4d8c9a78fd11353d7abf SHA512 4858d8bb2ed0ac410c1d3997fac7c7e576feb888713dd3e1ddb26151c7ab6eea274997fe0df9d5661cc88f3fa553b83e4e01d9784f39f8b85ed5c9e8b9e13749
DIST wraps-0.2.0.tar.gz 25308 BLAKE2B b68359d34995f7bc39535e97458807a5d55e3547124ccb8b34f9cd34fe1d3b38921a3a0c16df031410022f74d414aba97af9e9f60a20fb635428030bc400b130 SHA512 daf72785c3215db06f4bf06704f02c7ecfd1ef5c58dbf5c50b2dee14755d73b519f8a13be9658bf825c296689d9b3effd08aec4254779812583c1024522751f0
diff --git a/dev-python/wraps/wraps-0.13.0.ebuild b/dev-python/wraps/wraps-0.13.0.ebuild
new file mode 100644
index 000000000..bed0a104e
--- /dev/null
+++ b/dev-python/wraps/wraps-0.13.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1 pypi
+
+DESCRIPTION=" Meaningful and safe wrapping types. "
+HOMEPAGE="https://github.com/nekitdev/wraps"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+# package does not have test suite (yet)
+
+RDEPEND="
+ >=dev-python/attrs-21.4.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.2.0[${PYTHON_USEDEP}]
+ "
+
+distutils_enable_tests pytest
diff --git a/dev-python/wraps/wraps-0.2.0.ebuild b/dev-python/wraps/wraps-0.2.0.ebuild
index b06b511cd..dd2a9b24f 100644
--- a/dev-python/wraps/wraps-0.2.0.ebuild
+++ b/dev-python/wraps/wraps-0.2.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
DESCRIPTION=" Meaningful and safe wrapping types. "