aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-05-06 09:21:08 -0400
committerHorea Christian <chr@chymera.eu>2024-05-06 09:21:08 -0400
commit1794b33cc30fe3b533a39db20f9704843f5827e1 (patch)
treef7c450b1d8e3ac33823cb3a02af47630c044d53c /dev-python
parentsci-physics/jaxodraw-bin: new package, add 2.1.0 (diff)
downloadsci-1794b33cc30fe3b533a39db20f9704843f5827e1.tar.gz
sci-1794b33cc30fe3b533a39db20f9704843f5827e1.tar.bz2
sci-1794b33cc30fe3b533a39db20f9704843f5827e1.zip
dev-python/linesep: new package, add 0.5.0
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/linesep/Manifest1
-rw-r--r--dev-python/linesep/files/linesep-0.5.0-nocov.patch12
-rw-r--r--dev-python/linesep/linesep-0.5.0.ebuild25
-rw-r--r--dev-python/linesep/metadata.xml16
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/linesep/Manifest b/dev-python/linesep/Manifest
new file mode 100644
index 000000000..99369e648
--- /dev/null
+++ b/dev-python/linesep/Manifest
@@ -0,0 +1 @@
+DIST linesep-0.5.0.tar.gz 23979 BLAKE2B 78413c41b5002c8d4edf28c97eb8867416710ed5164d872bce845debfd4d17ac6aa03d7f4a36ef3e22160f517913e1f57c2d99a1ef4963941001892211f0386f SHA512 fe91aea8f4f36e722edc025fbfc452488bcef9a8dfef85b36a446f33a5a0c079102538a0f141ec7474325d5948214082790c53a928d1b7453d7d1e56622714fb
diff --git a/dev-python/linesep/files/linesep-0.5.0-nocov.patch b/dev-python/linesep/files/linesep-0.5.0-nocov.patch
new file mode 100644
index 000000000..a27bbd4b8
--- /dev/null
+++ b/dev-python/linesep/files/linesep-0.5.0-nocov.patch
@@ -0,0 +1,12 @@
+diff --git a/tox.ini b/tox.ini
+index 4d45597..cdd9e18 100644
+--- a/tox.ini
++++ b/tox.ini
+@@ -31,7 +31,6 @@ commands =
+ mypy src test
+
+ [pytest]
+-addopts = --cov=linesep --no-cov-on-fail
+ asyncio_mode = strict
+ doctest_optionflags = IGNORE_EXCEPTION_DETAIL
+ filterwarnings = error
diff --git a/dev-python/linesep/linesep-0.5.0.ebuild b/dev-python/linesep/linesep-0.5.0.ebuild
new file mode 100644
index 000000000..148ff0883
--- /dev/null
+++ b/dev-python/linesep/linesep-0.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Handling lines with arbitrary separators"
+HOMEPAGE="https://github.com/jwodder/linesep"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-nocov.patch" )
+
+distutils_enable_tests pytest
diff --git a/dev-python/linesep/metadata.xml b/dev-python/linesep/metadata.xml
new file mode 100644
index 000000000..017856905
--- /dev/null
+++ b/dev-python/linesep/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jwodder/linesep</remote-id>
+ <remote-id type="pypi">linesep</remote-id>
+ </upstream>
+</pkgmetadata>