aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-16 00:09:09 -0500
committerHorea Christian <chr@chymera.eu>2023-01-16 00:09:09 -0500
commit506fab4d6c4017042543b388fce75a8673242d2e (patch)
treeda5e179b3c350c0539d23847da402aeb555d1123 /dev-vcs
parentprofiles: sci-biology/longstitch dep stack cleared (diff)
downloadsci-506fab4d6c4017042543b388fce75a8673242d2e.tar.gz
sci-506fab4d6c4017042543b388fce75a8673242d2e.tar.bz2
sci-506fab4d6c4017042543b388fce75a8673242d2e.zip
dev-vcs/dandi-cli: add 0.48.0
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/dandi-cli/Manifest1
-rw-r--r--dev-vcs/dandi-cli/dandi-cli-0.48.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-vcs/dandi-cli/Manifest b/dev-vcs/dandi-cli/Manifest
index d58fa0e76..74414a300 100644
--- a/dev-vcs/dandi-cli/Manifest
+++ b/dev-vcs/dandi-cli/Manifest
@@ -1,4 +1,5 @@
DIST dandi-0.45.1.tar.gz 321362 BLAKE2B d07296be6bd4237fea4aa83c0b087de45234157aa6aa457f8d44f56b514a4deca11226831182b84c19a72b398183b3b181beb3946c7f8cce2d842ac80f0b57e2 SHA512 07d97420651bbd82d8d4146322ff80873489bd49869834ace9986f1ddc1880be5ff6bd1d625d8b4607a90de8007aeba152e8161af05c25a804cb18c7a0c78e29
DIST dandi-0.46.6.tar.gz 218868 BLAKE2B 7900c153172aa9669d0eae6bc2293ef51d1640b2fdd4e40eb887b1aba555d61617f95fb76601f1e81aeb9e0a54901c711bfb3c95eb478853490b29a0c1ee20e7 SHA512 db04e261205be716d6a098fbb63760411d3869c692df78954b50b649228747e0c18a9a32d3a9b0a5f21f55432e6a6cadad2142ee99168d02f02cfe51bf7eef93
+DIST dandi-0.48.0.tar.gz 228206 BLAKE2B 5cef713220839751b873170223bead06effddedf4b0d98d7de134fb87d64a4cc49521dd26d6a90777d331e77649c271466af9e30fd2511d72a3e505b5a904fbe SHA512 2e6686169105299f39f66d32542ce0e2d9d9fd9035f306c537771218ef8ced9832e6ea7911259623112604d83675aa52322410078eb7d00b6f83ec77a2cbc2c6
DIST dandi-cli-0.38.0.gh.tar.gz 322974 BLAKE2B 5451eb922019e0b06de1181161d23fac21ddbd772fb9ff5b23e296eb5ccc54c44b6c6c62d5d8f25bf075e6c93136f1db4d3ab72d372dfa7a28c84fc03008e0f3 SHA512 a77d834dadbd532ce016425fe25324582a5d2c442b52087d5751770d99c84fa9532a08525ee75f40d45ccb5c50ed11b9fbe0c29a24c7d1b24c253d218538e054
DIST dandi-cli-0.39.4.gh.tar.gz 329268 BLAKE2B c34674570c3474dbc12a2f96c0877a84ca3cddbf8d04cb1bc7cc47e6d03bbf4103cf8f36d4267f59bfb5da2504300e14dc007a3f23a5d807bb92cece506fb7b7 SHA512 8ac4ae25eb9b09530a017ca2812a490c578157caeb0cca2737630f9796ec4559fc2379f150764544e1cd474cf481f87bb08dd255d4bf4dcc7722c8006ae78c4b
diff --git a/dev-vcs/dandi-cli/dandi-cli-0.48.0.ebuild b/dev-vcs/dandi-cli/dandi-cli-0.48.0.ebuild
new file mode 100644
index 000000000..f5e9d67cf
--- /dev/null
+++ b/dev-vcs/dandi-cli/dandi-cli-0.48.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..10} )
+
+inherit distutils-r1
+
+MY_PN="dandi"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="DANDI command line client to facilitate common operations"
+HOMEPAGE="https://github.com/dandi/dandi-cli"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test etelemetry"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-didyoumean[${PYTHON_USEDEP}]
+ =dev-python/dandi-schema-0.7*[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/fscacher[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/interleave[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/keyrings-alt[${PYTHON_USEDEP}]
+ dev-python/nwbinspector[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.9.0[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyout[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}]
+ dev-python/tenacity[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/zarr[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/anys[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ media-libs/opencv[ffmpeg,${PYTHON_USEDEP}]
+ )
+"
+# Upstream might be amenable to dropping opencv:
+# https://github.com/dandi/dandi-cli/issues/944
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if use etelemetry; then
+ default
+ else
+ eapply "${FILESDIR}/${PN}-0.28.0-no-etelemetry.patch"
+ default
+ sed -i "/etelemetry/d" setup.cfg
+ fi
+}
+
+python_test() {
+ export DANDI_TESTS_NONETWORK=1
+ epytest
+}