aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-01-02 21:06:44 +0100
committerHorea Christian <chr@chymera.eu>2021-01-03 14:20:43 -0500
commitebdb3033fce9c9ff51893291873aade713ef703e (patch)
tree9c16c3df574c87335e0d8fdcfffc489775c957d1 /net-misc
parentsci-libs/simpleitk: new package (diff)
downloadsci-ebdb3033fce9c9ff51893291873aade713ef703e.tar.gz
sci-ebdb3033fce9c9ff51893291873aade713ef703e.tar.bz2
sci-ebdb3033fce9c9ff51893291873aade713ef703e.zip
net-misc/cernbox-client: Bump version to 2.7.4.2934.
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/cernbox-client/Manifest2
-rw-r--r--net-misc/cernbox-client/cernbox-client-2.7.4.2934.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/net-misc/cernbox-client/Manifest b/net-misc/cernbox-client/Manifest
index 9ebdb08d0..1aff24cc3 100644
--- a/net-misc/cernbox-client/Manifest
+++ b/net-misc/cernbox-client/Manifest
@@ -1,2 +1,4 @@
DIST cernbox-client-2.5.4-2719.1.src.rpm 14672426 BLAKE2B 905db6f82f135a6f1012c7e1139313f546ca1556fbde48f803a1d67df0dc24f8841407c4a7e8b39bdc51dd5a264bc464e667b0404000699b7892bb8b9c8b4f56 SHA512 9c2ff9ed01e024ec70809e159fbba952b3cc00159228f9ef15ce78160c3133c86f96b6d6281ed76bc0dbb4e00587533cbae036864b79191f4e614c9b4daaa8c7
+DIST cernbox-client-2.7.1-2596.src.rpm 15434250 BLAKE2B 3ef3fcc4010b3f292aee9b6bba7b5f9a72e4fbca1236e1e85e6523cd4e38d980fe4542c5f019647a19040be64628159651630a61ee8894cb7bcf4b69d342ccd0 SHA512 e329b84fc7aa62068f934bf8a9f47432709094adc618274c1b8ddbf7331094cb71b6208d3a777150ee426141301e0279cb219d65b123335f2e198a9b87980e5d
+DIST ownCloud-2.7.4.2934.tar.xz 14151708 BLAKE2B ad6f3d827a2fdcead6fdc2514696e8fbdb75b2d365c9a09602b95b24c669695e3693167f5da305e27e6fb2266f106b50c578def1d1518730926a10f640defbd9 SHA512 7e04d987751d0b8e29fbe8ba8ae58f38fabd7f5007f7508d001532e595b00f58cce487b1d180928154286ffd6b01db1e6ca0407f7d675e8b101ec4ae8414f2a6
DIST owncloudclient-2.6.3.14058.tar.xz 21246672 BLAKE2B 15b75c2162d22c22827a057242d783e739837f618c2f65be3edce6b2678aaa13505fd14c4e4088374c240537a999d9aff7758ccb93993e0cbdebb886f735311c SHA512 e2159dc5668f263449e7a9a20ef10c6bb140ea5bd1128a6d3438abce03bc4913bb4eecbacc5160c8018398b6fa75ccfb2a9ab9ad637965e41caebc83994b80b3
diff --git a/net-misc/cernbox-client/cernbox-client-2.7.4.2934.ebuild b/net-misc/cernbox-client/cernbox-client-2.7.4.2934.ebuild
new file mode 100644
index 000000000..2eb01cf8e
--- /dev/null
+++ b/net-misc/cernbox-client/cernbox-client-2.7.4.2934.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake rpm xdg
+
+DESCRIPTION="Synchronize files from CERNBox EOS with your computer"
+
+# Origin is classic owncloud-client, branded for CERN during compilation.
+ORIGIN_PN="ownCloud"
+BRANDED_P="cernbox"
+BRANDED_PV="2.7.1"
+BRANDED_REL="2596"
+HOMEPAGE="https://cernbox.cern.ch/"
+SRC_URI="http://download.owncloud.com/desktop/${ORIGIN_PN}/stable/${PV}/source/${ORIGIN_PN}-${PV}.tar.xz
+ https://cernbox.cern.ch/cernbox/doc/Linux/repo/CentOS_7/src/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm
+ https://cern.ch/ofreyerm/gentoo/cernbox/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm"
+
+LICENSE="CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc dolphin gnome-keyring nautilus test"
+
+COMMON_DEPEND=">=dev-db/sqlite-3.4:3
+ dev-libs/qtkeychain[gnome-keyring?,qt5(+)]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-fs/inotify-tools
+ dolphin? (
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/kio:5
+ )
+ nautilus? ( dev-python/nautilus-python )"
+
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/linguist-tools:5
+ kde-frameworks/extra-cmake-modules
+ doc? (
+ dev-python/sphinx
+ dev-tex/latexmk
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )
+ test? (
+ dev-util/cmocka
+ dev-qt/qttest:5
+ )"
+
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${ORIGIN_PN}-${PV}
+
+src_unpack() {
+ rpm_src_unpack ${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm || die "failed to extract branding RPM"
+ mv ${PN%-*}-${BRANDED_PV}.${BRANDED_REL}/branding "${S}" || die "failed to extract branding"
+}
+
+src_prepare() {
+ # Keep tests in ${T}
+ sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die
+
+ if ! use nautilus; then
+ pushd shell_integration > /dev/null || die
+ cmake_comment_add_subdirectory nautilus
+ popd > /dev/null || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DCMAKE_DISABLE_FIND_PACKAGE_Sphinx=$(usex !doc)
+ -DBUILD_SHELL_INTEGRATION_DOLPHIN=$(usex dolphin)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if ! use doc ; then
+ elog "Documentation and man pages not installed"
+ elog "Enable doc USE-flag to generate them"
+ fi
+ xdg_pkg_postinst
+}