aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-27 12:31:57 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-09-27 12:35:09 +0000
commit5ea7859cdddb3f0d0af0cb95643de7542b3e641a (patch)
tree7dfc774b039670892a3ead615997c1d3c90cdcc5 /sci-astronomy
parentsci-libs/libsufr: version bump to 0.7.5 (diff)
downloadsci-5ea7859cdddb3f0d0af0cb95643de7542b3e641a.tar.gz
sci-5ea7859cdddb3f0d0af0cb95643de7542b3e641a.tar.bz2
sci-5ea7859cdddb3f0d0af0cb95643de7542b3e641a.zip
sci-astronomy/libthesky: version bump to 0.4.1
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/libthesky/Manifest2
-rw-r--r--sci-astronomy/libthesky/libthesky-0.4.1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-astronomy/libthesky/Manifest b/sci-astronomy/libthesky/Manifest
index 240414b04..577d73e65 100644
--- a/sci-astronomy/libthesky/Manifest
+++ b/sci-astronomy/libthesky/Manifest
@@ -1,2 +1,4 @@
DIST libthesky-0.3.2.tar.gz 124598 BLAKE2B a70db5dea8aa7ce478a5eb5ac3a837e2580b90c4ede2539059c57033e90eee56f453ea4efc811795bbbad5896190d8455315b41e3b5e147650f0f3c8e2263b1a SHA512 64fae18cf410c37d6bda5d65f8890a045734fa3bbaa23c76a8080ef06e15443af5159baf779b69594e24bb1fc8b0719ba03174764d46abed66f61750e8e9e68e
+DIST libthesky-0.4.1.tar.gz 214547 BLAKE2B 4f3c8dbda236cd86505e1aa307546e39f9e615341605bed0bf5980ff04b6506dd33be3d037fa2913d80ffe858b0d6ae6ad5c9284d1bce43aeb1d6d78d7c36177 SHA512 a8e46c325c8c13a53177ae482ace79fa5de8507d1b052df412df7735692c19712915f78ebd0ecd83c1a0ed9d9b9d99f6065ae3c313ec4842d2223b28558abcb1
DIST libthesky-data-20131020.tar.bz2 3945800 BLAKE2B 317556d3f045fb154f692caa37d40001713ae382810edec9843685868facc89e90d74a01c4169232ffe765536e2c4a0504dd94be4ff01699d76069bb43f7f18e SHA512 2bbc2eaeb37a52f383625ecbb0c8d455741631b8cf212e5b8839a9d4276ca8bfc638087aca6d94a458e2889e8e0b9a37cd0392828fe24fb1f653d5956c27b27d
+DIST libthesky-data-20160409.tar.bz2 3780265 BLAKE2B 9331156f7536d634f8523e776209190d73c10158800ff73694ac499292b2be80948810e6aaa531b51d878b5018f7304188b855fcbc976a1b1c285829555d2f4e SHA512 b790aa70b60c6c35db85a54de3487aa5ef47710121cb6c6c13069d4d8adba822b61449eb59ce7ec9203fb4d9cf33570222ec9a65b36ac21f5d4506cddd0b35a3
diff --git a/sci-astronomy/libthesky/libthesky-0.4.1.ebuild b/sci-astronomy/libthesky/libthesky-0.4.1.ebuild
new file mode 100644
index 000000000..8bb4600e8
--- /dev/null
+++ b/sci-astronomy/libthesky/libthesky-0.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE=Release
+inherit cmake fortran-2
+
+DESCRIPTION="Fortran library to compute positions of celestial bodies"
+HOMEPAGE="http://libthesky.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/libthesky-data-20160409.tar.bz2
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="~sci-libs/libsufr-0.7.5[static-libs?]"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+
+ gunzip -r "${S}"/man || die
+
+ mv "${WORKDIR}"/data "${S}" || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCREATE_SHAREDLIB=ON
+ -DCREATE_STATICLIB=$(usex static-libs)
+ )
+ cmake_src_configure
+}